forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
11 additions
and
22 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1 @@ | ||
DIST ppx_jane-113.33.00.tar.gz 51315 SHA256 46e5eaa6d6ed1900c2924d9e6256ab09f634ebf9769efd101073202913cb8b96 SHA512 89dc9351f3c1dd419d503c525b36e0e062bc09b7c3f6afe1a107d53c831cd72c63c6b1230a57a00d4db578168e9c3493189308f42661e69fa4703867eb82e219 WHIRLPOOL 3c4973281c06ada6441db6627e427bd4d03d2ba70f77f8efc70bcf88b078604be364d825392dc818f74e3d8a31e6a737f8e67532940455531d8d07aac26ae84a | ||
DIST ppx_jane-0.9.0.tar.gz 5831 SHA256 90b628dffeeecc9b023042d205f0c900fc05a0501ad768fe5e5fcd80e3a03970 SHA512 18b09c060519b94013c78ef4673ec7c26f465453391c6ad2ea3235b6f8e23208879c5d4e69dc01915cfb694b23171397af5e4b7208556a369d191c081c86fc2a WHIRLPOOL 6b36f3e7d4afe21f7a2d1e0bb05d11756f8ec091e473f6df929cdf9354afeff48404922afe7a17a9036a10a2430f0b37779b2951063f0ba679b97a72abdab364 |
31 changes: 10 additions & 21 deletions
31
dev-ml/ppx_jane/ppx_jane-113.33.00.ebuild → dev-ml/ppx_jane/ppx_jane-0.9.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,57 +1,46 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="5" | ||
|
||
inherit oasis | ||
EAPI=6 | ||
|
||
DESCRIPTION="Standard Jane Street ppx rewriters" | ||
HOMEPAGE="http://www.janestreet.com/ocaml" | ||
SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz" | ||
HOMEPAGE="https://github.com/janestreet/ppx_jane" | ||
SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0/${PV}" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
DEPEND="dev-ml/ppx_tools:= | ||
DEPEND=" | ||
dev-lang/ocaml:= | ||
dev-ml/ppx_assert:= | ||
dev-ml/ppx_base:= | ||
dev-ml/ppx_bench:= | ||
dev-ml/ppx_bin_prot:= | ||
dev-ml/ppx_compare:= | ||
dev-ml/ppx_custom_printf:= | ||
dev-ml/ppx_driver:= | ||
dev-ml/ppx_enumerate:= | ||
dev-ml/ppx_expect:= | ||
dev-ml/ppx_fail:= | ||
dev-ml/ppx_fields_conv:= | ||
dev-ml/ppx_here:= | ||
dev-ml/ppx_inline_test:= | ||
dev-ml/ppx_let:= | ||
dev-ml/ppx_optional:= | ||
dev-ml/ppx_pipebang:= | ||
dev-ml/ppx_sexp_conv:= | ||
dev-ml/ppx_sexp_message:= | ||
dev-ml/ppx_sexp_value:= | ||
dev-ml/ppx_typerep_conv:= | ||
dev-ml/ppx_variants_conv:= | ||
dev-ml/ocaml-migrate-parsetree:= | ||
" | ||
RDEPEND="${DEPEND}" | ||
DEPEND="${DEPEND} dev-ml/opam" | ||
|
||
src_configure() { | ||
emake setup.exe | ||
OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure | ||
} | ||
|
||
src_compile() { | ||
emake | ||
} | ||
DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder" | ||
|
||
src_install() { | ||
opam-installer -i \ | ||
--prefix="${ED}/usr" \ | ||
--libdir="${D}/$(ocamlc -where)" \ | ||
--docdir="${ED}/usr/share/doc/${PF}" \ | ||
${PN}.install || die | ||
dodoc README.md | ||
} |