forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-backup/borgbackup: version bump to 1.1.10
Signed-off-by: Anthony G. Basile <[email protected]> Package-Manager: Portage-2.3.62, Repoman-2.3.11
- Loading branch information
Showing
3 changed files
with
49 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST borgbackup-1.1.10.tar.gz 3610011 BLAKE2B 9c13d89a0441b5403019ed24b2f36fd55f4d133219b68802b79c76f5086324f4a249124a89c67049fecbadb78d5dae64b007ed6c53a579c115ce248db3e83054 SHA512 9315335208f10427e3105e10819817d15fd05171479252903bd51eaacb016bc3ff792d505b9203ce0b9b41ec350472bdb9a23b0128e7fe156aaa47c1608451c0 | ||
DIST borgbackup-1.1.8.tar.gz 3456058 BLAKE2B cad55216f92025418e1a427f4b578d6b7eafa03f6b3e9c4fccb148dd3856c4f6649928fb4227249c534add125f9b3a2a0b6ed808ae12c5e60a28f9df4fb0031a SHA512 1455e68bcedab8f35f9426dc73958c6a6565ad1f1cc274ce59d34a12e3a7bfa1d12fa2b8e8dd3e71824e1cd0927babf79f4e99d4e516454ed12dbd3970d0e921 | ||
DIST borgbackup-1.1.9.tar.gz 3468259 BLAKE2B 91c89304cf22328a0bd74583c22370343915209a204f52c65290dbec0cb688392c2e80b946a55317f8c58ef23099e710c16a34c6bfbbfb547a3e4b38c3c81c37 SHA512 466288258700fb0b3dae936c79fd423d26bea2d721dd70112b3cfd0f8e2bb335144a00de76743c31d336f6c19793775260d154326ec70d6d6d0a4e5ad6a59e59 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{5,6} ) | ||
|
||
inherit distutils-r1 | ||
|
||
if [[ ${PV} == "9999" ]] ; then | ||
EGIT_REPO_URI="https://github.com/${PN}/borg.git" | ||
inherit git-r3 | ||
else | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~x86" | ||
fi | ||
|
||
DESCRIPTION="Deduplicating backup program with compression and authenticated encryption" | ||
HOMEPAGE="https://borgbackup.readthedocs.io/" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
IUSE="libressl" | ||
|
||
# Unfortunately we have a file conflict with app-office/borg, bug #580402 | ||
RDEPEND=" | ||
!!app-office/borg | ||
app-arch/lz4 | ||
virtual/acl | ||
dev-python/llfuse[${PYTHON_USEDEP}] | ||
~dev-python/msgpack-0.5.6[${PYTHON_USEDEP}] | ||
dev-python/pyzmq[${PYTHON_USEDEP}] | ||
!libressl? ( dev-libs/openssl:0= ) | ||
libressl? ( dev-libs/libressl:0= ) | ||
" | ||
|
||
DEPEND=" | ||
dev-python/setuptools_scm[${PYTHON_USEDEP}] | ||
dev-python/cython[${PYTHON_USEDEP}] | ||
${RDEPEND} | ||
" | ||
|
||
python_prepare_all() { | ||
# allow use of new (renamed) msgpack | ||
sed -i "s|'msgpack-python.*',||g" setup.py || die | ||
distutils-r1_python_prepare_all | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters