Skip to content

Commit

Permalink
app-office/texmacs: fix build failure on 32-bit hosts, bug #652054
Browse files Browse the repository at this point in the history
C compiler compiles this code for bot int-based and size_t-based
guile. C++ compiler does not (and is what used by texmacs).

Closes: https://bugs.gentoo.org/652054
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
Sergei Trofimovich committed Apr 15, 2018
1 parent f3dcfbe commit dafbb15
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 0 deletions.
21 changes: 21 additions & 0 deletions app-office/texmacs/files/texmacs-1.99.6-guile-size_t.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
C compiler compiles this code for bot int-based and size_t-based
guile. C++ compiler does not (and is what used by texmacs).

https://bugs.gentoo.org/652054
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 37e9e87..5de2711 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -274,11 +274,11 @@ SET(CMAKE_REQUIRED_FLAGS "-Werror ${Guile_CFLAGS}")
SET(CMAKE_REQUIRED_INCLUDES ${Guile_INCLUDE_DIRS})
SET(CMAKE_REQUIRED_LIBRARIES ${Guile_LIBRARIES})

MESSAGE(STATUS "Checking the size_t of guile strings")

-CHECK_C_SOURCE_COMPILES( "#include <guile/gh.h>
+CHECK_CXX_SOURCE_COMPILES( "#include <guile/gh.h>
#include <libguile.h>
void print_string (SCM s) {
int len_r;
char* r= gh_scm2newstr (s, &len_r); } int main() { return 0; }
" _guile_str_size_test)
3 changes: 3 additions & 0 deletions app-office/texmacs/texmacs-1.99.6-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -51,6 +51,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.99-remove-new-declaration.patch

"${FILESDIR}"/${PN}-1.99.6-math_util.patch

# fix build failure on 32-bit systems, bug #652054
"${FILESDIR}"/${PN}-1.99.6-guile-size_t.patch
)

src_configure() {
Expand Down

0 comments on commit dafbb15

Please sign in to comment.