Skip to content

Commit

Permalink
gui-libs/wf-config: configuration manager for wayfire
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/713882

allows to parse wayfire configuration files and
reloads them on the fly

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Aisha Tammy <[email protected]>
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
epsilon-0 authored and FuzzyGophers committed May 17, 2020
1 parent 03ccd31 commit db22c91
Show file tree
Hide file tree
Showing 4 changed files with 111 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-libs/wf-config/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST wf-config-0.4.0.tar.xz 64108 BLAKE2B 83999dd246e6b7a6c54bbbcdf7abf08767b31bd29e75cd41d9844c4b98c66fbe787b7d87ec433e2c5e860e476f4f621116aac16c7f3f56903ee1689c5d1bc6c9 SHA512 30358ada695012b9f4be835f2b2d032e0d8d52c3e9d49d39ae975c74bc0cac188341e507124a088d8cdb3d62c77645a7d435262d15a6cc604b4738861362a299
18 changes: 18 additions & 0 deletions gui-libs/wf-config/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<longdescription>
Library for creating and parsing the configuration
file for the WayfireWM while also allowing you to
make changes in the configuration and reload them on
the fly.
</longdescription>
<maintainer type="person">
<email>[email protected]</email>
<name>Aisha Tammy</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>
46 changes: 46 additions & 0 deletions gui-libs/wf-config/wf-config-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="library for managing wayfire configuration files"
HOMEPAGE="https://github.com/WayfireWM/wf-config"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="debug"

DEPEND="
dev-libs/libevdev
dev-libs/libxml2
gui-libs/wlroots
media-libs/glm
"

RDEPEND="${DEPEND}"

BDEPEND="
${DEPEND}
dev-libs/wayland-protocols
virtual/pkgconfig
"

src_compile () {
local emesonargs=""
if use debug; then
emesonargs+=(
"-Db_sanitize=address,undefined"
)
fi
meson_src_compile
}
46 changes: 46 additions & 0 deletions gui-libs/wf-config/wf-config-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="library for managing wayfire configuration files"
HOMEPAGE="https://github.com/WayfireWM/wf-config"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="debug"

DEPEND="
dev-libs/libevdev
dev-libs/libxml2
gui-libs/wlroots
media-libs/glm
"

RDEPEND="${DEPEND}"

BDEPEND="
${DEPEND}
dev-libs/wayland-protocols
virtual/pkgconfig
"

src_compile () {
local emesonargs=""
if use debug; then
emesonargs+=(
"-Db_sanitize=address,undefined"
)
fi
meson_src_compile
}

0 comments on commit db22c91

Please sign in to comment.