Skip to content

Commit

Permalink
dev-python/promises: initial commit
Browse files Browse the repository at this point in the history
An implementation of Promises in Python.  See https://github.com/syrusakbary/promise.
  • Loading branch information
blueness committed Mar 2, 2018
1 parent fe86446 commit db33e08
Show file tree
Hide file tree
Showing 3 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/promises/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST promise-2.0.1.tar.gz 26274 BLAKE2B 528d938ab93790dc57545eb0064a014ea293d782ff6a7e6eeb2287f23c79c9cf9b2427ad57df524a888193c5aa9d62b21bd1e533d49ca4c8f2615d5719be58f9 SHA512 2bd9ad83a3b21dd4e3ae3052dfe6705790fb6ec925e9607960d43d9329fea606c82f6806599f09e6255ff5639c936369f88601668cf4ec8944747b1b6676693c
11 changes: 11 additions & 0 deletions dev-python/promises/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Anthony G. Basile</name>
</maintainer>
<upstream>
<remote-id type="github">syrusakbary/promise</remote-id>
</upstream>
</pkgmetadata>
41 changes: 41 additions & 0 deletions dev-python/promises/promises-2.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{5,6} )

inherit distutils-r1

MY_P=${PN%s}-${PV}

DESCRIPTION="An implementation of Promises in Python"
HOMEPAGE="https://github.com/syrusakbary/promise"
SRC_URI="https://github.com/syrusakbary/${PN%s}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"

S=${WORKDIR}/${MY_P}

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
dev-python/typing[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"

RESTRICT=test
# TODO: When we get all the dependencies in, we can add test
# test? (
# >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
# dev-python/pytest-cov[${PYTHON_USEDEP}]
# dev-python/coveralls[${PYTHON_USEDEP}]
# dev-python/futures[${PYTHON_USEDEP}]
# dev-python/pytest-benchmark[${PYTHON_USEDEP}]
# dev-python/mock[${PYTHON_USEDEP}]
# )

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"

0 comments on commit db33e08

Please sign in to comment.