Skip to content

Commit

Permalink
dev-dotnet/coco: new package; add 2014.12.24
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Sep 16, 2023
1 parent 327be7a commit db3627c
Show file tree
Hide file tree
Showing 4 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-dotnet/coco/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST coco-2014.12.24.tar.gz 37670 BLAKE2B acd2299e3452d4dac495a0a7f897694791b4abcc0dd7c243771fe8c7084cd9909110c655788844e11fbb576bd95e3596cb890c0ec930c3e4587fd3313082b5cb SHA512 d3b5af1b73b233a8c4b4572db8d65b1c1ffec36e455e4d5fadf1002125433551c833b9574ae03edbe2cd3978fedef41c85667fce82ff2d6ee155c16f778f970e
43 changes: 43 additions & 0 deletions dev-dotnet/coco/coco-2014.12.24.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DOTNET_PKG_COMPAT=6.0
unset NUGET_PACKAGES

inherit dotnet-pkg

DESCRIPTION="The compiler generator Coco/R for C#"
HOMEPAGE="https://github.com/boogie-org/coco/"

if [[ "${PV}" == *9999* ]] ; then
inherit git-r3

EGIT_REPO_URI="https://github.com/boogie-org/${PN}.git"
else
SRC_URI="https://github.com/boogie-org/${PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="GPL-2+"
SLOT="0"

DOTNET_PKG_PROJECTS=( "${S}/Coco.csproj" )
PATCHES=( "${FILESDIR}/${P}-Coco-csproj.patch" )

src_unpack() {
dotnet-pkg_src_unpack

if [[ -n ${EGIT_REPO_URI} ]] ; then
git-r3_src_unpack
fi
}

src_install() {
dotnet-pkg-base_install
dotnet-pkg-base_dolauncher "/usr/share/${P}/${PN^}" "${PN}"

einstalldocs
}
11 changes: 11 additions & 0 deletions dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/Coco.csproj
+++ b/Coco.csproj
@@ -13,7 +13,7 @@

<PropertyGroup>
<OutputType>Exe</OutputType>
- <TargetFrameworks>net6.0;net5.0;netcoreapp3.1</TargetFrameworks>
+ <TargetFrameworks>net6.0</TargetFrameworks>
<PackAsTool>true</PackAsTool>
<ToolCommandName>coco</ToolCommandName>
<GeneratePackageOnBuild>true</GeneratePackageOnBuild>
13 changes: 13 additions & 0 deletions dev-dotnet/coco/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">

<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Dotnet Project</name>
</maintainer>
<upstream>
<bugs-to>https://github.com/boogie-org/coco/issues/</bugs-to>
<remote-id type="github">boogie-org/coco</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit db3627c

Please sign in to comment.