forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-benchmarks/stress-ng: bump to version 0.11.02
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <[email protected]>
- Loading branch information
Showing
3 changed files
with
103 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST stress-ng-0.10.18.tar.xz 417592 BLAKE2B 806a6b1bdd49e5f0ab7f91f0b381b74c47df43e896ee2bbb1f7b8e78a9604443615fd13f331806e6fbaf360f9088a3e8c80d51deadd0dd56ffe92f821b8a3bb5 SHA512 ee2980c28479e50fed90a697e4cbd60732934b0488bb18733d7df8e3e04c32d5f0c5458d536f836a1f8160a60b9d2aa0d99bd2d2de03e1cc94d2c60a250c2daa | ||
DIST stress-ng-0.11.02.tar.xz 421596 BLAKE2B 3f6eb0d6a17cdbedf66c3efdbaec73760e6f6dfedb8fb1c59f759c31dd5d471c0687e0fe7d1f578c630b0a38499c3e7bf37799571dfdab3c6d47965dc39967d6 SHA512 115812728bc26af6ce32e78fa8008fe5fb8a08d8fbb5d82ac96b49572e4c451c0f4affdbad86ce15b5f77106d0e50bdd209eeae4c84fe0e0547161f2f3064140 |
64 changes: 64 additions & 0 deletions
64
app-benchmarks/stress-ng/files/stress-ng-0.11.02-makefile.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
Always respect users CFLAGS, enable verbose output when compiling | ||
and don't install compressed man pages. | ||
|
||
--- a/Makefile | ||
+++ b/Makefile | ||
@@ -21,7 +21,7 @@ | ||
# Codename "synthetic system strainer" | ||
# | ||
|
||
-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99 | ||
+CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -std=gnu99 | ||
|
||
# | ||
# Pedantic flags | ||
@@ -357,12 +357,10 @@ | ||
.o: stress-ng.h Makefile | ||
|
||
.c.o: stress-ng.h Makefile $(SRC) | ||
- @echo "CC $<" | ||
- @$(CC) $(CFLAGS) -c -o $@ $< | ||
+ $(CC) $(CFLAGS) -c -o $@ $< | ||
|
||
stress-ng: $(OBJS) | ||
- @echo "LD $@" | ||
- @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@ | ||
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@ | ||
@sync | ||
|
||
makeconfig: | ||
@@ -383,7 +381,7 @@ | ||
sed '$$ s/.$$//' >> apparmor-data.c | ||
@echo "};" >> apparmor-data.c | ||
@echo "const size_t g_apparmor_data_len = sizeof(g_apparmor_data);" >> apparmor-data.c | ||
- @echo "CC $<" | ||
+ echo "CC $<" | ||
@$(CC) -c apparmor-data.c -o apparmor-data.o | ||
@rm -rf apparmor-data.c apparmor-data.bin | ||
|
||
@@ -399,12 +397,12 @@ | ||
core-perf.o: core-perf.c core-perf-event.c | ||
@$(CC) $(CFLAGS) -E core-perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | \ | ||
awk {'print "#define _SNG_" $$1 " (1)"'} > core-perf-event.h | ||
- @echo CC $< | ||
- @$(CC) $(CFLAGS) -c -o $@ $< | ||
+ echo CC $< | ||
+ $(CC) $(CFLAGS) -c -o $@ $< | ||
|
||
stress-vecmath.o: stress-vecmath.c | ||
- @echo CC $< | ||
- @$(CC) $(CFLAGS) -fno-builtin -c -o $@ $< | ||
+ echo CC $< | ||
+ $(CC) $(CFLAGS) -fno-builtin -c -o $@ $< | ||
@touch stress-ng.c | ||
|
||
$(OBJS): stress-ng.h Makefile | ||
@@ -453,7 +451,7 @@ | ||
mkdir -p ${DESTDIR}${BINDIR} | ||
cp stress-ng ${DESTDIR}${BINDIR} | ||
mkdir -p ${DESTDIR}${MANDIR} | ||
- cp stress-ng.1.gz ${DESTDIR}${MANDIR} | ||
+ cp stress-ng.1 ${DESTDIR}${MANDIR} | ||
mkdir -p ${DESTDIR}${JOBDIR} | ||
cp -rp example-jobs/*.job ${DESTDIR}${JOBDIR} | ||
mkdir -p ${DESTDIR}${BASHDIR} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit toolchain-funcs | ||
|
||
DESCRIPTION="Stress test for a computer system with various selectable ways" | ||
HOMEPAGE="https://kernel.ubuntu.com/~cking/stress-ng/" | ||
SRC_URI="https://kernel.ubuntu.com/~cking/tarballs/${PN}/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
|
||
DEPEND=" | ||
dev-libs/libaio | ||
dev-libs/libbsd | ||
dev-libs/libgcrypt:0= | ||
net-misc/lksctp-tools | ||
sys-apps/attr | ||
sys-apps/keyutils:= | ||
sys-libs/libapparmor | ||
sys-libs/libcap | ||
sys-libs/zlib | ||
" | ||
|
||
RDEPEND="${DEPEND}" | ||
|
||
DOCS=( "README" "README.Android" "TODO" "syscalls.txt" ) | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-0.11.02-makefile.patch" ) | ||
|
||
src_compile() { | ||
tc-export CC | ||
|
||
default | ||
} |