forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge github#931: dev-perl/MongoDB: version bump to v1.2.2
This PR introduces MongoDB v1.2.2 to the tree along with a couple of minor bumps here and there to get MongoDB to work. Pull-Request: gentoo#931 Reporter: Kent Fredric <[email protected]> Acked-by: Patrice Clement <[email protected]> Signed-off-by: Patrice Clement <[email protected]>
- Loading branch information
Showing
13 changed files
with
267 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
From b03f13d762d577a3f4774c0ed64b8d376c74da9a Mon Sep 17 00:00:00 2001 | ||
From: Nigel Gregoire <[email protected]> | ||
Date: Mon, 11 Jan 2016 12:00:06 -0800 | ||
Subject: [PATCH] Fix locale test for newer DateTime::Locale | ||
|
||
As of v1.00, DateTime::Locale uses "en-US-POSIX" instead of "C". | ||
--- | ||
t/02_main.t | 6 +++++- | ||
1 file changed, 5 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/t/02_main.t b/t/02_main.t | ||
index 18bd8d1..6c2b371 100644 | ||
--- a/t/02_main.t | ||
+++ b/t/02_main.t | ||
@@ -10,6 +10,7 @@ BEGIN { | ||
|
||
use Test::More tests => 31; | ||
use DateTime::Tiny; | ||
+use version 0.77; | ||
|
||
|
||
|
||
@@ -76,7 +77,10 @@ SKIP: { | ||
# Expand to a DateTime | ||
my $dt = $date->DateTime; | ||
isa_ok( $dt, 'DateTime' ); | ||
- is( $dt->locale->id, 'C', '->locate ok' ); | ||
+ # DateTime::Locale version 1.00 changes "C" to "en-US-POSIX". | ||
+ my $expected = version->parse($DateTime::Locale::VERSION) < version->parse("1.00") | ||
+ ? "C" : "en-US-POSIX"; | ||
+ is( $dt->locale->id, $expected, '->locale ok' ); | ||
is( $dt->time_zone->name, 'floating', '->timezone ok' ); | ||
|
||
# Compare accessor results |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST MongoDB-0.701.4.tar.gz 1465098 SHA256 1cb5e77449aab787abdb69df2dd98a721e243ca80500b88815090f44e9320813 SHA512 329da2bddecf33bb02fc04e3e2d62d7c3ca106fdcba01a2b604d3e5319ca57a03a20229764245e152d5dc6aa2e187459ae7fa96b564a975461c56545e71267c9 WHIRLPOOL c9547405da0896dbbadc803603b40138c7d4d72ed9df88bfbdb108038c9c61b4b1539c3fe4f93742e791d519a16ea836b192b8108c8b1419a96d4b841d665ec7 | ||
DIST MongoDB-v0.708.0.0.tar.gz 1625892 SHA256 ec7d9a3d5b50b99a7249ee3744cf9ce0ec587e5664dfaed6db33001c5acc7f20 SHA512 1bc623d45e885953d51fcefda8efe2e1fa20b507ef3fda77dac40aa3009f7bd0290c75413dc9ef1f026776dbb1c06b77950842bc2d05d310aad694403130be72 WHIRLPOOL 392ca5dfaef7fedc545b89f578caecfd3e57e69beb041d088aafe4dcd4ea7417106415b5ca23948223b97ded35f284f910496c2b2010db85cabf9f60b8c76812 | ||
DIST MongoDB-v0.708.3.0.tar.gz 1627550 SHA256 03c4b885f327de7a8c0d9f449306d849d43e7fea4a6331da8a970710934378f0 SHA512 01bd174504cfb172f9ba179a97dffa4d3c1acbeee93ecb4d6a898928c9a6139f8199baa764eb6cdfcf121fd278b0eff899d774e1549a46c3bc5af7d9534f75f1 WHIRLPOOL 6b259e8391dcb883160eff7de0d9ad6c06479dfe7a3285251d9e2d954d2b1bd75c40b649cefe897bcda0cf38a2712c70e7f6297686426a5be30edea33b5d2604 | ||
DIST MongoDB-v1.2.2.tar.gz 1735147 SHA256 ed57c87c649f77cb41e122cd610111b136651e5d3b21b51d953b1fcbe79013e7 SHA512 49687c6e2d283709a2745293a00db37f16261868e47bc228926325526834c8988bd931c6befbb8c35578d63f0699dff94ed6e0e1a65ae533ebc2ca04e4de7f27 WHIRLPOOL 50e825b2d40eef73a0613f139adf6bec4b399fcb9b2fc19801c1ad2c7739c9884f3eb2d494957ec72f7de3a5eae84df6e4c32a422fb93df08489ae58af40180f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
DIST_AUTHOR=MONGODB | ||
DIST_VERSION="v${PV}" | ||
|
||
inherit perl-module | ||
|
||
DESCRIPTION="Official MongoDB Driver for Perl" | ||
SLOT="0" | ||
|
||
KEYWORDS="~amd64" | ||
|
||
LICENSE="Apache-2.0" | ||
IUSE="test minimal" | ||
|
||
# IO::Socket::SSL was escallated from suggested to recommended | ||
RDEPEND=" | ||
!minimal? ( | ||
>=virtual/perl-IO-Socket-IP-0.250.0 | ||
>=dev-perl/IO-Socket-SSL-1.560.0 | ||
>=dev-perl/Mozilla-CA-20130114 | ||
>=dev-perl/Net-SSLeay-1.490.0 | ||
) | ||
>=dev-perl/Authen-SCRAM-0.3.0 | ||
virtual/perl-Carp | ||
dev-perl/Class-XSAccessor | ||
>=dev-perl/DateTime-0.780.0 | ||
virtual/perl-Digest-MD5 | ||
virtual/perl-Encode | ||
>=virtual/perl-Exporter-5.570.0 | ||
virtual/perl-IO | ||
>=virtual/perl-JSON-PP-2.273.0 | ||
virtual/perl-MIME-Base64 | ||
>=dev-perl/Moo-2 | ||
dev-perl/Safe-Isa | ||
virtual/perl-Scalar-List-Utils | ||
virtual/perl-Socket | ||
dev-perl/Tie-IxHash | ||
virtual/perl-Time-HiRes | ||
dev-perl/Try-Tiny | ||
dev-perl/Type-Tiny-XS | ||
virtual/perl-XSLoader | ||
>=dev-perl/boolean-0.250.0 | ||
virtual/perl-if | ||
dev-perl/namespace-clean | ||
virtual/perl-version | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-perl/Config-AutoConf-0.220.0 | ||
virtual/perl-ExtUtils-MakeMaker | ||
>=dev-perl/Path-Tiny-0.52.0 | ||
test? ( | ||
!minimal? ( | ||
>=virtual/perl-CPAN-Meta-2.120.900 | ||
>=dev-perl/DateTime-Tiny-1.0.0 | ||
>=virtual/perl-Test-Harness-3.310.0 | ||
>=dev-perl/Time-Moment-0.220.0 | ||
) | ||
virtual/perl-Data-Dumper | ||
virtual/perl-File-Spec | ||
virtual/perl-File-Temp | ||
dev-perl/JSON-MaybeXS | ||
virtual/perl-Math-BigInt | ||
>=dev-perl/Path-Tiny-0.54.0 | ||
>=dev-perl/Test-Deep-0.111.0 | ||
dev-perl/Test-Fatal | ||
>=virtual/perl-Test-Simple-0.960.0 | ||
virtual/perl-bignum | ||
virtual/perl-threads-shared | ||
) | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST Test-Number-Delta-1.03.tar.gz 18586 SHA256 9cd18d89bde4333f9f9b77668ef03e6e20d8ee5675c2ab1b216c7323419a320e SHA512 03a859c9f497a0a591a1790383987fab969401d5b508abbdce810fca442f74c2e46967acc53607422b473923ef96e0f4b01846a38ad44fb782d4fd4d63fc6d02 WHIRLPOOL 918e7e48e31fcb6e5f53af32e12b5353adac04c663b7fe51a18714337da2ef390f9a5b3d098627a2cbfaee643201c89b101421431a663a9f4e13e1c0efd24d14 | ||
DIST Test-Number-Delta-1.04.tar.gz 18773 SHA256 883fd8a4a71e867f3bb30879f4c2d91e75610a7bb9822370743be377c3de4dbd SHA512 ae0eea95b3d671eac8efef7d9e65335111fc6403921172ed96c597269d56d7e7137ed65f80c896f08c16c6fafe1bd99d7f7d0c99fa0f50d8f659d9e749f9dfbc WHIRLPOOL cd0774b9dc2b9379046691397b25afd938982602fa29f78bbdf62f9c55a47c28827f3b5f1d622e584908a8c08a9fbd0e6d7e059238dec524f6de97f9a49507d1 | ||
DIST Test-Number-Delta-1.06.tar.gz 21077 SHA256 535430919e6fdf6ce55ff76e9892afccba3b7d4160db45f3ac43b0f92ffcd049 SHA512 87d64aad1ffc180ac9105d8f80aa1086ae9f6d11d7fead6f77daca6b0440320ed49dc628bed88b67836c091116fa43402b4a902e8319997fbad7a0fa19edfd79 WHIRLPOOL f5b165549f6d2cb470a633178d76f737d6558725f268774ca8946f87f6cce609e3e793727916e4ba3f03fc3837989f5e3b9c7934ac33a8449d6568e2070c5ac3 |
32 changes: 32 additions & 0 deletions
32
dev-perl/Test-Number-Delta/Test-Number-Delta-1.60.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=DAGOLDEN | ||
DIST_VERSION=1.06 | ||
inherit perl-module | ||
|
||
DESCRIPTION="Compare the difference between numbers against a given tolerance" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos" | ||
|
||
IUSE="test minimal" | ||
RDEPEND=" | ||
virtual/perl-Carp | ||
virtual/perl-Exporter | ||
virtual/perl-Test-Simple | ||
" | ||
DEPEND=" | ||
>=virtual/perl-ExtUtils-MakeMaker-6.170.0 | ||
test? ( | ||
!minimal? ( | ||
>=virtual/perl-CPAN-Meta-2.120.900 | ||
) | ||
virtual/perl-File-Spec | ||
>=virtual/perl-Test-Simple-0.960.0 | ||
) | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST Time-Moment-0.38.tar.gz 150867 SHA256 0a8e3d77676f66095c15d63395cacf7dc283eccf1844ad3b718f4e18d9db74a1 SHA512 e287b66cf6dc902bd3748753246ff554a4f512cdfa41e84ac6dc1d6853d2ec37cf9a4de476914cee4582f2a2121fc14fc6d71e98efa6d8a4f0600aff883571aa WHIRLPOOL 7c151d3d6d10c5aaf335baa5581b6eea275072781d1ace9472da51553ac3d7d1479f2f2815920aa03d5b798bb45f119089156edb5602102fa32493e8a832ef39 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=CHANSEN | ||
DIST_VERSION=0.38 | ||
inherit perl-module | ||
|
||
DESCRIPTION="Represents a date and time of day with an offset from UTC" | ||
|
||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${DIST_VERSION}-makefilepl.patch" | ||
) | ||
RDEPEND=" | ||
virtual/perl-Carp | ||
virtual/perl-Time-HiRes | ||
>=virtual/perl-XSLoader-0.20.0 | ||
" | ||
DEPEND="${RDEPEND} | ||
>=virtual/perl-ExtUtils-MakeMaker-6.590.0 | ||
>=virtual/perl-ExtUtils-ParseXS-3.180.0 | ||
test? ( | ||
>=dev-perl/Test-Fatal-0.6.0 | ||
>=dev-perl/Test-Number-Delta-1.60.0 | ||
dev-perl/Test-Requires | ||
>=virtual/perl-Test-Simple-0.880.0 | ||
) | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
diff -Naur Time-Moment-0.38/Makefile.PL Time-Moment-0.38b/Makefile.PL | ||
--- Time-Moment-0.38/Makefile.PL 2015-10-09 11:44:58.000000000 +0000 | ||
+++ Time-Moment-0.38b/Makefile.PL 2016-02-28 10:29:46.187136188 +0000 | ||
@@ -3,27 +3,10 @@ | ||
|
||
BEGIN { | ||
unshift @INC, 'inc'; | ||
- | ||
- my @required = ( | ||
- 'inc::Module::Install' => '1.00', | ||
- 'Module::Install::XSUtil' => '0.36', | ||
- 'Module::Install::ReadmeFromPod' => '0', | ||
- ); | ||
- | ||
- my @missing; | ||
- while(my($module, $version) = splice(@required, 0, 2)) { | ||
- eval qq{use $module $version (); 1} | ||
- or push @missing, $module; | ||
- } | ||
- | ||
- if(@missing) { | ||
- print qq{# The following modules are not available.\n}; | ||
- print qq{# `perl $0 | cpanm` will install them:\n}; | ||
- s/\A inc:: //x for @missing; | ||
- print $_, "\n" for @missing; | ||
- exit 1; | ||
- } | ||
} | ||
+use inc::Module::Install 1.00 (); | ||
+use Module::Install::XSUtil 0.36 (); | ||
+use Module::Install::ReadmeFromPod 0 (); | ||
|
||
use inc::Module::Install; | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Gentoo Perl Project</name> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="cpan">Time-Moment</remote-id> | ||
<remote-id type="cpan-module">Time::Moment</remote-id> | ||
<remote-id type="cpan-module">Time::Moment::Adjusters</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST Type-Tiny-XS-0.012.tar.gz 77259 SHA256 a93ed33fd21646548ab5cdb0de647cc574ad3e41b414af7980526e8612cacb16 SHA512 488925d913872f1f5bf73d8b165b1e04bd8f86bda44d594819120760f79c877d4b1be9f2924712ceabaead8822710bd8851f8ff5bb79f91b07fa253ce9ef7a33 WHIRLPOOL 6626ea7a596fe033fc97fd5d23d83ff1686dd24719872188a7d260f2af90f757848f54455bfa894662fd916e98414bf1f121bb0932c8661ee6462299f5b5fb43 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=TOBYINK | ||
DIST_VERSION=0.012 | ||
inherit perl-module | ||
|
||
DESCRIPTION="provides an XS boost for some of Type::Tiny's built-in type constraints" | ||
|
||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test minimal" | ||
|
||
RDEPEND=" | ||
!minimal? ( dev-perl/Type-Tiny ) | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
>=virtual/perl-ExtUtils-MakeMaker-6.170.0 | ||
test? ( | ||
>=virtual/perl-Test-Simple-0.920.0 | ||
) | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Gentoo Perl Project</name> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="cpan">Type-Tiny-XS</remote-id> | ||
<remote-id type="cpan-module">Type::Tiny::XS</remote-id> | ||
<remote-id type="cpan-module">Type::Tiny::XS::Util</remote-id> | ||
</upstream> | ||
</pkgmetadata> |