Skip to content

Commit

Permalink
app-i18n/ibus-qt: update patches
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
hattya committed Aug 5, 2017
1 parent abe619b commit db9c6e1
Show file tree
Hide file tree
Showing 7 changed files with 36 additions and 40 deletions.
4 changes: 2 additions & 2 deletions app-i18n/ibus-qt/files/ibus-qt-1.2.0.20091217-doc.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- ibus-qt-1.2.0.20091217-Source.orig/CMakeLists.txt 2009-12-17 14:50:00.000000000 +0900
+++ ibus-qt-1.2.0.20091217-Source/CMakeLists.txt 2010-01-03 09:11:53.000000000 +0900
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,7 +76,7 @@
# pkg_check_modules(IBUS REQUIRED ibus-1.0>=1.2.0)

Expand Down
22 changes: 8 additions & 14 deletions app-i18n/ibus-qt/files/ibus-qt-1.3.1-display-unset.patch
Original file line number Diff line number Diff line change
@@ -1,15 +1,12 @@
From d2a4e30fdb92aeaf476dcaaf2b5d6f8275d6af70 Mon Sep 17 00:00:00 2001
From: Peter Wu <[email protected]>
Date: Tue, 4 Sep 2012 19:40:08 +0200
Subject: [PATCH] Do not crash on missing/invalid DISPLAY envvar.
commit d2a4e30fdb92aeaf476dcaaf2b5d6f8275d6af70
Author: Peter Wu <[email protected]>
Date: Tue Sep 4 19:40:08 2012 +0200

- Check whether the passed DISPLAY environment variable contains ":".
Do not crash on missing/invalid DISPLAY envvar.

- Fallback to "-display" parameter passed to QApplication.
---
src/CMakeLists.txt | 2 ++
src/qibusbus.cpp | 23 ++++++++++++++++-------
2 files changed, 18 insertions(+), 7 deletions(-)
- Check whether the passed DISPLAY environment variable contains ":".

- Fallback to "-display" parameter passed to QApplication.

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2ad5588..8866ac0 100644
Expand Down Expand Up @@ -41,7 +38,7 @@ index 6a45d65..ed8248a 100644

namespace IBus {
/**
@@ -121,15 +122,23 @@
@@ -121,15 +122,23 @@ QString
Bus::getSocketPath (void)
{
QString display = getenv ("DISPLAY");
Expand Down Expand Up @@ -71,6 +68,3 @@ index 6a45d65..ed8248a 100644

QString path =
QDir::homePath() +
--
1.7.10

11 changes: 9 additions & 2 deletions app-i18n/ibus-qt/files/ibus-qt-1.3.1-gold.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,12 @@
src/CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
commit 0f3b716934f5e5e2b8a72140f875a6e598b28750
Author: fujiwarat <[email protected]>
Date: Thu Dec 13 07:10:19 2012 +0900

Fix an undefined reference to 'XDisplayString'

BUG=http://code.google.com/p/ibus/issues/detail?id=1560

Review URL: https://codereview.appspot.com/6923057

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8866ac0..f419141 100644
Expand Down
23 changes: 9 additions & 14 deletions app-i18n/ibus-qt/files/ibus-qt-1.3.1-qvariant.patch
Original file line number Diff line number Diff line change
@@ -1,21 +1,19 @@
From 40e119bd5577fc383990ad02b175ec64292f764b Mon Sep 17 00:00:00 2001
From: Jekyll Wu <[email protected]>
Date: Tue, 16 Oct 2012 11:24:06 +0900
Subject: [PATCH] Fix a non-const lvalue build error with clang-3.1
commit 40e119bd5577fc383990ad02b175ec64292f764b
Author: Jekyll Wu <[email protected]>
Date: Tue Oct 16 11:24:06 2012 +0900

BUG=http://code.google.com/p/ibus/issues/detail?id=1506
Fix a non-const lvalue build error with clang-3.1

Review URL: https://codereview.appspot.com/6697048
Patch from Jekyll Wu <[email protected]>.
---
src/qibusserializable.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
BUG=http://code.google.com/p/ibus/issues/detail?id=1506

Review URL: https://codereview.appspot.com/6697048
Patch from Jekyll Wu <[email protected]>.

diff --git a/src/qibusserializable.h b/src/qibusserializable.h
index 594d973..92a32ed 100644
--- a/src/qibusserializable.h
+++ b/src/qibusserializable.h
@@ -91,7 +91,7 @@ class Serializable : public Object
@@ -91,7 +91,7 @@ private:

template<typename T>
QVariant &
Expand All @@ -24,6 +22,3 @@ index 594d973..92a32ed 100644
{
QDBusArgument argument;

--
1.8.1.5

Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- CMakeLists.txt.old 2014-08-04 15:26:19.636569061 +0200
+++ CMakeLists.txt 2014-08-04 15:26:54.637618456 +0200
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,7 +77,7 @@
pkg_check_modules(IBUS REQUIRED ibus-1.0>=1.3.7)

Expand Down
8 changes: 4 additions & 4 deletions app-i18n/ibus-qt/ibus-qt-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
Expand Down Expand Up @@ -37,9 +37,9 @@ src_configure() {

src_prepare() {
epatch "${FILESDIR}/${PN}-1.2.0.20091217-doc.patch" \
"${FILESDIR}"/${PN}-1.3.1-display-unset.patch \
"${FILESDIR}"/${PN}-1.3.1-gold.patch \
"${FILESDIR}"/${PN}-1.3.1-qvariant.patch
"${FILESDIR}"/${P}-display-unset.patch \
"${FILESDIR}"/${P}-gold.patch \
"${FILESDIR}"/${P}-qvariant.patch
}

src_compile() {
Expand Down
4 changes: 2 additions & 2 deletions app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
Expand Down Expand Up @@ -26,7 +26,7 @@ DEPEND="${RDEPEND}

DOCS="AUTHORS README TODO"

PATCHES=( "${FILESDIR}"/${PN}-1.3-doc.patch )
PATCHES=( "${FILESDIR}"/${PN}-doc.patch )

src_configure() {
local mycmakeargs=( -DLIBDIR=$(get_libdir) all )
Expand Down

0 comments on commit db9c6e1

Please sign in to comment.