Skip to content

Commit

Permalink
sys-fs/eudev: version bump to 3.2.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
blueness committed Sep 3, 2017
1 parent 9bcb716 commit db9dffe
Show file tree
Hide file tree
Showing 2 changed files with 241 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/eudev/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST eudev-1.9.tar.gz 1762520 SHA256 8f17e92f1177ce9352bde00360e227a7cbb3b97ac88
DIST eudev-3.1.2.tar.gz 1858004 SHA256 4393b69e93dd8117defde6519b199d479f9d051f52061157a1a7a41b8fe10273 SHA512 d9aeb37a163ce4a0c116f75a927b4b99f8445d06624fbb3c28ade18f3effd8c54af5a4a52477c31a0452822a3dc0901468263195256e9dbf79d2ef08cf46f2b6 WHIRLPOOL 2249128672d2adfa968c123a2538063331348bc8e8481ad9c25bf8d9fb4d2d3c8a05417439f155d9ababe657b19a595c18c6ba60ad0d5584a8ead86220b39577
DIST eudev-3.1.5.tar.gz 1745524 SHA256 f75885a430cd50fe4b31732f808ba7f9b2adf0f26b53b8ba2957b0c1d84b6f2a SHA512 c5192e085ca4230aaac918e701989b712e5bda1558db31eb6ba635c17c4bdff398458d51cefbc5fb77a7c775ec1e04b1dbe019b8314cac3f43a5c1ae61521b5e WHIRLPOOL bc845c474101635c039515489e1316053156d3dd5f9c915c312324b9a1a6168f831e7476eeff834487fc83289e5d5eea2ba764c10bb6628b7c18d188de5f3846
DIST eudev-3.2.2.tar.gz 1821812 SHA256 3e4c56ec2fc1854afd0a31f3affa48f922c62d40ee12a0c1a4b4f152ef5b0f63 SHA512 38465ba6a68c3a8756d750ac36dfde0e220c3b13d058a8fcb664ee628e95d2f83b4155cb080a7bd518a5435c7c502aa3fa785a99233ebb24dda406441a753f7a WHIRLPOOL bcebd850c5c9b0ffea21bbb3517feb15f2328f602366daa2fd13b62ce62b0834815b98618fbe80bbe9db9d27085a6ef917c4b1e597f6ad47182acf7386786bbb
DIST eudev-3.2.3.tar.gz 1856424 SHA256 49200c54f63bb0ae922880a9bb64f360959fa83d272239b9cf72111dd53f444a SHA512 7c3409ba48da187df005e30078b2ebf3cef771ec1a6d39c10e4a670f3c945edb1952216dadcbc2585fdf9a24a08d88eca7cd0670c3f612c4c2401d0fe0545d42 WHIRLPOOL 8cf2217425fc1c8b1ab12d8ef07fa588ae6af4d28711553e8c3777093067eb4f33c8f7a09b4094727f8059d33a3f8ce30e314ac9c602712867fa21e0411b365f
240 changes: 240 additions & 0 deletions sys-fs/eudev/eudev-3.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,240 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

KV_min=2.6.39

inherit autotools linux-info multilib multilib-minimal user

if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/gentoo/eudev.git"
inherit git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi

DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
HOMEPAGE="https://github.com/gentoo/eudev"

LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"

COMMON_DEPEND=">=sys-apps/util-linux-2.20
introspection? ( >=dev-libs/gobject-introspection-1.38 )
kmod? ( >=sys-apps/kmod-16 )
selinux? ( >=sys-libs/libselinux-2.1.9 )
!<sys-libs/glibc-2.11
!sys-apps/gentoo-systemd-integration
!sys-apps/systemd
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20130224-r7
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)"
DEPEND="${COMMON_DEPEND}
dev-util/gperf
virtual/os-headers
virtual/pkgconfig
>=sys-devel/make-3.82-r4
>=sys-kernel/linux-headers-${KV_min}
>=dev-util/intltool-0.50
test? ( app-text/tree dev-lang/perl )"

RDEPEND="${COMMON_DEPEND}
!<sys-fs/lvm2-2.02.103
!<sec-policy/selinux-base-2.20120725-r10
!sys-fs/udev
!sys-apps/systemd"

PDEPEND=">=sys-fs/udev-init-scripts-26
hwdb? ( >=sys-apps/hwids-20140304[udev] )"

# The multilib-build.eclass doesn't handle situation where the installed headers
# are different in ABIs. In this case, we install libgudev headers in native
# ABI but not for non-native ABI.
multilib_check_headers() { :; }

pkg_pretend() {
ewarn
ewarn "As of 2013-01-29, ${P} provides the new interface renaming functionality,"
ewarn "as described in the URL below:"
ewarn "https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
ewarn
ewarn "This functionality is enabled BY DEFAULT because eudev has no means of synchronizing"
ewarn "between the default or user-modified choice of sys-fs/udev. If you wish to disable"
ewarn "this new iface naming, please be sure that /etc/udev/rules.d/80-net-name-slot.rules"
ewarn "exists: touch /etc/udev/rules.d/80-net-name-slot.rules"
ewarn
}

pkg_setup() {
CONFIG_CHECK="~BLK_DEV_BSG ~DEVTMPFS ~!IDE ~INOTIFY_USER ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2 ~SIGNALFD ~EPOLL ~FHANDLE ~NET ~UNIX"
linux-info_pkg_setup
get_running_version

# These are required kernel options, but we don't error out on them
# because you can build under one kernel and run under another.
if kernel_is lt ${KV_min//./ }; then
ewarn
ewarn "Your current running kernel version ${KV_FULL} is too old to run ${P}."
ewarn "Make sure to run udev under kernel version ${KV_min} or above."
ewarn
fi
}

src_prepare() {
# change rules back to group uucp instead of dialout for now
sed -e 's/GROUP="dialout"/GROUP="uucp"/' -i rules/*.rules \
|| die "failed to change group dialout to uucp"

eapply_user
eautoreconf
}

multilib_src_configure() {
tc-export CC #463846
export cc_cv_CFLAGS__flto=no #502950

# Keep sorted by ./configure --help and only pass --disable flags
# when *required* to avoid external deps or unnecessary compile
local econf_args
econf_args=(
ac_cv_search_cap_init=
ac_cv_header_sys_capability_h=yes
DBUS_CFLAGS=' '
DBUS_LIBS=' '
--with-rootprefix=
--with-rootrundir=/run
--libdir="${EPREFIX}"/usr/$(get_libdir)
--with-rootlibexecdir="${EPREFIX}"/lib/udev
--enable-split-usr
--enable-manpages
--disable-hwdb
--exec-prefix="${EPREFIX}"
)

# Only build libudev for non-native_abi, and only install it to libdir,
# that means all options only apply to native_abi
if multilib_is_native_abi; then
econf_args+=(
--with-rootlibdir="${EPREFIX}"/$(get_libdir)
$(use_enable introspection)
$(use_enable kmod)
$(use_enable static-libs static)
$(use_enable selinux)
$(use_enable rule-generator)
)
else
econf_args+=(
--disable-static
--disable-introspection
--disable-kmod
--disable-selinux
--disable-rule-generator
)
fi
ECONF_SOURCE="${S}" econf "${econf_args[@]}"
}

multilib_src_compile() {
if multilib_is_native_abi; then
emake
else
emake -C src/shared
emake -C src/libudev
fi
}

multilib_src_install() {
if multilib_is_native_abi; then
emake DESTDIR="${D}" install
else
emake -C src/libudev DESTDIR="${D}" install
fi
}

multilib_src_test() {
# make sandbox get out of the way
# these are safe because there is a fake root filesystem put in place,
# but sandbox seems to evaluate the paths of the test i/o instead of the
# paths of the actual i/o that results.
# also only test for native abi
if multilib_is_native_abi; then
addread /sys
addwrite /dev
addwrite /run
default_src_test
fi
}

multilib_src_install_all() {
prune_libtool_files --all

insinto /lib/udev/rules.d
doins "${FILESDIR}"/40-gentoo.rules

use rule-generator && doinitd "${FILESDIR}"/udev-postmount
}

pkg_postinst() {
mkdir -p "${EROOT}"run

# "losetup -f" is confused if there is an empty /dev/loop/, Bug #338766
# So try to remove it here (will only work if empty).
rmdir "${EROOT}"dev/loop 2>/dev/null
if [[ -d ${EROOT}dev/loop ]]; then
ewarn "Please make sure your remove /dev/loop,"
ewarn "else losetup may be confused when looking for unused devices."
fi

# https://cgit.freedesktop.org/systemd/systemd/commit/rules/50-udev-default.rules?id=3dff3e00e044e2d53c76fa842b9a4759d4a50e69
# https://bugs.gentoo.org/246847
# https://bugs.gentoo.org/514174
enewgroup input

# REPLACING_VERSIONS should only ever have zero or 1 values but in case it doesn't,
# process it as a list. We only care about the zero case (new install) or the case where
# the same version is being re-emerged. If there is a second version, allow it to abort.
local rv rvres=doitnew
for rv in ${REPLACING_VERSIONS} ; do
if [[ ${rvres} == doit* ]]; then
if [[ ${rv%-r*} == ${PV} ]]; then
rvres=doit
else
rvres=${rv}
fi
fi
done

if use hwdb && has_version 'sys-apps/hwids[udev]'; then
udevadm hwdb --update --root="${ROOT%/}"

# https://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
# reload database after it has be rebuilt, but only if we are not upgrading
# also pass if we are -9999 since who knows what hwdb related changes there might be
if [[ ${rvres} == doit* ]] && [[ ${ROOT%/} == "" ]] && [[ ${PV} != "9999" ]]; then
udevadm control --reload
fi
fi
if [[ ${rvres} != doitnew ]]; then
ewarn
ewarn "You need to restart eudev as soon as possible to make the"
ewarn "upgrade go into effect:"
ewarn "\t/etc/init.d/udev --nodeps restart"
fi

if use rule-generator && \
[[ -x $(type -P rc-update) ]] && rc-update show | grep udev-postmount | grep -qsv 'boot\|default\|sysinit'; then
ewarn
ewarn "Please add the udev-postmount init script to your default runlevel"
ewarn "to ensure the legacy rule-generator functionality works as reliably"
ewarn "as possible."
ewarn "\trc-update add udev-postmount default"
fi

elog
elog "For more information on eudev on Gentoo, writing udev rules, and"
elog "fixing known issues visit: https://wiki.gentoo.org/wiki/Eudev"
}

0 comments on commit db9dffe

Please sign in to comment.