Skip to content

Commit

Permalink
www-client/opera-beta: Version 68.0.3618.55
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Apr 28, 2020
1 parent 2d7a744 commit dbfb0ab
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/opera-beta/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST opera-beta_68.0.3618.45_amd64.deb 67623460 BLAKE2B 612c243fee60df644aacb93d3a4a0dc3638fb3b3d60e746d9b09780e4262768c31485113adb7c4687abea3fae2f3d701c051a2f6843c6dc756cf60fe633e4326 SHA512 9694aa000215e8b093ce02c4c420ebfe371977f6a58fb618a6ca0ae9e6b686ab2a5a4ad9ec5949d8a8ebdecca7d3d7a46feff88f4e0f7dfbc1aff8126862a957
DIST opera-beta_68.0.3618.55_amd64.deb 67671084 BLAKE2B bbde66def33b8853c6944f938856cf5d12198a4f51dda03d02a49c77660575bf075ddaaa932947bbc2e8a6fecf2fc47abb7dc79a883ca70939b716997271db0a SHA512 bc2f54b0f8db7125e2dff3f546ca93b07a161350e5aafd4aef1064034a147fb71c3afb243e31754bb97f5f61db45e10c3d4b5aab251128b0c61f53e7c7a6b92e
115 changes: 115 additions & 0 deletions www-client/opera-beta/opera-beta-68.0.3618.55.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
CHROMIUM_LANGS="
be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
zh-CN zh-TW
"
inherit chromium-2 multilib unpacker xdg-utils

DESCRIPTION="A fast and secure web browser"
HOMEPAGE="https://www.opera.com/"
LICENSE="OPERA-2014"
SLOT="0"
SRC_URI_BASE="
https://download1.operacdn.com/pub/
https://download2.operacdn.com/pub/
https://download3.operacdn.com/pub/
https://download4.operacdn.com/pub/
"
SRC_URI="amd64? ("
for uri in ${SRC_URI_BASE}; do
SRC_URI+="
"${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
"
done
SRC_URI+=")"
KEYWORDS="~amd64"

RDEPEND="
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype
net-misc/curl
net-print/cups
sys-apps/dbus
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/libnotify
x11-libs/pango[X]
"

QA_PREBUILT="*"
S=${WORKDIR}

pkg_setup() {
OPERA_HOME="usr/$(get_libdir)/${PN}"
}

src_unpack() {
unpack_deb ${A}
}

src_prepare() {
default

case ${ARCH} in
amd64)
mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
rm -r usr/lib || die
;;
x86)
mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
;;
esac

mv usr/share/doc/${PN} usr/share/doc/${PF} || die
gunzip usr/share/doc/${PF}/changelog.gz || die

rm usr/bin/${PN} || die

pushd "${OPERA_HOME}/localization" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die

sed -i \
-e 's|^TargetEnvironment|X-&|g' \
usr/share/applications/${PN}.desktop || die
}

src_install() {
mv * "${D}" || die
dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
}

pkg_postrm() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

0 comments on commit dbfb0ab

Please sign in to comment.