Skip to content

Commit

Permalink
dev-python/rq: Bump to 1.8.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 17, 2021
1 parent aca436a commit dc1d48e
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/rq/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rq-1.8.0.tar.gz 584251 BLAKE2B 3da1d4f1604a57e16e26c39643337fb8ab804089f783d6a7c44500f577a326cf4883835c996427e819896faad512b9a380ebfdcf67e865eec475d39321ecd2f5 SHA512 e8946b4454e67bc9ce0c69c302ba3bb6403654cce384904d64996766227ba8fdcbff834a8901a8fa09dcccebe8aba769d38daf228283f4142166fa5ea0f9a107
DIST rq-1.8.1.tar.gz 585211 BLAKE2B 17feb07cb376c5aef88a7aab6d716f58a19f62f19db6c6b0490b4f666981e40304c6a23c88669a0aef9b75a39ce8cb85a9b10a2d42e83e646cdcb6282167d8f9 SHA512 b9df7b4e894a5da693827ff720be3068336d82d2f17928faf5ae6133b042ac2f98a3d673bb2ed86c9351479669e9ef0e4fffcb1dba9b8853f6f793db4a4678f8
53 changes: 53 additions & 0 deletions dev-python/rq/rq-1.8.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1

DESCRIPTION="simple, lightweight library for creating and processing background jobs"
HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"

RDEPEND="
>=dev-python/click-5.0[${PYTHON_USEDEP}]
>=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-db/redis
dev-python/mock[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/sentry-sdk[${PYTHON_USEDEP}]
)
"

distutils_enable_tests --install pytest

src_test() {
local redis_pid="${T}"/redis.pid
local redis_port=6379
local redis_test_config="daemonize yes
pidfile ${redis_pid}
port ${redis_port}
bind 127.0.0.1
"

# Spawn Redis itself for testing purposes
# NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
# I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
elog "Spawning Redis"
elog "NOTE: Port ${redis_port} must be free"
/usr/sbin/redis-server - <<< "${redis_test_config}" || die

# Run the actual tests
distutils-r1_src_test

# Clean up afterwards
kill "$(<"${redis_pid}")" || die
}

0 comments on commit dc1d48e

Please sign in to comment.