forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-plasma/plasma-integration: Ensure rebuild with Qt 5.14.1
Bug: https://bugs.gentoo.org/707658 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
1 changed file
with
51 additions
and
0 deletions.
There are no files selected for viewing
51 changes: 51 additions & 0 deletions
51
kde-plasma/plasma-integration/plasma-integration-5.17.5-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
VIRTUALX_REQUIRED="test" | ||
KFMIN=5.64.0 | ||
PVCUT=$(ver_cut 1-3) | ||
QTMIN=5.12.3 | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces" | ||
LICENSE="LGPL-2+" | ||
SLOT="5" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=kde-frameworks/kcompletion-${KFMIN}:5 | ||
>=kde-frameworks/kconfig-${KFMIN}:5 | ||
>=kde-frameworks/kconfigwidgets-${KFMIN}:5 | ||
>=kde-frameworks/kcoreaddons-${KFMIN}:5 | ||
>=kde-frameworks/ki18n-${KFMIN}:5 | ||
>=kde-frameworks/kiconthemes-${KFMIN}:5 | ||
>=kde-frameworks/kio-${KFMIN}:5 | ||
>=kde-frameworks/kjobwidgets-${KFMIN}:5 | ||
>=kde-frameworks/knotifications-${KFMIN}:5 | ||
>=kde-frameworks/kwayland-${KFMIN}:5 | ||
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5 | ||
>=kde-frameworks/kwindowsystem-${KFMIN}:5 | ||
>=kde-frameworks/kxmlgui-${KFMIN}:5 | ||
>=kde-plasma/breeze-${PVCUT}:5 | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtgui-${QTMIN}:5=[dbus] | ||
|| ( | ||
>=dev-qt/qtgui-5.14.1:5[dbus] | ||
<dev-qt/qtgui-5.14.0:5[dbus] | ||
) | ||
>=dev-qt/qtquickcontrols2-${QTMIN}:5 | ||
>=dev-qt/qtwidgets-${QTMIN}:5 | ||
>=dev-qt/qtx11extras-${QTMIN}:5 | ||
x11-libs/libXcursor | ||
x11-libs/libxcb | ||
" | ||
RDEPEND="${DEPEND} | ||
media-fonts/hack | ||
media-fonts/noto | ||
" | ||
|
||
# requires running kde environment | ||
RESTRICT+=" test" |