forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/cryptography: Bump to 41.0.3
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
151 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,149 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
CARGO_OPTIONAL=yes | ||
DISTUTILS_EXT=1 | ||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{10..12} pypy3 ) | ||
PYTHON_REQ_USE="threads(+)" | ||
|
||
CRATES=" | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
[email protected] | ||
" | ||
|
||
inherit cargo distutils-r1 flag-o-matic multiprocessing pypi | ||
|
||
VEC_P=cryptography_vectors-$(ver_cut 1-3) | ||
DESCRIPTION="Library providing cryptographic recipes and primitives" | ||
HOMEPAGE=" | ||
https://github.com/pyca/cryptography/ | ||
https://pypi.org/project/cryptography/ | ||
" | ||
SRC_URI+=" | ||
${CARGO_CRATE_URIS} | ||
test? ( | ||
$(pypi_sdist_url cryptography_vectors "$(ver_cut 1-3)") | ||
) | ||
" | ||
|
||
LICENSE="|| ( Apache-2.0 BSD ) PSF-2" | ||
# Dependent crate licenses | ||
LICENSE+=" | ||
Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD MIT | ||
Unicode-DFS-2016 | ||
" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86" | ||
|
||
RDEPEND=" | ||
>=dev-libs/openssl-1.0.2o-r6:0= | ||
$(python_gen_cond_dep ' | ||
>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}] | ||
' 'python*') | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
" | ||
BDEPEND=" | ||
dev-python/setuptools-rust[${PYTHON_USEDEP}] | ||
test? ( | ||
>=dev-python/hypothesis-1.11.4[${PYTHON_USEDEP}] | ||
dev-python/iso8601[${PYTHON_USEDEP}] | ||
dev-python/pretend[${PYTHON_USEDEP}] | ||
dev-python/pyasn1-modules[${PYTHON_USEDEP}] | ||
dev-python/pytest-subtests[${PYTHON_USEDEP}] | ||
dev-python/pytest-xdist[${PYTHON_USEDEP}] | ||
dev-python/pytz[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
# Files built without CFLAGS/LDFLAGS, acceptable for rust | ||
QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/cryptography/hazmat/bindings/_rust.*.so" | ||
|
||
distutils_enable_tests pytest | ||
|
||
src_unpack() { | ||
cargo_src_unpack | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -i -e 's:--benchmark-disable::' pyproject.toml || die | ||
|
||
# work around availability macros not supported in GCC (yet) | ||
if [[ ${CHOST} == *-darwin* ]] ; then | ||
local darwinok=0 | ||
if [[ ${CHOST##*-darwin} -ge 16 ]] ; then | ||
darwinok=1 | ||
fi | ||
sed -i -e 's/__builtin_available(macOS 10\.12, \*)/'"${darwinok}"'/' \ | ||
src/_cffi_src/openssl/src/osrandom_engine.c || die | ||
fi | ||
} | ||
|
||
python_configure_all() { | ||
filter-lto # bug #903908 | ||
} | ||
|
||
python_test() { | ||
local -x PYTHONPATH="${PYTHONPATH}:${WORKDIR}/cryptography_vectors-${PV}" | ||
local EPYTEST_IGNORE=( | ||
tests/bench | ||
) | ||
epytest -n "$(makeopts_jobs)" | ||
} |