Skip to content

Commit

Permalink
mail-filter/afew: version bump 3.0.1
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/739436
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Guillaume Seren <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
GuillaumeSeren authored and thesamesam committed Sep 14, 2020
1 parent 4acc40c commit dc33cf1
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-filter/afew/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST afew-1.2.0.tar.gz 31831 BLAKE2B 7976dfc1e56461afbd6244220c5d548c7de5e95649b
DIST afew-1.3.0.tar.gz 33361 BLAKE2B 2553c04fce7e1c9f0a6551a8a01ed85735320bea95fe723050bdbde97aea80b93631c3621ec6cb0687753cbd88ac26725b1c608f7b8a6bcb4fc5bce6d3fce411 SHA512 2e15dc2aa6032b14c3fed57cb5912e3c3471592586f5fa40991b2a007d8a9579c0e1f69e455e1405923b93de64b9b8c126b5ccf8da72144528c57108beea7370
DIST afew-2.0.0.tar.gz 33116 BLAKE2B 59f2686a6495ee9e4a0afaf3180a83667bc65aaee453fe73cb2813401778d63fbb67adb45ed5f98c5c593d07d53411042096d44d85e652157d6705eb2e236152 SHA512 09eaca6fd387b76f310879f6e04c21f3247e703300d9995d40c420a06a5884cb08ebd51e5d1caee6d8c5be29844f6d562838104445e7b7efd372690c1856f97d
DIST afew-3.0.0.tar.gz 36525 BLAKE2B fd9b676ad00d9f6d989d8901f8885a7861d753ab96e4a768f2a1118b72893517fc3a8122a7a63d2e26659bf1afc2467bc7503f279b8037c65da9c250c18b152b SHA512 8d1947d547bde7fdc9ec2fc8fb212165fecc1cd4bc37c2dda60133e5ffe31dee1393ad0a92e4f0e2c85863a01f7ae252555e88868fa8ba5dece8380080f0e36c
DIST afew-3.0.1.tar.gz 40092 BLAKE2B 9ce125ec2359f7cf4630b9602b3068327adc06a699d325c90bc9b545df9ce7f3a62623cc733dfec55ee3e51523e4512ebec04e7186470fc56bb1589a7141cbc9 SHA512 1a76ecc78ed9fb8598be74c48a1d51c78db20df08b27c04c24779aaba01aa457c776457a647c54a5e92f0fda364a86810957a95c0d3f686e77e083d2103b1bf1
52 changes: 52 additions & 0 deletions mail-filter/afew/afew-3.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6,7,8} )

inherit distutils-r1

DESCRIPTION="Initial tagging script for Notmuch"
HOMEPAGE="https://github.com/afewmail/afew"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

RDEPEND="
$(python_gen_cond_dep '
dev-python/chardet[${PYTHON_MULTI_USEDEP}]
dev-python/dkimpy[${PYTHON_MULTI_USEDEP}]
net-mail/notmuch[python,${PYTHON_MULTI_USEDEP}]
')"
DEPEND="
$(python_gen_cond_dep '
dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
')"

DOCS=( "README.rst" )

python_prepare_all() {
sed -r \
-e "s/^([[:space:]]+)use_scm_version=.*,$/\1version='${PV}',/" \
-e "/^([[:space:]]+)setup_requires=.*,$/d" \
-i setup.py || die
distutils-r1_python_prepare_all
}

python_compile_all() {
esetup.py build_sphinx -b man --build-dir=docs/build
use doc && esetup.py build_sphinx -b html --build-dir=docs/build
}

python_install_all() {
doman docs/build/man/*
dodoc afew/defaults/afew.config
use doc && HTML_DOCS=( docs/build/html/. )
einstalldocs
}

0 comments on commit dc33cf1

Please sign in to comment.