Skip to content

Commit

Permalink
dev-python/wrapt: fix bug #568208
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Alex Brandt committed Dec 24, 2015
1 parent 1174eac commit dc9b002
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/wrapt/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST wrapt-1.10.5.tar.gz 119157 SHA256 4fd82193b23f60e1a39f3e10c81143c1e29e26cd5fc9afe1a7dc0f5e4b4a67d7 SHA512 450b32eea67774081d23c0e020ed7eea3c8ac458925a16cd606a4f95ee5b7631bda5ff00ceb914e9ccc28a5e0a7302534b6711bb23d637c77327a8a9d228cb55 WHIRLPOOL 7cfa9477f525e60f16a7b1689ba43b327192837bea34e96977442b9cd143a63fafdfa7d0b3895c93052b0e6f426e76fa439b155ee4e481dd5e922c529676691c
DIST wrapt-1.10.6-r1.tar.gz 120259 SHA256 b540e23753d3f7017ec0d38f16daf77f9e9cf170d5040abc3d87573ba20fc4f3 SHA512 658c780971dddf444070b9d30a8ac7c08ee0088b8f4378bcc9c22126608e52b338dc00969b08828b0318070abcf0e875bc2b7c6228a71fbbca362033088b4314 WHIRLPOOL 7aed77677a1448d6b3795be7fb56989be98a691a7470096adf45002ca124a99b5cab3e42b319493b4c8300684e488a07cf96d1c5a01e9fc9f181f765a0542254
DIST wrapt-1.10.6.tar.gz 25134 SHA256 9576869bb74a43cbb36ee39dc3584e6830b8e5c788e83edf0a397eba807734ab SHA512 d0c326fd401bc84656d69ec5da446b459f5596873a1ec01d616bebcc3d11237949eaafcfdf5de78e43f59927a0eaeee3da3f462975fa46fa22fd6c1593509e04 WHIRLPOOL 2d3c56d0a6e9e9af0a59708ce70190097da2459d80bdaa8d8f884a849905b44cdfb6bedb412ccd1e74be1e975492309a398e05d4b6c61a6852d3cd125230846a
48 changes: 48 additions & 0 deletions dev-python/wrapt/wrapt-1.10.6-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )

inherit distutils-r1 vcs-snapshot

DESCRIPTION="Module for decorators, wrappers and monkey patching"
HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}-r1.tar.gz"
S="${S}-r1"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc test"

DEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
)
"
RDEPEND=""

python_compile_all() {
use doc && emake -C docs html
}

python_compile() {
local WRAPT_EXTENSIONS=true

distutils-r1_python_compile
}

python_test() {
py.test -vv || die "tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )

distutils-r1_python_install_all
}

0 comments on commit dc9b002

Please sign in to comment.