Skip to content

Commit

Permalink
games-arcade/apricots: Stop using games.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
pacho2 committed Apr 15, 2018
1 parent 0d87b72 commit dc9b81e
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 8 deletions.
63 changes: 63 additions & 0 deletions games-arcade/apricots/apricots-0.2.6-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools desktop

DESCRIPTION="Fly a plane around bomb/shoot the enemy. Port of Planegame from Amiga"
HOMEPAGE="http://www.fishies.org.uk/apricots.html"
SRC_URI="http://www.fishies.org.uk/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE=""

DEPEND="media-libs/libsdl[sound,video]
media-libs/openal
media-libs/freealut"
RDEPEND="${DEPEND}"

src_prepare() {
default

eapply "${FILESDIR}"/${P}-freealut.patch \
"${FILESDIR}"/${P}-ldflags.patch

cp admin/acinclude.m4.in acinclude.m4

sed -i \
-e 's:-DAP_PATH=\\\\\\"$prefix.*":-DAP_PATH=\\\\\\"/usr/share/${PN}/\\\\\\"":' \
-e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
configure.in || die
sed -i \
-e "s:filename(AP_PATH):filename(\"/etc/${PN}/\"):" \
${PN}/init.cpp || die
sed -i \
-e "s:apricots.cfg:/etc/${PN}/apricots.cfg:" \
README apricots.html || die
sed -i \
-e 's/-Wmissing-prototypes//' \
acinclude.m4 || die

mv configure.in configure.ac || die
eautoreconf
}

src_compile() {
emake LIBTOOL="/usr/bin/libtool"
}

src_install() {
HTML_DOCS="apricots.html"
einstalldocs

cd ${PN}
dobin apricots
insinto /usr/share/${PN}
doins *.wav *.psf *.shapes
insinto /etc/${PN}
doins apricots.cfg

make_desktop_entry ${PN} Apricots
}
12 changes: 6 additions & 6 deletions games-arcade/apricots/files/apricots-0.2.6-freealut.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- apricots/apricots.cpp
+++ apricots/apricots.cpp
--- a/apricots/apricots.cpp
+++ b/apricots/apricots.cpp
@@ -16,6 +16,7 @@
int main(int, char**){
#endif
Expand All @@ -9,8 +9,8 @@
gamedata g;
init_data(g);

--- apricots/sampleio.cpp
+++ apricots/sampleio.cpp
--- a/apricots/sampleio.cpp
+++ b/apricots/sampleio.cpp
@@ -74,12 +74,9 @@
alListenerfv(AL_ORIENTATION, front );

Expand Down Expand Up @@ -51,8 +51,8 @@
}


--- configure.in
+++ configure.in
--- a/configure.in
+++ b/configure.in
@@ -100,7 +100,8 @@

dnl Check for OpenAL
Expand Down
4 changes: 2 additions & 2 deletions games-arcade/apricots/files/apricots-0.2.6-ldflags.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- apricots/Makefile.am.old 2010-10-11 15:58:18.000000000 +0200
+++ apricots/Makefile.am 2010-10-11 15:59:21.000000000 +0200
--- a/apricots/Makefile.am.old 2010-10-11 15:58:18.000000000 +0200
+++ b/apricots/Makefile.am 2010-10-11 15:59:21.000000000 +0200
@@ -4,7 +4,8 @@
## INCLUDES were found outside kdevelop specific part

Expand Down

0 comments on commit dc9b81e

Please sign in to comment.