Skip to content

Commit

Permalink
dev-java/commons-dbutils: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Oct 6, 2015
1 parent 7c5eeb6 commit dcb3fa6
Show file tree
Hide file tree
Showing 3 changed files with 317 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/commons-dbutils/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST commons-dbutils-1.1-src.tar.gz 60062 SHA256 645f79936bb90c5ed02fd4d1ddbc15b23e22a468ab0df22771f2b78fe8d49a59 SHA512 03859d0ddc65b1f0254f71e9de371f131a81dc839de6bea938a0547b63759d18a9e957f44ac887b7ae9ea85ee3aeea90ffd8f03069c670ec7b700fe8b6e45fe2 WHIRLPOOL b4b3e670b30101657c0d57fcf33993cdca89838135f147b54c63ac4bbced6fe1ed1218af36e95bec60e856c73a9d47fbfc1eecdbbd55dd7e476f6883fd94f3fd
DIST commons-dbutils-1.6-src.tar.gz 90708 SHA256 c7cb1bd7e0f9a6d509c98bb60f9941503473d6fe0fbe144736fb1819096c4524 SHA512 05aa5fb448d949ac4d5d34f1219539e57cfb550fa423af0691cb35002984036b0de62b8f618199bd2f562a441867c5b7138e9204afc36bd6d0fa2c4c5e9cd2c6 WHIRLPOOL 012a8cace08c96c136b9e9a05ec34d173d544aecad465908ad823a47ec535cfa91c609e5280e9e05967b3d863b13e999ad2c9a826a100e3faa3333869c26dd97
53 changes: 53 additions & 0 deletions dev-java/commons-dbutils/commons-dbutils-1.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5

JAVA_PKG_IUSE="doc source test"

inherit java-pkg-2 java-ant-2

DESCRIPTION="A small set of classes designed to make working with JDBC easier"
HOMEPAGE="http://commons.apache.org/dbutils/"
SRC_URI="mirror://apache/commons/dbutils/source/${P}-src.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND=">=virtual/jdk-1.6
test? (
dev-java/mockito:0
dev-java/ant-junit:0
dev-java/hamcrest-core:1.3
)"
RDEPEND=">=virtual/jre-1.6"

S="${WORKDIR}/${P}-src"

JAVA_ANT_REWRITE_CLASSPATH="yes"

EANT_TEST_TARGET="test"
EANT_TEST_GENTOO_CLASSPATH="
mockito
hamcrest-core-1.3
"

# Uses a bunch of deprecated methods.
JAVA_RM_FILES=(
src/test/java/org/apache/commons/dbutils/handlers/ArrayHandlerTest.java
)

java_prepare() {
cp "${FILESDIR}"/"${P}-build.xml" build.xml || die
}

src_test() {
java-pkg-2_src_test
}

src_install() {
java-pkg_newjar target/${P}.jar
use doc && java-pkg_dojavadoc target/site/apidocs
use source && java-pkg_dosrc src/main/java
}
263 changes: 263 additions & 0 deletions dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,263 @@
<?xml version="1.0" encoding="UTF-8"?>

<!-- ====================================================================== -->
<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
<!-- ====================================================================== -->

<!-- ====================================================================== -->
<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
<!-- ====================================================================== -->
<!-- -->
<!-- Any modifications will be overwritten. -->
<!-- -->
<!-- Generated by Maven Ant Plugin on 10/5/15 8:20 PM -->
<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
<!-- -->
<!-- ====================================================================== -->

<project name="commons-dbutils-from-maven" default="package" basedir=".">

<!-- ====================================================================== -->
<!-- Build environment properties -->
<!-- ====================================================================== -->

<property file="${user.home}/.m2/maven.properties"/>
<property file="maven-build.properties"/>

<property name="maven.build.finalName" value="commons-dbutils-1.6"/>
<property name="maven.build.dir" value="target"/>
<property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
<property name="maven.build.srcDir.0" value="src/main/java"/>
<property name="maven.build.resourceDir.0" value="src/main/resources"/>
<property name="maven.build.resourceDir.1" value="."/>
<property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
<property name="maven.build.testDir.0" value="src/test/java"/>
<property name="maven.build.testResourceDir.0" value="src/test/resources"/>
<property name="maven.build.testResourceDir.1" value="."/>
<property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
<property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>

<property name="maven.repo.local" value="${user.home}/.m2/repository"/>
<property name="maven.settings.offline" value="false"/>
<property name="maven.settings.interactiveMode" value="true"/>

<!-- ====================================================================== -->
<!-- Defining classpaths -->
<!-- ====================================================================== -->

<path id="build.classpath"/>
<path id="build.test.classpath">
<pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
<pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
<pathelement location="${maven.repo.local}/org/mockito/mockito-core/1.9.5/mockito-core-1.9.5.jar"/>
<pathelement location="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"/>
<pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-all/1.3/hamcrest-all-1.3.jar"/>
</path>

<!-- ====================================================================== -->
<!-- Cleaning up target -->
<!-- ====================================================================== -->

<target name="clean" description="Clean the output directory">
<delete dir="${maven.build.dir}"/>
</target>

<!-- ====================================================================== -->
<!-- Compilation target -->
<!-- ====================================================================== -->

<target name="compile" description="Compile the code">
<mkdir dir="${maven.build.outputDir}"/>
<javac destdir="${maven.build.outputDir}"
encoding="iso-8859-1"
nowarn="false"
debug="true"
optimize="false"
deprecation="true"
target="1.6"
verbose="false"
fork="false"
source="1.6">
<src>
<pathelement location="${maven.build.srcDir.0}"/>
</src>
<classpath refid="build.classpath"/>
</javac>
<mkdir dir="${maven.build.outputDir}/META-INF"/>
<copy todir="${maven.build.outputDir}/META-INF">
<fileset dir="${maven.build.resourceDir.1}">
<include name="NOTICE.txt"/>
<include name="LICENSE.txt"/>
</fileset>
</copy>
</target>

<!-- ====================================================================== -->
<!-- Test-compilation target -->
<!-- ====================================================================== -->

<target name="compile-tests"
depends="compile"
description="Compile the test code"
unless="maven.test.skip">
<mkdir dir="${maven.build.testOutputDir}"/>
<javac destdir="${maven.build.testOutputDir}"
encoding="iso-8859-1"
nowarn="false"
debug="true"
optimize="false"
deprecation="true"
target="1.6"
verbose="false"
fork="false"
source="1.6">
<src>
<pathelement location="${maven.build.testDir.0}"/>
</src>
<classpath>
<path refid="build.test.classpath"/>
<pathelement location="${maven.build.outputDir}"/>
</classpath>
</javac>
<copy todir="${maven.build.testOutputDir}">
<fileset dir="${maven.build.testResourceDir.0}"/>
</copy>
<mkdir dir="${maven.build.testOutputDir}/META-INF"/>
<copy todir="${maven.build.testOutputDir}/META-INF">
<fileset dir="${maven.build.testResourceDir.1}">
<include name="NOTICE.txt"/>
<include name="LICENSE.txt"/>
</fileset>
</copy>
</target>

<!-- ====================================================================== -->
<!-- Run all tests -->
<!-- ====================================================================== -->

<target name="test"
depends="compile-tests, junit-missing"
unless="junit.skipped"
description="Run the test cases">
<mkdir dir="${maven.test.reports}"/>
<junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
<sysproperty key="basedir" value="."/>
<formatter type="xml"/>
<formatter type="plain" usefile="false"/>
<classpath>
<path refid="build.test.classpath"/>
<pathelement location="${maven.build.outputDir}"/>
<pathelement location="${maven.build.testOutputDir}"/>
</classpath>
<batchtest todir="${maven.test.reports}" unless="test">
<fileset dir="${maven.build.testDir.0}">
<include name="**/Test*.java"/>
<include name="**/*Test.java"/>
<include name="**/*TestCase.java"/>
<exclude name="**/TestBean.java"/>
<exclude name="**/BaseTestCase.java"/>
</fileset>
</batchtest>
<batchtest todir="${maven.test.reports}" if="test">
<fileset dir="${maven.build.testDir.0}">
<include name="**/${test}.java"/>
<exclude name="**/BaseTestCase.java"/>
</fileset>
</batchtest>
</junit>
</target>

<target name="test-junit-present">
<available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
</target>

<target name="test-junit-status"
depends="test-junit-present">
<condition property="junit.missing">
<and>
<isfalse value="${junit.present}"/>
<isfalse value="${maven.test.skip}"/>
</and>
</condition>
<condition property="junit.skipped">
<or>
<isfalse value="${junit.present}"/>
<istrue value="${maven.test.skip}"/>
</or>
</condition>
</target>

<target name="junit-missing"
depends="test-junit-status"
if="junit.missing">
<echo>=================================== WARNING ===================================</echo>
<echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
<echo>===============================================================================</echo>
</target>

<!-- ====================================================================== -->
<!-- Javadoc target -->
<!-- ====================================================================== -->

<target name="javadoc" description="Generates the Javadoc of the application">
<javadoc sourcepath="${maven.build.srcDir.0}"
packagenames="*"
destdir="${maven.reporting.outputDirectory}/apidocs"
access="protected"
old="false"
verbose="false"
encoding="iso-8859-1"
version="true"
use="true"
author="true"
splitindex="false"
nodeprecated="false"
nodeprecatedlist="false"
notree="false"
noindex="false"
nohelp="false"
nonavbar="false"
serialwarn="false"
charset="ISO-8859-1"
docencoding="iso-8859-1"
source="1.6"
linksource="true"
breakiterator="false">
<link href="http://docs.oracle.com/javase/6/docs/api/"/>
<link href="http://docs.oracle.com/javaee/6/api/"/>
</javadoc>
</target>

<!-- ====================================================================== -->
<!-- Package target -->
<!-- ====================================================================== -->

<target name="package" depends="compile,test" description="Package the application">
<jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
compress="true"
index="false"
basedir="${maven.build.outputDir}"
excludes="**/package.html">
<manifest>
<attribute name="Main-Class" value="Main"/>
</manifest>
</jar>
</target>

<!-- ====================================================================== -->
<!-- A dummy target for the package named after the type it creates -->
<!-- ====================================================================== -->

<target name="jar" depends="package" description="Builds the jar for the application"/>

<!-- ====================================================================== -->
<!-- Download dependencies target -->
<!-- ====================================================================== -->

<target name="test-offline">
<condition property="maven.mode.offline">
<equals arg1="${maven.settings.offline}" arg2="true"/>
</condition>
</target>

</project>

0 comments on commit dcb3fa6

Please sign in to comment.