Skip to content

Commit

Permalink
app-portage/elogv: 0.8.1
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/841134
Signed-off-by: Sebastian Pipping <[email protected]>
  • Loading branch information
hartwork committed Oct 5, 2023
1 parent 4886f92 commit dcc1d96
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/elogv/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST elogv-0.7.9.tar.gz 19556 BLAKE2B 5d5f1a4adab09cf8b56ca3433b2a1cd0d3572345ff92f34b6b3ad175178161c36531bf9211563f4ad18191c6ff99c2cdcf9c3d188eca293a1698157e0a9f04a2 SHA512 703d1e8f55f5ee17a393f3a331ee38ef1d4e4c918c316055d5e2297b96dbe7de0ca6df864f462520f2087ed1a7bb7f43db56bfd3864a865d349516694522a686
DIST elogv-0.8.0.tar.gz 19563 BLAKE2B 1483f1973f0d18470484f8b4861f9301f5a2cc5e813709c3783127d0ed61db952c7edb1e5c12a3ba2066aa09bfd9c7547bc695ea9b46f106996b3036abc32d2d SHA512 75c1bce6dae36f5720e36a92d08c9469a54b31ff50321cc6fc250aa5a3039f2b4ce7ad518d261acb2d653e20783d375ec2c88bc2b86cc1400b6a49cfbb14647b
DIST elogv-0.8.1.tar.gz 19289 BLAKE2B e88e7383661e0a6336ffbb9027ee9d5540f14db7dd00e385afeb732925487a5cf9e73aa56cead2e11c6ae893a92006b3c75231dfb8918d8102af5988c10a480a SHA512 36f4eb237a8811d3720862d0551a84a0abce36cf565c810d25457ec5b1b2735897be69856ab50be2ad08be77b3761435aae87ac377407374c7643d05fe592f27
56 changes: 56 additions & 0 deletions app-portage/elogv/elogv-0.8.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{9..11} pypy3 )
PYTHON_REQ_USE="ncurses"
DISTUTILS_USE_PEP517=setuptools

inherit distutils-r1

DESCRIPTION="Curses based utility to parse the contents of elogs created by Portage"
HOMEPAGE="https://gitweb.gentoo.org/proj/elogv.git/"
SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
PLOCALES=( "de" "es" "it" "pl" )
IUSE="${PLOCALES[*]/#/l10n_}"

RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"

DOCS=( README )

src_install() {
distutils-r1_src_install

elog 'Deleting unwanted language files...'
for i in ${PLOCALES[@]}; do
if use "l10n_${i}"; then
# Keep and fix man page filename (bug #869905)
mv "${ED}"/usr/share/man/${i}/man1/${PN}.1{.${i},} || die
else
rm -r "${ED}"/usr/share/{locale,man}/"${i}" || die
elog "- Language \"${i}\" deleted"
fi
done
}

pkg_postinst() {
elog "In order to use this software, you need to activate"
elog "Portage's elog features. Required is"
elog " PORTAGE_ELOG_SYSTEM=\"save\" "
elog "and at least one out of "
elog " PORTAGE_ELOG_CLASSES=\"warn error info log qa\""
elog "More information on the elog system can be found"
elog "in ${EPREFIX}/usr/share/portage/config/make.conf.example"
elog
elog "To operate properly this software needs the directory"
elog "${PORT_LOGDIR:-${EPREFIX}/var/log/portage}/elog created, belonging to group portage."
elog "To start the software as a user, add yourself to the portage"
elog "group."
elog
}

0 comments on commit dcc1d96

Please sign in to comment.