Skip to content

Commit

Permalink
media-gfx/imagemagick: bump to v6.9.11-58 & v7.0.10-58
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jan 22, 2021
1 parent 7f43712 commit dcf1eb2
Show file tree
Hide file tree
Showing 3 changed files with 524 additions and 0 deletions.
2 changes: 2 additions & 0 deletions media-gfx/imagemagick/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST ImageMagick-6.9.11-52.tar.xz 9152084 BLAKE2B bc50767e3eacc06ccf6168d9cac5666a2836e3b2085ee834594da419c2912cafce7dee84573f1a2062e051afb066529ae79b7bea25242fb055fdd11e734ee0d7 SHA512 79e6ab62722060601283f4c172f7a27b7d3c00f5dbdfaea4c1f5c1940a681ab3fd53e4ea4b736adc3e0662ecccba13f7f86baada3d319733191eda37abee38a1
DIST ImageMagick-6.9.11-58.tar.xz 9167216 BLAKE2B 48fa4d6ced002a08268bb607bcf5988bb9fdb27c6c5fc20e5c73c06b9e48837c972b884e73d8a57d16dc0a1d9ba0cb4cf6aaee144a7193caa3d9fbd5ec6839a8 SHA512 b116596bb737cf78b9ec27ae4cc8aa3163f4201e68c3bbc9666421766859d2a2d7521697a4fdd94c6276d190667161816d0ee31dde3e06303bf09ffe79409885
DIST ImageMagick-7.0.10-52.tar.xz 9642352 BLAKE2B c1a86214978da88d66ef90b91516482fe67ee5e215fd5d76c79dbbcd9e33cc2d417d8f5d8e29056743737dd2275fe7a8d891b6ad2f3c8d7d5ab0adfd83f60dd1 SHA512 da1a8d53af0dc8f0dc8f71a7d41c5277c1e17f81e03a3c54852ced65d5d379577989e274bac66926c8a10f4d2f2834f7456b79635007252308ca593e98ef6d43
DIST ImageMagick-7.0.10-58.tar.xz 9655792 BLAKE2B b16db99046427bc0c764588fbf7d10f9f7cdf665d8662b03103ec69c75d44aea80575ae1b8381b15e33dc6a393216918cecbdbd93ea61639b4b09ec15d1588c8 SHA512 ec58eba8a35d78e481d98ae6e13daddc81a8e28904b1524735ce54a7d1557b4ec22d314ecdfcb199685ba55604e6fcdc3cbf9193775627dbd42bf61983c98593
254 changes: 254 additions & 0 deletions media-gfx/imagemagick/imagemagick-6.9.11.58.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,254 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit eapi7-ver eutils flag-o-matic libtool perl-functions toolchain-funcs multilib

MY_PV="$(ver_rs 3 '-')"
MY_P="ImageMagick-${MY_PV}"

DESCRIPTION="A collection of tools and libraries for many image formats"
HOMEPAGE="https://www.imagemagick.org/"
SRC_URI="mirror://imagemagick/${MY_P}.tar.xz"

LICENSE="imagemagick"
SLOT="0/6.9.11-37"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="bzip2 corefonts +cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf X xml zlib"

REQUIRED_USE="corefonts? ( truetype )
test? ( corefonts )"

RESTRICT="!test? ( test )"

RDEPEND="
dev-libs/libltdl:0
bzip2? ( app-arch/bzip2 )
corefonts? ( media-fonts/corefonts )
djvu? ( app-text/djvu )
fftw? ( sci-libs/fftw:3.0 )
fontconfig? ( media-libs/fontconfig )
fpx? ( >=media-libs/libfpx-1.3.0-r1 )
graphviz? ( media-gfx/graphviz )
heif? ( media-libs/libheif:= )
jbig? ( >=media-libs/jbigkit-2:= )
jpeg? ( virtual/jpeg:0 )
jpeg2k? ( >=media-libs/openjpeg-2.1.0:2 )
lcms? ( media-libs/lcms:2= )
lqr? ( media-libs/liblqr )
opencl? ( virtual/opencl )
openexr? ( media-libs/openexr:0= )
pango? ( x11-libs/pango )
perl? ( >=dev-lang/perl-5.8.8:0= )
png? ( media-libs/libpng:0= )
postscript? ( app-text/ghostscript-gpl )
raw? ( media-libs/libraw:= )
svg? (
gnome-base/librsvg
media-gfx/potrace
)
tiff? ( media-libs/tiff:0= )
truetype? (
media-fonts/urw-fonts
>=media-libs/freetype-2
)
webp? ( media-libs/libwebp:0= )
wmf? ( media-libs/libwmf )
X? (
x11-libs/libICE
x11-libs/libSM
x11-libs/libXext
x11-libs/libXt
)
xml? ( dev-libs/libxml2:= )
lzma? ( app-arch/xz-utils )
zlib? ( sys-libs/zlib:= )"
DEPEND="${RDEPEND}
!media-gfx/graphicsmagick[imagemagick]
virtual/pkgconfig
X? ( x11-base/xorg-proto )"

S="${WORKDIR}/${MY_P}"
#S="${WORKDIR}/ImageMagick6-${MY_PV}"

src_prepare() {
default

# Apply hardening #664236
cp "${FILESDIR}"/policy-hardening.snippet "${S}" || die
sed -i -e '/^<policymap>$/ {
r policy-hardening.snippet
d
}' \
config/policy.xml || \
die "Failed to apply hardening of policy.xml"
einfo "policy.xml hardened"

elibtoolize # for Darwin modules

# For testsuite, see https://bugs.gentoo.org/show_bug.cgi?id=500580#c3
local mesa_cards ati_cards nvidia_cards render_cards
shopt -s nullglob
ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
if test -n "${ati_cards}"; then
addpredict "${ati_cards}"
fi
mesa_cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
if test -n "${mesa_cards}"; then
addpredict "${mesa_cards}"
fi
nvidia_cards=$(echo -n /dev/nvidia** | sed 's/ /:/g')
if test -n "${nvidia_cards}"; then
addpredict "${nvidia_cards}"
fi
render_cards=$(echo -n /dev/dri/renderD128* | sed 's/ /:/g')
if test -n "${render_cards}"; then
addpredict "${render_cards}"
fi
shopt -u nullglob
addpredict /dev/nvidiactl
}

src_configure() {
local depth=16
use q8 && depth=8
use q32 && depth=32

local openmp=disable
use openmp && { tc-has-openmp && openmp=enable; }

use perl && perl_check_env

[[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket

local myeconfargs=(
$(use_enable static-libs static)
$(use_enable hdri)
$(use_enable opencl)
--with-threads
--with-modules
--with-quantum-depth=${depth}
$(use_with cxx magick-plus-plus)
$(use_with perl)
--with-perl-options='INSTALLDIRS=vendor'
--with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
$(use_with bzip2 bzlib)
$(use_with X x)
$(use_with zlib)
--without-autotrace
$(use_with postscript dps)
$(use_with djvu)
--with-dejavu-font-dir="${EPREFIX}"/usr/share/fonts/dejavu
$(use_with fftw)
$(use_with fpx)
$(use_with fontconfig)
$(use_with truetype freetype)
$(use_with postscript gslib)
$(use_with graphviz gvc)
$(use_with heif heic)
$(use_with jbig)
$(use_with jpeg)
$(use_with jpeg2k openjp2)
$(use_with lcms)
$(use_with lqr)
$(use_with lzma)
$(use_with openexr)
$(use_with pango)
$(use_with png)
$(use_with raw)
$(use_with svg rsvg)
$(use_with tiff)
$(use_with webp)
$(use_with corefonts windows-font-dir "${EPREFIX}"/usr/share/fonts/corefonts)
$(use_with wmf)
$(use_with xml)
--${openmp}-openmp
--with-gcc-arch=no-automagic
)
CONFIG_SHELL=$(type -P bash) econf "${myeconfargs[@]}"
}

src_test() {
# Install default (unrestricted) policy in $HOME for test suite #664238
local _im_local_config_home="${HOME}/.config/ImageMagick"
mkdir -p "${_im_local_config_home}" || \
die "Failed to create IM config dir in '${_im_local_config_home}'"
cp "${FILESDIR}"/policy.test.xml "${_im_local_config_home}/policy.xml" || \
die "Failed to install default blank policy.xml in '${_im_local_config_home}'"

local im_command= IM_COMMANDS=()
IM_COMMANDS+=( "identify -version | grep -q -- \"${MY_PV}\"" ) # Verify that we are using version we just built
IM_COMMANDS+=( "identify -list policy" ) # Verify that policy.xml is used
IM_COMMANDS+=( "emake check" ) # Run tests

for im_command in "${IM_COMMANDS[@]}"; do
eval "${S}"/magick.sh \
${im_command} || \
die "Failed to run \"${im_command}\""
done
}

src_install() {
# Ensure documentation installation files and paths with each release!
emake \
DESTDIR="${D}" \
DOCUMENTATION_PATH="${EPREFIX}"/usr/share/doc/${PF}/html \
install

rm -f "${ED%/}"/usr/share/doc/${PF}/html/{ChangeLog,LICENSE,NEWS.txt}
dodoc {AUTHORS,README}.txt ChangeLog

if use perl; then
find "${ED}" -type f -name perllocal.pod -exec rm -f {} +
find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} +
fi

find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
# .la files in parent are not needed, keep plugin .la files
rm "${ED}"/usr/$(get_libdir)/*.la || die

if use opencl; then
cat <<-EOF > "${T}"/99${PN}
SANDBOX_PREDICT="/dev/nvidiactl:/dev/nvidia-uvm:/dev/ati/card:/dev/dri/card:/dev/dri/card0:/dev/dri/renderD128"
EOF

insinto /etc/sandbox.d
doins "${T}"/99${PN} #472766
fi

insinto /usr/share/${PN}
doins config/*icm
}

pkg_postinst() {
local _show_policy_xml_notice=

if [[ -z "${REPLACING_VERSIONS}" ]]; then
# This is a new installation
_show_policy_xml_notice=yes
else
local v
for v in ${REPLACING_VERSIONS}; do
if ! ver_test "${v}" -gt "6.9.10.10-r2"; then
# This is an upgrade
_show_policy_xml_notice=yes

# Show this elog only once
break
fi
done
fi

if [[ -n "${_show_policy_xml_notice}" ]]; then
elog "For security reasons, a policy.xml file was installed in /etc/ImageMagick-6"
elog "which will prevent the usage of the following coders by default:"
elog ""
elog " - PS"
elog " - PS2"
elog " - PS3"
elog " - EPS"
elog " - PDF"
elog " - XPS"
fi
}
Loading

0 comments on commit dcf1eb2

Please sign in to comment.