Skip to content

Commit

Permalink
media-plugins/alsa-plugins: Bump to version 1.1.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Nov 15, 2017
1 parent 2b1c35e commit dd54c9f
Show file tree
Hide file tree
Showing 2 changed files with 106 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-plugins/alsa-plugins/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST alsa-plugins-1.1.1.tar.bz2 366193 SHA256 8ea4d1e082c36528a896a2581e5eb62d4dc2683238e353050d0d624e65f901f1 SHA512 9dd277cb5cce144ce4e5e0010cebcba0f8634c783e7bcd80ce6d04b198d6de5150a2764df3087a39a468b5fb7c4578de2e252095568e811dedaa5e7ffdbeb7c9 WHIRLPOOL 20f36afcb01dfe47172b6470fea929ffb267e0b7a78ac4ca8c2031b33faa6fe15bd0608d9963e053366ac6bf3b2f540d776537c8547418a0d2b80b5c0366a76f
DIST alsa-plugins-1.1.4.tar.bz2 366931 SHA256 530d1c3bdaeb058f2a03607a33b9e16ee5369bfd30a96bc09bd2c69b4ddd1a8a SHA512 edbc9dd762e2500ce6f820d81fcd8d2577506afcea0b33a32cece95f8d6651840f4f8a55664f274d735ab3effa13cdbfc0331690c37a64a9ad050c15dc77cac6 WHIRLPOOL 38229f5d194ee0ef47b00d1464ed5392fbdb33f8d63a9b8dbdf26e39db3d096314fbe1f9220566a30aa905ec38607ebeb042611c3defd0f93543075d23382e45
DIST alsa-plugins-1.1.5.tar.bz2 366999 SHA256 797da5f8f53379fbea28817bc466de16affd2c07849e84f1af8d5e22f7bb7f1c SHA512 50a79d9dbcca72b2133aba7dca594302dcd5816eb71afc311a4c2a96aac7632a0a034875faf3100f2c8a44f3fbbede264e5cd9beacf2a07f2fa6786f66edae39 WHIRLPOOL b34067b474e403d982a07846bcaa70587f09dfff1e48ae61734c6252188581409e4a96bab301373489d94f4a4f7900f3cb50b0b9a6a92d73d3a40690f155540e
105 changes: 105 additions & 0 deletions media-plugins/alsa-plugins/alsa-plugins-1.1.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,105 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools eutils flag-o-matic multilib multilib-minimal

DESCRIPTION="ALSA extra plugins"
HOMEPAGE="http://www.alsa-project.org/"
SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"

LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
IUSE="debug ffmpeg jack libav libsamplerate pulseaudio speex"

RDEPEND="
>=media-libs/alsa-lib-${PV}:=[${MULTILIB_USEDEP}]
ffmpeg? (
libav? ( media-video/libav:= )
!libav? ( media-video/ffmpeg:0= )
)
jack? ( virtual/jack[${MULTILIB_USEDEP}] )
libsamplerate? ( >=media-libs/libsamplerate-0.1.8-r1:=[${MULTILIB_USEDEP}] )
pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
speex? (
|| (
(
>=media-libs/speex-1.2.0[${MULTILIB_USEDEP}]
media-libs/speexdsp[${MULTILIB_USEDEP}]
)
<media-libs/speex-1.2.0[${MULTILIB_USEDEP}]
)
media-libs/speex:=[${MULTILIB_USEDEP}]
)
"
DEPEND="${RDEPEND}
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}/${PN}-1.0.23-automagic.patch"
)

src_prepare() {
default

# For some reasons the polyp/pulse plugin does fail with alsaplayer with a
# failed assert. As the code works just fine with asserts disabled, for now
# disable them waiting for a better solution.
sed -i \
-e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
pulse/Makefile.am || die

eautoreconf
}

multilib_src_configure() {
use debug || append-cppflags -DNDEBUG

local myspeex=no
use speex && myspeex=lib

ECONF_SOURCE=${S} \
econf \
$(use_enable ffmpeg avcodec) \
$(use_enable jack) \
$(use_enable libsamplerate samplerate) \
$(use_enable pulseaudio) \
--with-speex=${myspeex}
}

multilib_src_install_all() {
einstalldocs

cd doc || die
dodoc upmix.txt vdownmix.txt README-pcm-oss
use jack && dodoc README-jack
use libsamplerate && dodoc samplerate.txt
use ffmpeg && dodoc lavcrate.txt a52.txt

if use pulseaudio; then
dodoc README-pulse
# install ALSA configuration files
# making PA to be used by alsa clients
insinto /usr/share/alsa
doins "${FILESDIR}"/pulse-default.conf
insinto /usr/share/alsa/alsa.conf.d
doins "${FILESDIR}"/51-pulseaudio-probe.conf
# bug #410261, comment 5+
# seems to work fine without any path
sed -i \
-e "s:/usr/lib/alsa-lib/::" \
"${ED}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
fi

prune_libtool_files --all
}

pkg_postinst() {
if use pulseaudio; then
einfo "The PulseAudio device is now set as the default device if the"
einfo "PulseAudio server is found to be running. Any custom"
einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
einfo "purpose should now be unnecessary."
fi
}

0 comments on commit dd54c9f

Please sign in to comment.