Skip to content

Commit

Permalink
x11-wm/xpra: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
xmw committed Feb 22, 2016
1 parent 8498081 commit dd59b94
Show file tree
Hide file tree
Showing 3 changed files with 152 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-wm/xpra/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST xpra-0.14.27.tar.xz 1123504 SHA256 9d51d6e656a9afc6559ec4b671a706ba134257c8e6d909d2514a3ca653502efb SHA512 5f195b211b8e78091ba42661c08f367d66e2a34ebcea9e5df57f0408cf1c4232294d38692171abbfe7396a1da28b2cc4100252dc034872a278530c48282db5cf WHIRLPOOL b14d58cddd03093a598e99d69fb145a5a04347f48fc0ec0b0311efa7bc75f5a51be5db93a361032ead2e021d2c8ead13986a3bd7434108506bbc4b601556141b
DIST xpra-0.14.34.tar.xz 1127536 SHA256 1f59e3d308bdff6e3b19df0c671a97d2a4bc8e1ec1c3dd49c2bbc8f9feefd8aa SHA512 e19cc701fce797ca96bbf1cc1e4140b8a1d35ca5c1a8bd3cf4a16623908c28c0dd119f654e103352a3a2ec09735bf8562f4669aefe39b746933202621e905230 WHIRLPOOL 32a175b04ab8b6bdf3e5a53bea91a6e01925a3f40358e3edf2a786d58d52e05d917a04f3ffdcf8bbee07fb5ce8c8d032e5cbc52542d9b16a13ba072ff4aa71af
DIST xpra-0.15.10.tar.xz 1200040 SHA256 1403aaf571c486bb4a67bc9e9d431e5f863c9b7912bd65e6aec62fcea2d9d4e0 SHA512 add1e63da75b7e29163a7e0957e3f841019c557ba42b15f437ed385de99905cb28a3760386570b72c5d2ba305c5b7779a85ca39d4452ccd6133c26f0a7983d9a WHIRLPOOL a5c50b68b39786aad6c50332340bf421ac17f38948880acb49d55769e8a9b4fb48b068a0fea0e5e660e9621b460eb60d19131600173b826b54a4f7d2e623fb5f
DIST xpra-0.16.2.tar.xz 1341856 SHA256 ce99b941f63aeae465c9d095bcdef857227f8102759df3d013fbfb65c8cea540 SHA512 a5431367918551c630a7f80bd59c51b3bd360472ee268b7865862f4de03b0962b534ab65c4926faa386098c48cdab49f8d7e91b60b998017df52ab077d270a33 WHIRLPOOL bb3c89eb6f32349f26b076abea5535b9e37a3ea2789be9aa35723a383603cce090044d8b8631817b5eda0b158ddcf2c278240e977a3daed0c8fe510e576f4135
27 changes: 27 additions & 0 deletions x11-wm/xpra/files/xpra-0.16.2-prefix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
--- xpra-0.16.2/setup.py
+++ xpra-0.16.2/setup.py
@@ -1723,8 +1723,8 @@
#prepare default [/usr/local]/etc configuration files:
if '--user' in sys.argv:
etc_prefix = 'etc/xpra'
- elif sys.prefix == '/usr':
- etc_prefix = '/etc/xpra'
+ elif sys.prefix[-4:] == '/usr':
+ etc_prefix = sys.prefix[:-4] + '/etc/xpra'
else:
etc_prefix = sys.prefix + '/etc/xpra'

--- xpra-0.16.2/xpra/platform/paths.py
+++ xpra-0.16.2/xpra/platform/paths.py
@@ -40,9 +40,9 @@
def do_get_system_conf_dirs():
prefix = get_install_prefix()
#the system wide configuration directory
- if prefix == '/usr':
+ if prefix[-4:] == '/usr':
#default posix config location:
- return ['/etc/xpra']
+ return [sys.prefix[:-4] + '/etc/xpra']
#hope the prefix is something like "/usr/local" or "$HOME/.local":
return [prefix + '/etc/xpra/']

124 changes: 124 additions & 0 deletions x11-wm/xpra/xpra-0.16.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,124 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5

# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3, and setup.py not python3.2 compat
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 eutils flag-o-matic

DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
SRC_URI="http://xpra.org/src/${P}.tar.xz"

LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+client +clipboard csc cups dec_av2 libav lz4 lzo opengl pulseaudio server sound vpx webp x264 x265"

REQUIRED_USE="${PYTHON_REQUIRED_USE}
clipboard? ( || ( server client ) )
opengl? ( client )
|| ( client server )"

# x264/old-libav.path situation see bug 459218
COMMON_DEPEND=""${PYTHON_DEPS}"
dev-python/pygobject:2[${PYTHON_USEDEP}]
dev-python/pygtk:2[${PYTHON_USEDEP}]
x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXdamage
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libXtst
csc? (
!libav? ( >=media-video/ffmpeg-1.2.2:0= )
libav? ( media-video/libav:0= )
)
dec_av2? (
!libav? ( >=media-video/ffmpeg-2:0= )
libav? ( media-video/libav:0= )
)
opengl? ( dev-python/pygtkglext )
pulseaudio? ( media-sound/pulseaudio )
sound? ( media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
dev-python/gst-python:1.0 )
vpx? ( media-libs/libvpx virtual/ffmpeg )
webp? ( media-libs/libwebp )
x264? ( media-libs/x264
!libav? ( >=media-video/ffmpeg-1.0.4:0= )
libav? ( media-video/libav:0= )
)
x265? ( media-libs/x265
!libav? ( >=media-video/ffmpeg-2:0= )
libav? ( media-video/libav:0= )
)"

RDEPEND="${COMMON_DEPEND}
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/rencode[${PYTHON_USEDEP}]
virtual/ssh
x11-apps/xmodmap
cups? ( dev-python/pycups[${PYTHON_USEDEP}] )
lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
lzo? ( dev-python/python-lzo[${PYTHON_USEDEP}] )
opengl? (
client? ( dev-python/pyopengl_accelerate[${PYTHON_USEDEP}] )
)
server? ( x11-base/xorg-server[-minimal,xvfb]
x11-drivers/xf86-input-void
x11-drivers/xf86-video-dummy
)"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
>=dev-python/cython-0.16[${PYTHON_USEDEP}]"

python_prepare_all() {
rm -rf rencode || die

epatch \
"${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
"${FILESDIR}"/${PN}-0.16.2-prefix.patch

if use libav ; then
if ! has_version ">=media-video/libav-9" ; then
epatch patches/old-libav.patch
fi
fi

distutils-r1_python_prepare_all
}

python_configure_all() {
mydistutilsargs=(
$(use_with client)
$(use_with clipboard)
$(use_with csc csc_swscale)
$(use_with cups printing)
$(use_with dec_av2 dec_avcodec2)
$(use_with opengl)
$(use_with server shadow)
$(use_with server)
$(use_with sound)
$(use_with vpx)
$(use_with webp)
$(use_with x264 enc_x264)
$(use_with x265 enc_x265)
--with-Xdummy
--with-gtk2
--without-gtk3
--with-strict
--with-warn
--with-x11
--without-PIC
--without-debug )

# see https://www.xpra.org/trac/ticket/1080
# and http://trac.cython.org/ticket/395
append-cflags -fno-strict-aliasing
}

0 comments on commit dd59b94

Please sign in to comment.