Skip to content

Commit

Permalink
dev-php/composer: bump to v2.1.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.19, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jun 11, 2021
1 parent 6b5baea commit dd5a483
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/composer/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST composer-2.0.13.tar.gz 497819 BLAKE2B ab51556ff65b0c2822d5419bb6dde2c775c91
DIST composer-2.0.14.tar.gz 498661 BLAKE2B 0b454ed6a00b5cab169a4ff82e9a3d7ceb0d885bd1fe8f70ed495bc28e13a93f477c24df7d9510d0611941addc894d914b6856ef823762f0aeb596fef9332526 SHA512 7eb87f8454d38a091bf97ad470c41f6d1b82bc153618312093935d2b7b5890bf3d1eba25f9bd8e46c5f8ae462729e85ea19eb03184a4484332694a6369a82917
DIST composer-2.1.1.tar.gz 513391 BLAKE2B 9177eb7d1acfb3557dde0382e0d0b6fd367a16f4c2de30739c40a1fae396e7f188173c5ef9356c6f55922457ea52c7c3e19e9040c37e86fdb4575016aac07808 SHA512 22105ab3f831ab89cf80e247c6e6f6263f3116a24394b9367b7e7c1e1aebfdcf9bb833add4763c34c621714dd8f22c87327ccf6c8eeef113f753ba800a111a5c
DIST composer-2.1.2.tar.gz 513790 BLAKE2B cc1c807ae4d69537541acf3ec384dbad64bf3196067c5ad016b03903e9b47460a6757c0fe692600f3042650c030b323f0a0b5ef4c3933049899843cbdc8266dc SHA512 1835daeb943af2ff58e5f5b3966b59356c14ac740689779c05fa0021174a7d0ac2a45aae7f54fade0695ca7eedf59f7ac4c9c14ae4aa1e4a5fbfb1650aae8ca9
DIST composer-2.1.3.tar.gz 514147 BLAKE2B 3abf64aceea5b95b72419b60fc74d23e42c652036690c2e31b4250eb4a0e3607a1b4080745642fb085be75dd1174073164f9a8a1422745b4bff5887df694fd99 SHA512 d3214f39651e323b419979ed150d5239f992a6b643048a73a777ece0a1b3d5e3dc2c58a5084b3e825834acc258c18947b0c6461c47960a10552617c8f541df86
80 changes: 80 additions & 0 deletions dev-php/composer/composer-2.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

DESCRIPTION="Dependency Manager for PHP"
HOMEPAGE="https://github.com/composer/composer"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

BDEPEND="dev-php/theseer-Autoload"

RDEPEND="dev-lang/php:*[curl]
>=dev-php/ca-bundle-1.0
dev-php/fedora-autoloader
>=dev-php/jsonlint-1.4
>=dev-php/json-schema-5.2.10
>=dev-php/metadata-minifier-1.0
>=dev-php/phar-utils-1.0
>=dev-php/psr-log-1.0
>=dev-php/reactphp-promise-2.7
>=dev-php/semver-3.0
>=dev-php/spdx-licenses-1.2
>=dev-php/symfony-console-2.8.52
>=dev-php/symfony-filesystem-2.8.52
>=dev-php/symfony-finder-2.8.52
>=dev-php/symfony-process-2.8.52
>=dev-php/xdebug-handler-2"

src_prepare() {
default

mkdir vendor || die

phpab \
--output vendor/autoload.php \
--template "${FILESDIR}"/autoload.php.tpl \
--basedir src \
src \
|| die

cat >> vendor/autoload.php <<EOF || die "failed to extend autoload.php"
// Dependencies
\Fedora\Autoloader\Dependencies::required([
'/usr/share/php/Composer/CaBundle/autoload.php',
'/usr/share/php/Composer/MetadataMinifier/autoload.php',
'/usr/share/php/Composer/Semver/autoload.php',
'/usr/share/php/Composer/Spdx/autoload.php',
'/usr/share/php/Composer/XdebugHandler/autoload.php',
'/usr/share/php/JsonSchema/autoload.php',
'/usr/share/php/Psr/Log/autoload.php',
'/usr/share/php/Seld/JsonLint/autoload.php',
'/usr/share/php/Seld/PharUtils/autoload.php',
'/usr/share/php/Symfony/Component/Console/autoload.php',
'/usr/share/php/Symfony/Component/Filesystem/autoload.php',
'/usr/share/php/Symfony/Component/Finder/autoload.php',
'/usr/share/php/Symfony/Component/Process/autoload.php',
'/usr/share/php/React/Promise/autoload.php'
]);
EOF
}

src_install() {
insinto "/usr/share/${PN}"

# Composer expects the LICENSE file to be there, and the
# easiest thing to do is to give it what it wants.
doins -r LICENSE res src vendor

exeinto "/usr/share/${PN}/bin"
doexe "bin/${PN}"
dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"

dodoc CHANGELOG.md README.md doc/*.md
dodoc -r doc/articles doc/faqs
}

0 comments on commit dd5a483

Please sign in to comment.