Skip to content

Commit

Permalink
kde-plasma/kwin: Initialize kcrash for xclipboardsync
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Nov 18, 2018
1 parent 660b273 commit dd923de
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 2 deletions.
48 changes: 48 additions & 0 deletions kde-plasma/kwin/files/kwin-5.14.3-kcrash-init.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
From aace9b1675819feab81d50f694391c7d854d9822 Mon Sep 17 00:00:00 2001
From: Harald Sitter <[email protected]>
Date: Fri, 16 Nov 2018 12:50:53 +0100
Subject: actually initialize kcrash for xclipboardsync

Summary:
to successfully use kcrash when linking with as-needed (which is a default
flag on many linux distros) one also needs to call KCrash::initialize.

https://markmail.org/thread/zv5pheijaze72bzs

Test Plan: builds; correctly links kcrash

Reviewers: davidedmundson

Reviewed By: davidedmundson

Subscribers: kwin

Tags: #kwin

Differential Revision: https://phabricator.kde.org/D16923
---
helpers/xclipboardsync/main.cpp | 2 ++
1 file changed, 2 insertions(+)

diff --git a/helpers/xclipboardsync/main.cpp b/helpers/xclipboardsync/main.cpp
index 2f06e9c..1a5e5ee 100644
--- a/helpers/xclipboardsync/main.cpp
+++ b/helpers/xclipboardsync/main.cpp
@@ -19,6 +19,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
*********************************************************************/
#include "waylandclipboard.h"

+#include <KCrash>
#include <QGuiApplication>

#include <config-kwin.h>
@@ -40,6 +41,7 @@ int main(int argc, char *argv[])
argv[0], qPrintable(app.platformName()));
return 1;
}
+ KCrash::initialize();
new WaylandClipboard(&app);
return app.exec();
}
--
cgit v0.11.2
5 changes: 3 additions & 2 deletions kde-plasma/kwin/kwin-5.14.3-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -89,8 +89,9 @@ PDEPEND="
RESTRICT+=" test"

PATCHES=(
"${FILESDIR}/${PN}-5.14.3-virtualdesktop-crash.patch"
"${FILESDIR}/${PN}-5.14.3-resizewindows-crash.patch"
"${FILESDIR}/${P}-virtualdesktop-crash.patch"
"${FILESDIR}/${P}-resizewindows-crash.patch"
"${FILESDIR}/${P}-kcrash-init.patch"
)

src_prepare() {
Expand Down

0 comments on commit dd923de

Please sign in to comment.