forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/pyproject-api: Bump to 1.3.0
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
43 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST pyproject-api-1.1.2.gh.tar.gz 19058 BLAKE2B 3c8672821baad2ed440474c42818bd37fb7ed7f20f29d9c765190cc8ac6352ff18a17b35d97a73cf4f76001bdff92d2e0e8fd0f29f45d69a5bf7377b2ddc9626 SHA512 e4f2c97d49789fcf231af83758697e5b505c4a9afb6268349da215c3f5f94e3bf78b70beeea4ca51706b71313101dffc15942db394a7994b85e7c5f763e090d7 | ||
DIST pyproject-api-1.2.1.gh.tar.gz 19579 BLAKE2B 4d973fd5d3a5625b3080411c447cc66ee1ec4d79f37a2a00ca9e4be1bbb642a18466a442aae510d4b8c0f078ee3bcfb64e77143f2cea0e557c4f16b0bf7fcefb SHA512 bc84a0aa1845cf910a980a2fb562553eb3e58f6b16f3516fccc46c9723dca8ac553c457160a1fcb39d4de984906a196dd9f625fcae1ee6295e30b3f9a2618c6d | ||
DIST pyproject-api-1.3.0.gh.tar.gz 20650 BLAKE2B 9efc0a4fb753c6246d056a9c4bb6a8d36a385bb952b5099b86eff9312b014db499337091716708a57a4fcab1ca55ed5d716898942b37a08420d5bb4681835d63 SHA512 916fc35538b5d28e343170c0c5b7a70e534f4c6095cf2dc4714988fdab51791d55389bea6c7b7645d1da9a0f863e75d7c0a33956c3b24b8682efeb4c016ba740 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 2022-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=hatchling | ||
PYTHON_COMPAT=( pypy3 python3_{8..11} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="API to interact with the python pyproject.toml based projects" | ||
HOMEPAGE=" | ||
https://github.com/tox-dev/pyproject-api/ | ||
https://pypi.org/project/pyproject-api/ | ||
" | ||
SRC_URI=" | ||
https://github.com/tox-dev/pyproject-api/archive/${PV}.tar.gz | ||
-> ${P}.gh.tar.gz | ||
" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~riscv" | ||
|
||
RDEPEND=" | ||
>=dev-python/packaging-21.3[${PYTHON_USEDEP}] | ||
$(python_gen_cond_dep ' | ||
>=dev-python/tomli-2.0.1[${PYTHON_USEDEP}] | ||
' 3.8 3.9 3.10) | ||
" | ||
BDEPEND=" | ||
>=dev-python/hatch-vcs-0.2[${PYTHON_USEDEP}] | ||
test? ( | ||
>=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}] | ||
>=dev-python/wheel-0.37.1[${PYTHON_USEDEP}] | ||
>=dev-python/virtualenv-20.17[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
distutils_enable_tests pytest | ||
|
||
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV} |