Skip to content

Commit

Permalink
dev-python/irc: version bump to 15.0.6.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
Closes: gentoo#3209
  • Loading branch information
sbraz authored and monsieurp committed Dec 22, 2016
1 parent b98fa8c commit ddd0666
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/irc/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST irc-11.0.1.zip 120409 SHA256 25d818003780fd6d62e93d3ff32580e74c0e527c6290ae14b47af50b58339233 SHA512 fca2fe653d921c9ec65dfb2b072c16658d88d4a22ae91568b1eaf722a90179920808db157f587afe6de0055af3a04a528eb9022122e539150e5635f05b58f466 WHIRLPOOL dd9b9e8624e6bd86d27fead1f3006a2b80832d236ad21f50c147c07a27b2cc4933d68efd951dece44398dbc0299b73ba7a98e4eff2061d0e3a8a01833518113b
DIST irc-15.0.2.tar.gz 81790 SHA256 23893c1fb21826fd9b3edf6ef49b0e1080c846761900ab06b4f1980f5cb8e2e3 SHA512 5f6daa539a9ae665b0153d97ab11f246040963d9109d84efde0a92cbe200c2a6e8126120eee11b4bc92d65d415946627116b62cde07bebeb68a7105af40f98ab WHIRLPOOL 1f28b3e343328a2c78af406944fcfac4be25a61834e1807d7a1636834a2ea9fa9775856380e8ea75df7917913756a4b971e76ab47a06e0379304dfd2e5d81e61
DIST irc-15.0.5.tar.gz 82138 SHA256 f4ac9678e7e9b451d7852dd67ee216ca9debec7004b16c9708e83137142b30cf SHA512 d9e5eadd02aba00262fee5fc67d52e1caebfcf715466bc104df76e5deee5559692436517b21c08918cb41fbf172bb81c11147f86c488da3441a72efd2c6832b9 WHIRLPOOL 85f5c479c6047e1cb85056489aee0e5e96148865a34a6c31bf8aeddd16ed7f07328efe53bd44327be8f74bc913d039472c01ea922d81e1447194643103a0d348
DIST irc-15.0.6.tar.gz 81996 SHA256 986706eb76da86f14ebd69f7955a2ae132fe45dde60e67ddd9c6c50b7dc914ee SHA512 48240eb496a3c88310f02cf092b8e19e4aa8d8dc165a9a8a39c313490a69ecc29ac67db297436df5e86e7253e2481bd19bc0429ea9cc359089a5cd6179125c0f WHIRLPOOL 33dbe34c49027d3dad6d1b3b322713185ebabb1607dde8a4f53ab9f48294dd5d592cffb98e66572d33e0e68a5a394eab2c2d3a5021af2ffa7b761792774bab5f
64 changes: 64 additions & 0 deletions dev-python/irc/irc-15.0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit distutils-r1

DESCRIPTION="IRC client framework written in Python"
HOMEPAGE="https://github.com/jaraco/irc"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"

RDEPEND="
dev-python/jaraco-collections[${PYTHON_USEDEP}]
>=dev-python/jaraco-functools-1.5[${PYTHON_USEDEP}]
>=dev-python/jaraco-itertools-1.8[${PYTHON_USEDEP}]
dev-python/jaraco-logging[${PYTHON_USEDEP}]
dev-python/jaraco-stream[${PYTHON_USEDEP}]
dev-python/jaraco-text[${PYTHON_USEDEP}]
dev-python/more-itertools[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
>=dev-python/tempora-1.6[${PYTHON_USEDEP}]
"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
>=dev-python/pytest-2.8[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
)
doc? (
dev-python/rst-linker[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
)
"

python_compile_all() {
if use doc; then
cd docs || die
sphinx-build . _build/html || die
HTML_DOCS=( docs/_build/html/. )
fi
}

python_test() {
py.test || die "Tests failed with ${EPYTHON}"
}

python_install_all() {
if use examples; then
insinto "/usr/share/doc/${PF}"
docompress -x "/usr/share/doc/${PF}/scripts"
doins -r scripts
fi
distutils-r1_python_install_all
}

0 comments on commit ddd0666

Please sign in to comment.