Skip to content

Commit

Permalink
dev-libs/protobuf: version bump to 3.0.2 and 3.1.0.
Browse files Browse the repository at this point in the history
  • Loading branch information
lluixhi authored and monsieurp committed Dec 8, 2016
1 parent 1bb8d6b commit dde8d15
Show file tree
Hide file tree
Showing 3 changed files with 225 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-libs/protobuf/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST protobuf-2.5.0.tar.bz2 1866763 SHA256 13bfc5ae543cf3aa180ac2485c0bc89495e3ae711fc6fab4f8ffe90dfb4bb677 SHA512 5994b3669808b82fef5c860ecad36358c0767f84acac877e7bfcf722e59d972835a955714149bdd4158fbd1328a51d01397a563991d26475351ee72be48142ee WHIRLPOOL 7e6786e1f20bf253d0e386a95c2bbfe1b443f484d492f97552cadcea62c24461436aa88130e3ff20b4dc9f352c101458cb8c03686f1cc4e6e2133b6e78f5b70d
DIST protobuf-2.6.1.tar.bz2 2021416 SHA256 ee445612d544d885ae240ffbcbf9267faa9f593b7b101f21d58beceb92661910 SHA512 8b092b87fcd79223db199cd3d330f3d43689b47f345aa4e34028dcf1680d609a5d5a89ab08588e817b566d3b265834c38f1db580bc1c144b512ce74d35f2a174 WHIRLPOOL b8d7f5e6b85670520435fd1107eb67035c822c2dad9689dadc29754de3bf8076ac256cf3fe3e719e99c0ccb03ed78edecb91afbe96b611073b60ae3fb3f29b1a
DIST protobuf-3.0.0_beta3_p1.tar.gz 3673779 SHA256 494726c9a6a45a20cd085795a26e4f05627e9b3b1fa5ab21a8b0edc5db8173dc SHA512 bebe655ffa6f8dd9bfbf4d2fcce160de6d45f50fd802b8907833cde3f232b7b44186d06fe9cc01ed5dc7b4a040fd3069e2ec7d2704da596e8d3af80f8dba7e8b WHIRLPOOL d35dca8e402741e4d30c9c787f5927c7fe7f22619ddb3ca20d302c27fbeb929cecd55cc7e6785b28acb76c89893d2baf7fce3f685a3f186006e1e30a2901ae1b
DIST protobuf-3.0.2.tar.gz 3917853 SHA256 b700647e11556b643ccddffd1f41d8cb7704ed02090af54cc517d44d912d11c1 SHA512 28eb8814555b0fe2cd57da6caf46802697a9612fccb3bba3ae7a379352437f81a18c1f6ab7242a22abea59c1ff9b06dcb6e2b52a97aa1a15cea6485ffc3c10c2 WHIRLPOOL 5c70def13be5e61d9405a24fdfc1efe9caee0b63c87f74e12f3d121801ecdc410e142eab80d8d4b49ebfe0c4f3cd13b2d77a17ec303978fec317265991a1f5a8
DIST protobuf-3.1.0.tar.gz 4051503 SHA256 0a0ae63cbffc274efb573bdde9a253e3f32e458c41261df51c5dbc5ad541e8f7 SHA512 8d3289a16944c255bd1cceab696e515e52467f2bfe1cc10f6b32fabdf082d5acdc248ec9cadc572223a24d04d431f75921076153109cea2f90ee533f502ab47a WHIRLPOOL b8a0bee9ff549c8da45c2b56b12aafbed5807959cdb11b3888a0f30fd0d6df83a72f3c6ef9e266522754b8901792f65235a6e81a8b0f74cee15d59ecbe6dee68
112 changes: 112 additions & 0 deletions dev-libs/protobuf/protobuf-3.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,112 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
inherit autotools elisp-common flag-o-matic python-r1 toolchain-funcs multilib-minimal

# If you bump this package, also consider bumping the official language bindings!
# At the current time these are java and python.
MY_PV=${PV/_beta/-beta-}
MY_PV=${MY_PV/_p/.}

DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
HOMEPAGE="https://github.com/google/protobuf/ https://developers.google.com/protocol-buffers/"
SRC_URI="https://github.com/google/protobuf/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0/10"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="emacs examples java python static-libs test vim-syntax zlib"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

DEPEND="
emacs? ( virtual/emacs )
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
test? ( dev-cpp/gmock[${MULTILIB_USEDEP}] )"

# This is provided for backwards compatibility due to (likely incorrect) use in consumers.
PDEPEND="
java? ( dev-java/protobuf-java )
python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )"

DOCS=( CHANGES.txt CONTRIBUTORS.txt README.md )

PATCHES=(
"${FILESDIR}/${PN}-2.5.0-emacs-24.4.patch"
"${FILESDIR}/${PN}-2.6.1-protoc-cmdline.patch"
"${FILESDIR}/${PN}-3.0.0_beta2-disable-local-gmock.patch"
)

S="${WORKDIR}/${PN}-${MY_PV}"
src_prepare() {
append-cppflags -DGOOGLE_PROTOBUF_NO_RTTI
default
eautoreconf
}

multilib_src_configure() {
local myeconfargs=(
$(use_enable static-libs static)
$(use_with zlib)
)
if tc-is-cross-compiler; then
# The build system wants `protoc` when building, so we need a copy that
# runs on the host. This is more hermetic than relying on the version
# installed in the host being the exact same version.
mkdir -p "${WORKDIR}"/build || die
pushd "${WORKDIR}"/build >/dev/null || die
ECONF_SOURCE=${S} econf_build "${myeconfargs[@]}"
myeconfargs+=( --with-protoc="${PWD}"/src/protoc )
popd >/dev/null || die
fi
ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
}

multilib_src_compile() {
if tc-is-cross-compiler; then
emake -C "${WORKDIR}"/build/src protoc
fi

default

if use emacs; then
elisp-compile "${S}"/editors/protobuf-mode.el
fi
}

multilib_src_test() {
emake check
}

multilib_src_install_all() {
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
doins editors/proto.vim
insinto /usr/share/vim/vimfiles/ftdetect/
doins "${FILESDIR}/proto.vim"
fi

if use emacs; then
elisp-install "${PN}" editors/protobuf-mode.el*
elisp-site-file-install "${FILESDIR}/70${PN}-gentoo.el"
fi

if use examples; then
DOCS+=( examples )
docompress -x /usr/share/doc/"${PF}"/examples
fi

einstalldocs
}

pkg_postinst() {
use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}
111 changes: 111 additions & 0 deletions dev-libs/protobuf/protobuf-3.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
inherit autotools elisp-common flag-o-matic python-r1 toolchain-funcs multilib-minimal

# If you bump this package, also consider bumping the official language bindings!
# At the current time these are java and python.
MY_PV=${PV/_beta/-beta-}
MY_PV=${MY_PV/_p/.}

DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
HOMEPAGE="https://github.com/google/protobuf/ https://developers.google.com/protocol-buffers/"
SRC_URI="https://github.com/google/protobuf/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0/11"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="emacs examples java python static-libs test vim-syntax zlib"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

DEPEND="
emacs? ( virtual/emacs )
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
test? ( dev-cpp/gmock[${MULTILIB_USEDEP}] )"

# This is provided for backwards compatibility due to (likely incorrect) use in consumers.
PDEPEND="
java? ( dev-java/protobuf-java )
python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )"

DOCS=( CHANGES.txt CONTRIBUTORS.txt README.md )

PATCHES=(
"${FILESDIR}/${PN}-2.6.1-protoc-cmdline.patch"
"${FILESDIR}/${PN}-3.0.0_beta2-disable-local-gmock.patch"
)

S="${WORKDIR}/${PN}-${MY_PV}"
src_prepare() {
append-cppflags -DGOOGLE_PROTOBUF_NO_RTTI
default
eautoreconf
}

multilib_src_configure() {
local myeconfargs=(
$(use_enable static-libs static)
$(use_with zlib)
)
if tc-is-cross-compiler; then
# The build system wants `protoc` when building, so we need a copy that
# runs on the host. This is more hermetic than relying on the version
# installed in the host being the exact same version.
mkdir -p "${WORKDIR}"/build || die
pushd "${WORKDIR}"/build >/dev/null || die
ECONF_SOURCE=${S} econf_build "${myeconfargs[@]}"
myeconfargs+=( --with-protoc="${PWD}"/src/protoc )
popd >/dev/null || die
fi
ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
}

multilib_src_compile() {
if tc-is-cross-compiler; then
emake -C "${WORKDIR}"/build/src protoc
fi

default

if use emacs; then
elisp-compile "${S}"/editors/protobuf-mode.el
fi
}

multilib_src_test() {
emake check
}

multilib_src_install_all() {
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax
doins editors/proto.vim
insinto /usr/share/vim/vimfiles/ftdetect/
doins "${FILESDIR}/proto.vim"
fi

if use emacs; then
elisp-install "${PN}" editors/protobuf-mode.el*
elisp-site-file-install "${FILESDIR}/70${PN}-gentoo.el"
fi

if use examples; then
DOCS+=( examples )
docompress -x /usr/share/doc/"${PF}"/examples
fi

einstalldocs
}

pkg_postinst() {
use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit dde8d15

Please sign in to comment.