Skip to content

Commit

Permalink
app-arch/tar: Bump to version 1.32.90
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Dec 2, 2019
1 parent 2db7d94 commit de068bc
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/tar/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST tar-1.32.90.tar.xz 2145976 BLAKE2B 95f1442da87bcbd58e0a6aad303b8c9da9179cc32a6e835d3fbe2e090ad4316e96265a54f573906b262034b92d8d3e56f3ff2609145249bd16dd4ea2a79bb601 SHA512 a42703b73ec3c1f462849469f00dd190a0164972fd2e97f128c3b559a6e9c79e87d5bbf47fca17ca9f8b6810221fbc727b6c15e38693256d9e43a2c2a2d7b593
DIST tar-1.32.tar.bz2 2947264 BLAKE2B 4e380a9a2f84a2af5130464e1b298ae6acf02ee459cbca20dd0991c2859785e5aac789d57b87b32e8b45d89985b6414af9dd37161385da9568d6030c5aa42c0e SHA512 3139e87112123269ee0600243b3ea081687cc93667bef5832bfe3c785c1be622f520f00fcfbdf44ad1d3247866d0ecfe347a85bbfec38eb38fa1014baef566f6
80 changes: 80 additions & 0 deletions app-arch/tar/tar-1.32.90.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic

DESCRIPTION="Use this to make tarballs :)"
HOMEPAGE="https://www.gnu.org/software/tar/"
SRC_URI="mirror://gnu/tar/${P}.tar.xz
mirror://gnu-alpha/tar/${P}.tar.xz"

LICENSE="GPL-3+"
SLOT="0"
[[ -n "$(ver_cut 3)" ]] && [[ "$(ver_cut 3)" -ge 90 ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="acl elibc_glibc minimal nls selinux static userland_GNU xattr"

LIB_DEPEND="acl? ( virtual/acl[static-libs(+)] )"

RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
selinux? ( sys-libs/libselinux )"
DEPEND="${RDEPEND}
nls? ( >=sys-devel/gettext-0.10.35 )
static? ( ${LIB_DEPEND} )
xattr? ( elibc_glibc? ( sys-apps/attr ) )"

src_prepare() {
default

if ! use userland_GNU ; then
sed -i \
-e 's:/backup\.sh:/gbackup.sh:' \
scripts/{backup,dump-remind,restore}.in \
|| die "sed non-GNU"
fi
}

src_configure() {
use static && append-ldflags -static
local myeconfargs=(
--bindir="${EPREFIX}"/bin
--enable-backup-scripts
--libexecdir="${EPREFIX}"/usr/sbin
$(usex userland_GNU "" "--program-prefix=g")
$(use_with acl posix-acls)
$(use_enable nls)
$(use_with selinux)
$(use_with xattr xattrs)
)
FORCE_UNSAFE_CONFIGURE=1 econf "${myeconfargs[@]}"
}

src_install() {
default

local p=$(usex userland_GNU "" "g")
if [[ -z ${p} ]] ; then
# a nasty yet required piece of baggage
exeinto /etc
doexe "${FILESDIR}"/rmt
fi

# autoconf looks for gtar before tar (in configure scripts), hence
# in Prefix it is important that it is there, otherwise, a gtar from
# the host system (FreeBSD, Solaris, Darwin) will be found instead
# of the Prefix provided (GNU) tar
if use prefix ; then
dosym tar /bin/gtar
fi

mv "${ED}"/usr/sbin/${p}backup{,-tar} || die
mv "${ED}"/usr/sbin/${p}restore{,-tar} || die

if use minimal ; then
find "${ED}"/etc "${ED}"/*bin/ "${ED}"/usr/*bin/ \
-type f -a '!' '(' -name tar -o -name ${p}tar ')' \
-delete || die
fi
}

0 comments on commit de068bc

Please sign in to comment.