Skip to content

Commit

Permalink
dev-ruby/path_expander: add 1.0.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
graaff committed Mar 24, 2018
1 parent 5074dcf commit de0c3f8
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/path_expander/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST path_expander-1.0.2.gem 12800 BLAKE2B 99bc161e39803b01f2bac48eaca063a00473db1cf2f033837a1ffc187847a32aa5a88077d163b8acb2a75171a5fb134f47ee6d82cc8105d4ce297919ea8fce76 SHA512 550d20be7f3379ccb30e2e0c86c26348103d7d11d7b5d21c684c341cdb7cf1aaa29886c7b1210265af7bbc1853b8c26a0048d6bd40a8a2752938101e64a23468
DIST path_expander-1.0.3.gem 13312 BLAKE2B 79be135b73f192e86cbdfae7a203434c4c8b1535c2db959141db79fd6a2eedd92c6436376485ccf3f8c15efcda31de40a7dd5a8c71eece17ca1e72f7bd7e95b7 SHA512 e05d66759a863f69845e41da1677f2020111e85e206d58acb93d18e044833f70b9420929e731884e6bcd156988ca3ae836f9913697ec85756a71f68499469ef2
30 changes: 30 additions & 0 deletions dev-ruby/path_expander/path_expander-1.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby22 ruby23 ruby24 ruby25"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"

inherit ruby-fakegem

DESCRIPTION="Pre-process CLI arguments expanding directories into their constituent files"
HOMEPAGE="https://github.com/seattlerb/path_expander"
LICENSE="MIT"

KEYWORDS="~amd64 ~x86"
SLOT="1"
IUSE=""

all_ruby_prepare() {
# Fix tests depending on sort order
sed -i -e '/test_process_args_dir/,/^ end/ s:^:#:' \
-e '33 s/$/.sort/' \
-e '83 s/act/act.sort/' \
test/test_path_expander.rb || die
}

each_ruby_test() {
${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
}

0 comments on commit de0c3f8

Please sign in to comment.