Skip to content

Commit

Permalink
dev-python/protobuf-python: fix tests
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/934062
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jun 13, 2024
1 parent f4c0928 commit de15b02
Show file tree
Hide file tree
Showing 2 changed files with 22 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
See also https://github.com/protocolbuffers/protobuf/pull/9098
--- a/google/protobuf/internal/json_format_test.py
+++ b/google/protobuf/internal/json_format_test.py
@@ -1060,7 +1060,7 @@ class JsonFormatTest(JsonFormatBase):
def testInvalidTimestamp(self):
message = json_format_proto3_pb2.TestTimestamp()
text = '{"value": "10000-01-01T00:00:00.00Z"}'
- self.assertRaisesRegexp(
+ self.assertRaisesRegex(
json_format.ParseError, 'Failed to parse value field: '
'time data \'10000-01-01T00:00:00\' does not match'
' format \'%Y-%m-%dT%H:%M:%S\' at TestTimestamp.value.',
@@ -1097,7 +1097,7 @@ class JsonFormatTest(JsonFormatBase):
def testInvalidOneof(self):
message = json_format_proto3_pb2.TestOneof()
text = '{"oneofInt32Value": 1, "oneofStringValue": "2"}'
- self.assertRaisesRegexp(
+ self.assertRaisesRegex(
json_format.ParseError, 'Message type "proto3.TestOneof"'
' should not have multiple "oneof_value" oneof fields at "TestOneof".',
json_format.Parse, text, message)
1 change: 1 addition & 0 deletions dev-python/protobuf-python/protobuf-python-4.22.5.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -56,6 +56,7 @@ PARENT_PATCHES=(

# Here for patches within "python/" subdirectory.
PATCHES=(
"${FILESDIR}/${PN}-4.22.5-python.patch"
)

python_prepare_all() {
Expand Down

0 comments on commit de15b02

Please sign in to comment.