Skip to content

Commit

Permalink
dev-python/boto3: Bump to 1.26.25
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 8, 2022
1 parent 5c1c21f commit de58952
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/boto3/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,4 +6,5 @@ DIST boto3-1.26.21.gh.tar.gz 573776 BLAKE2B a608b875d052cb895cae4bc20924836284dd
DIST boto3-1.26.22.gh.tar.gz 574580 BLAKE2B 35027efcfaa0ec27ff7e8769af32c4ea621fea842a84b689f76ef412305318a16fd3fe3b139f00a66f91892455a14cbb9753ea4f3d07ac24e4e18725cb6c7fb7 SHA512 5035f8be58384b1c8634ab801dd3930043febfbcc5d23f1c4385ce7e4aac37fda61a04ca3adcf86010db21f8d26403b491990746c578d91fa173c9629bb501bb
DIST boto3-1.26.23.gh.tar.gz 575113 BLAKE2B a39f1546f5733de801f00df97a383f45a6f96ba608f441f4e889ed9b9362bef4b84bfe61a817e4e39cafb25777d4f75021130b05fe14e328006c409a77dd7eeb SHA512 92de04f42e5e94ab1b7dd6aa1d4048fdd372814ecec7742ade8b0a49a871748921f5ac600a421c412c50474e21334e910eb64ce2f3abfaf1e1add391e6dc346b
DIST boto3-1.26.24.gh.tar.gz 575745 BLAKE2B 2dd132d9daf9dafd81549664b23bb457211adfde1da5279de9519b1a30e0f5921f763f4770f7061011de97d7a52a05cdff57ddede2c3b95f8d048398bd160e9c SHA512 ab1943be54a5979a7e73f9fafc2937528c9a010f3c8244e2951fe802a7a20e57414b2565d6b6628890f913c76386aeaa0583c01901798bcc5080e48aa7da74e4
DIST boto3-1.26.25.gh.tar.gz 576015 BLAKE2B 55d94441c1fa2668efa31390dbe972b354a4ab69d7825b2ecdcee47d03d44cb2533b428595dfdecc374a1164429166bb1740550334e2da1ff4a20ae31a53bb83 SHA512 c85b3b591926881a08e5143413848fd14b9cbe11c376970e71fe5fc6851a43448941583b73dc40cc0335c6749e7ea31eb8b4ef4d38dcf630d68693b94757bb07
DIST boto3-1.26.8.gh.tar.gz 557012 BLAKE2B 211bb7441acc8b1f901ebf5251288dc7c9073fa6e34f5a34426424ef064efb0fb3031deaf48ef336ec43bb015f95f618598da43d12ec83cbf814e1b4097b28a0 SHA512 738190cedfb0b85d3a1e9558b03e7f2fb14e43b152bc9627fd95c8ecc4a0ddc17f4c87ccb6129c1fbf5f47db9eea4dbc5c2cfbb69b903bc6f3ff417ef86b6f6b
68 changes: 68 additions & 0 deletions dev-python/boto3/boto3-1.26.25.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit distutils-r1 multiprocessing

DESCRIPTION="The AWS SDK for Python"
HOMEPAGE="
https://github.com/boto/boto3/
https://pypi.org/project/boto3/
"
LICENSE="Apache-2.0"
SLOT="0"

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/boto3"
inherit git-r3
BOTOCORE_PV=${PV}
else
SRC_URI="
https://github.com/boto/boto3/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"

# botocore is x.(y+3).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
fi

RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

distutils_enable_sphinx docs/source \
'dev-python/guzzle_sphinx_theme'
distutils_enable_tests pytest

python_prepare_all() {
# don't lock versions to narrow ranges
sed -e '/botocore/ d' \
-e '/jmespath/ d' \
-e '/s3transfer/ d' \
-i setup.py || die

# do not rely on bundled deps in botocore (sic!)
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die

distutils-r1_python_prepare_all
}

python_test() {
epytest tests/{functional,unit} -n "$(makeopts_jobs)"
}

0 comments on commit de58952

Please sign in to comment.