Skip to content

Commit

Permalink
gnome-base/nautilus: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
pacho2 committed Nov 14, 2015
1 parent cbe160f commit dea7bcd
Show file tree
Hide file tree
Showing 2 changed files with 124 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/nautilus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST nautilus-3.14.2.tar.xz 3344428 SHA256 b2c9e13ba896a15101abf5d5fe30e291243e6030e0c84e8eb5df1e7bd90c10a5 SHA512 9d07878fc2474c7444fb7c573ce1886514b82ecb386365e608de81473184791daf17875b7ea471a7bef2c84df0d6d06b207223c7b5ec64d195e46865440ceff6 WHIRLPOOL c29af2fe684abeeffe58d6ba872b97b846db5d97cace8b73196fb77a024262f82df1908bac975b67938db9a12091dee681f1d827a551eb2610d11a6db2164495
DIST nautilus-3.16.2.tar.xz 3325172 SHA256 3e7ecdda3a47b6ad03098270940aa506782866fa3602d91e711d99f96741478f SHA512 06b4c338fe2295122b35053d754d8bb797cfeedf736db3a52dd290d7742d79fbbf50c23a3d59e62ef937f3ebf6b67f26f12a652b75d42a8b44462a3e1eef1be1 WHIRLPOOL bd6d3aee888474e247f19cf95fecead27a86296afcab04de7052b8403df95d9b776b0c93bad04b748ba638d4edfc3fc11e8fbce50142a0aad517a0ed35038f9c
DIST nautilus-3.18.2.tar.xz 3316652 SHA256 68dcf668e2ca93126a899d2e236ef37af2aea93e3fc25eee23ccd7ba911d424a SHA512 ac40683027f3318bbea23feee7a654502106932b049faa4bcbc1340a7fbafaa7e8857237b1ec5a0bcbee25e8d75eb1e9c8136cd5b748f9009e72589e73908e86 WHIRLPOOL 317258a102cf89497cfe87965614f77bff189ad3539c61f777b0d19bd0f8febe316a1389f47256f65de50b23b8c79382ac5b45cfb94919c8bf2a7e1fbe26a304
123 changes: 123 additions & 0 deletions gnome-base/nautilus/nautilus-3.18.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,123 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes" # Needed with USE 'sendto'

inherit eutils gnome2 readme.gentoo virtualx

DESCRIPTION="A file manager for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"

LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
SLOT="0"

# profiling?
IUSE="exif gnome +introspection packagekit +previewer sendto tracker xmp"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"

# FIXME: tests fails under Xvfb, but pass when building manually
# "FAIL: check failed in nautilus-file.c, line 8307"
RESTRICT="test"

# FIXME: selinux support is automagic
# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
# and 2.30.0
COMMON_DEPEND="
>=dev-libs/glib-2.45.7:2[dbus]
>=x11-libs/pango-1.28.3
>=x11-libs/gtk+-3.17.5:3[introspection?]
>=dev-libs/libxml2-2.7.8:2
>=gnome-base/gnome-desktop-3:3=
gnome-base/dconf
>=gnome-base/gsettings-desktop-schemas-3.8.0
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrender
exif? ( >=media-libs/libexif-0.6.20 )
introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
tracker? ( >=app-misc/tracker-0.16:= )
xmp? ( >=media-libs/exempi-2.1.0 )
"
DEPEND="${COMMON_DEPEND}
>=dev-lang/perl-5
>=dev-util/gdbus-codegen-2.33
>=dev-util/gtk-doc-am-1.10
>=dev-util/intltool-0.40.1
sys-devel/gettext
virtual/pkgconfig
x11-proto/xproto
"
RDEPEND="${COMMON_DEPEND}
packagekit? ( app-admin/packagekit-base )
sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )
"

# For eautoreconf
# gnome-base/gnome-common
# dev-util/gtk-doc-am"

PDEPEND="
gnome? (
>=x11-themes/gnome-icon-theme-1.1.91
x11-themes/gnome-icon-theme-symbolic )
tracker? ( >=gnome-extra/nautilus-tracker-tags-0.12 )
previewer? ( >=gnome-extra/sushi-0.1.9 )
sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
>=gnome-base/gvfs-1.14[gtk]
"
# Need gvfs[gtk] for recent:/// support

src_prepare() {
if use previewer; then
DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
To activate the previewer, select a file and press space; to
close the previewer, press space again."
fi

# Remove -D*DEPRECATED flags. Don't leave this for eclass! (bug #448822)
sed -e 's/DISABLE_DEPRECATED_CFLAGS=.*/DISABLE_DEPRECATED_CFLAGS=/' \
-i configure || die "sed failed"

gnome2_src_prepare
}

src_configure() {
DOCS="AUTHORS HACKING MAINTAINERS NEWS README* THANKS"
gnome2_src_configure \
--disable-profiling \
--disable-update-mimedb \
$(use_enable exif libexif) \
$(use_enable introspection) \
$(use_enable packagekit) \
$(use_enable sendto nst-extension) \
$(use_enable tracker) \
$(use_enable xmp)
}

src_test() {
gnome2_environment_reset
unset DBUS_SESSION_BUS_ADDRESS
export GSETTINGS_BACKEND="memory"
Xemake check
unset GSETTINGS_BACKEND
}

src_install() {
use previewer && readme.gentoo_create_doc
gnome2_src_install
}

pkg_postinst() {
gnome2_pkg_postinst

if use previewer; then
readme.gentoo_print_elog
else
elog "To preview media files, emerge nautilus with USE=previewer"
fi
}

0 comments on commit dea7bcd

Please sign in to comment.