forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/cinnamon-settings-daemon: Version bump
Package-Manager: portage-2.3.0_rc1
- Loading branch information
Showing
2 changed files
with
100 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST cinnamon-settings-daemon-2.8.3.tar.gz 2935149 SHA256 bc04333674ee10886b6c2644bd74c21ce6d3f6f1e005ebce63693cb14bb1a298 SHA512 a66ab0943f4a370fb203ba73dfa9f938ab2fc418c7876b7a048fc438ed8eaef3f5f7789ce86c0c2039ed61473c1b3fb9c60205571140291448854c03cba36f76 WHIRLPOOL 93ecc021ffa76a493d65fcd001253da6ebbd2c8f92be716f4d0de0df53867fb24177a6f31027611586e965d1e378a8b53662dd3c5a73df026d13d3a7fd5ae080 | ||
DIST cinnamon-settings-daemon-2.8.4.tar.gz 2935478 SHA256 2f7e8764a842d9b4f21c1e6d5321e4101720f1600462b5452d14a061b608c584 SHA512 fab449efdfe4f12d17d61299b9c264d0bd70d88811406da68eab48943dbcd75ef3a87551eba653660efc4006c45f7eaa59d9ac3616a6da6808d35e59dd0a6d7f WHIRLPOOL bcdd93d53352d649f81a43730f4116508ad24379ba5e5c46a1dc9b867a653b9172b50b78b06450159f4e785bab8e2a604f172d2553dd949d693c358695ba4f17 |
99 changes: 99 additions & 0 deletions
99
gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-2.8.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,99 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
GNOME2_LA_PUNT="yes" | ||
|
||
inherit autotools eutils gnome2 virtualx | ||
|
||
DESCRIPTION="Cinnamon's settings daemon" | ||
HOMEPAGE="http://cinnamon.linuxmint.com/" | ||
SRC_URI="https://github.com/linuxmint/cinnamon-settings-daemon/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+colord cups input_devices_wacom smartcard systemd" | ||
|
||
# udev is non-optional since lots of plugins, not just gudev, pull it in | ||
RDEPEND=" | ||
>=dev-libs/glib-2.38:2 | ||
>=gnome-base/libgnomekbd-3.6 | ||
>=gnome-base/librsvg-2.36.2 | ||
>=gnome-extra/cinnamon-desktop-2.6.3:0= | ||
media-libs/fontconfig | ||
>=media-libs/lcms-2.2:2 | ||
media-libs/libcanberra:0=[gtk3] | ||
>=media-sound/pulseaudio-0.9.16:0= | ||
sys-apps/dbus | ||
>=sys-auth/polkit-0.97 | ||
x11-libs/gdk-pixbuf:2 | ||
>=x11-libs/gtk+-3.9.10:3 | ||
>=x11-libs/libnotify-0.7.3:0= | ||
x11-libs/libX11 | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXi | ||
x11-libs/libxklavier | ||
virtual/libgudev:= | ||
colord? ( >=x11-misc/colord-0.1.27:= ) | ||
cups? ( >=net-print/cups-1.4[dbus] ) | ||
input_devices_wacom? ( | ||
>=dev-libs/libwacom-0.7 | ||
x11-drivers/xf86-input-wacom | ||
x11-libs/libXtst ) | ||
smartcard? ( >=dev-libs/nss-3.11.2 ) | ||
|| ( >=sys-power/upower-0.9.11:= sys-power/upower-pm-utils ) | ||
systemd? ( sys-apps/systemd:0= ) | ||
!systemd? ( sys-auth/consolekit:0= ) | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-libs/libxml2:2 | ||
>=dev-util/intltool-0.37.1 | ||
x11-proto/kbproto | ||
virtual/pkgconfig | ||
" | ||
|
||
src_prepare() { | ||
# make colord and wacom optional | ||
eapply "${FILESDIR}"/${PN}-2.6.2-optional.patch | ||
|
||
# Disable broken test | ||
sed -e '/g_test_add_func ("\/color\/edid/d' \ | ||
-i plugins/color/gcm-self-test.c || die | ||
|
||
# Fix intltool unittest | ||
cat >>"${S}"/po/POTFILES.in <<EOF | ||
data/org.cinnamon.settings-daemon.peripherals.wacom.gschema.xml.in.in | ||
data/org.cinnamon.settings-daemon.plugins.background.gschema.xml.in | ||
data/org.cinnamon.settings-daemon.plugins.background.gschema.xml.in.in | ||
plugins/datetime/org.cinnamon.settingsdaemon.datetimemechanism.policy.in | ||
plugins/keyboard/csd-keyboard-xkb.c | ||
plugins/wacom/csd-wacom-device.c | ||
plugins/wacom/csd-wacom-osd-window.c | ||
plugins/wacom/org.cinnamon.settings-daemon.plugins.wacom.policy.in.in | ||
EOF | ||
|
||
eautoreconf | ||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
# no point in disabling gudev since other plugins pull it in | ||
gnome2_src_configure \ | ||
--disable-static \ | ||
--enable-gudev \ | ||
--enable-man \ | ||
--enable-polkit \ | ||
$(use_enable colord color) \ | ||
$(use_enable cups) \ | ||
$(use_enable smartcard smartcard-support) \ | ||
$(use_enable systemd logind) \ | ||
$(use_enable input_devices_wacom wacom) | ||
} | ||
|
||
src_test() { | ||
Xemake check | ||
} |