forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.26
- Loading branch information
Michael Sterrett
committed
Jan 8, 2016
1 parent
b655fd1
commit deb6300
Showing
2 changed files
with
89 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST AlephOne-20100424.tar.bz2 3180896 SHA256 d97089890ce99952027eaf6185baa6cb01b26c2882dfca9e68816dfe7076a5e6 SHA512 b246b662f4bf820238c09fbb6bc55289d0db0a9b5ba15ab2b91a53f93666e81583834fd8a64497074a2e270a2055de24b3be93bb56d58715f9d213b1f4c92494 WHIRLPOOL 3074f6c4ba4925b8a0f7718bdfb0d1084155421397a7604febfeae473635b970b3842152b9a3e200f2bc642790a0dc51e689aa3b18de2235d5697105060c7f93 | ||
DIST AlephOne-20120514.tar.bz2 4716348 SHA256 6a7797af74cf3fae7f5505e64ffe57c56f7331521cb569bcc8b7d7041cb3718b SHA512 71e54341221485765b63c7c723f95e04d41c8e2cecf6bc3f885efc178f4c75fd88cdffe703c4bf41a5e7101fd8cef33797d00cd249e211b7de1b22fc639b4278 WHIRLPOOL 03ff5bd735a28a3113706f4de5837351404ddede2fabc09d45233b3bb646a9550f00cc1d30710a6f32952c452668e5f764fb427ef5495553f6c49ddcfcaef350 | ||
DIST AlephOne-20150620.tar.bz2 5031898 SHA256 c0f360dfb74a6264f95d375103a74000930cf0439ffb0464f915f5379443e133 SHA512 fb47969137b791f83b111171d7b92b3708597db294ce19fb682ce28c49edcd4cb84a6ce4dcceb6630812a8c676dfe7f39f3fb4642f40ef7086a0d6c6fdeba8df WHIRLPOOL a00150e8c28763d7d01a5d805e449247dc9ff612eb0e9f0aa2d10e7fcf17654342fa31eb5a2eeb3bc756c80cce84dd9664179977900d635e67401036c71a7c10 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,88 @@ | ||
# Copyright 1999-2013 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit autotools eutils games | ||
|
||
MY_P=AlephOne-${PV} | ||
DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon" | ||
HOMEPAGE="http://source.bungie.org/" | ||
SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/AlephOne-${PV}.tar.bz2" | ||
|
||
LICENSE="GPL-3+ BitstreamVera OFL-1.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86" | ||
IUSE="alsa curl ffmpeg mad mpeg sndfile speex vorbis" | ||
|
||
RDEPEND="media-libs/sdl-net | ||
media-libs/sdl-ttf | ||
media-libs/sdl-image[png] | ||
media-libs/libsdl[joystick,opengl,video] | ||
dev-libs/expat | ||
dev-libs/zziplib | ||
dev-libs/boost | ||
media-libs/libpng:0 | ||
virtual/opengl | ||
virtual/glu | ||
alsa? ( media-libs/alsa-lib ) | ||
curl? ( net-misc/curl ) | ||
ffmpeg? ( virtual/ffmpeg ) | ||
mad? ( media-libs/libmad ) | ||
mpeg? ( media-libs/smpeg ) | ||
sndfile? ( media-libs/libsndfile ) | ||
speex? ( media-libs/speex ) | ||
vorbis? ( media-libs/libvorbis )" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \ | ||
"${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \ | ||
|| die | ||
|
||
# try using the system expat - bug #251108 | ||
sed -i \ | ||
-e '/SUBDIRS/ s/Expat//' \ | ||
-e 's/Expat\/libexpat.a/-lexpat/' \ | ||
Source_Files/Makefile.am || die | ||
sed -i -e '/Expat/d' configure.ac || die | ||
rm -r Source_Files/Expat || die | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
egamesconf \ | ||
--enable-lua \ | ||
--enable-opengl \ | ||
$(use_with alsa) \ | ||
$(use_with ffmpeg) \ | ||
$(use_with mad) \ | ||
$(use_with mpeg smpeg) \ | ||
$(use_with sndfile) \ | ||
$(use_with speex) \ | ||
$(use_with vorbis) | ||
} | ||
|
||
src_install() { | ||
default | ||
dogamesbin "${T}"/${PN}.sh | ||
doman docs/${PN}.6 | ||
dohtml docs/*.html | ||
prepgamesdirs | ||
} | ||
|
||
pkg_postinst() { | ||
games_pkg_postinst | ||
echo | ||
elog "Read the docs and install the data files accordingly to play." | ||
echo | ||
elog "If you only want to install one scenario, read" | ||
elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Single_scenario_3" | ||
elog "If you want to install multiple scenarios, read" | ||
elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Multiple_scenarios_3" | ||
echo | ||
} |