Skip to content

Commit

Permalink
app-text/libabw: 0.1.3 version bump, EAPI-7 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Sep 12, 2019
1 parent 083e104 commit debfbc2
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/libabw/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libabw-0.1.2.tar.xz 318400 BLAKE2B ba25542da0d6568530241892dbdba72d2b0dcf667b50e0c1a4e656e0facf82bf77ca8eff8db4d6e57ab699f12d8dad511d32aee291541ffe6460b2ee98590b68 SHA512 a365c1aa047a97a86eee6bce8463646bdf248a51013139ee288402a832fd545586e072d7c7fc11a56f42e3637de9e922197be20d0587e53c51fd80ced409a6cd
DIST libabw-0.1.3.tar.xz 318808 BLAKE2B 234ff797bf3798bc7f14f2b3f0d0cc2d80eda2a6ba2d656288c26e58d53b9798003d7f45ad7c9a0f504da36c8c8ba367f8fe5b565a85fbc6a1f1627d89e7e353 SHA512 0d2646e1bad1e11b3da43714ac5931fc67ffdbc4e7a25a44ef5b6e6a41de1e0ae14596b4a87cceb07bf56dbbe9344622b3d60afcb054ee0ab8577ca8e9b5c289
45 changes: 45 additions & 0 deletions app-text/libabw/libabw-0.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic

DESCRIPTION="Library parsing abiword documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libabw"
SRC_URI="https://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="doc static-libs"

BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
RDEPEND="
dev-libs/librevenge
dev-libs/libxml2
sys-libs/zlib
"
DEPEND="${RDEPEND}
>=dev-libs/boost-1.46
sys-devel/libtool
"

src_configure() {
# bug 619470
append-cxxflags -std=c++14

local myeconfargs=(
$(use_with doc docs)
$(use_enable static-libs static)
)
econf "${myeconfargs[@]}"
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
}

0 comments on commit debfbc2

Please sign in to comment.