Skip to content

Commit

Permalink
app-shells/pdmenu: version bump, comaintain
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Ben Kohler <[email protected]>
  • Loading branch information
benkohler committed Jan 6, 2021
1 parent 533d8a4 commit decdcc3
Show file tree
Hide file tree
Showing 3 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/pdmenu/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pdmenu-1.3.6.tar.gz 160265 BLAKE2B 7b5a391e4f2ace71bbf7c9a9c184c997a8db91907d61dbcd79cda3112a5e6319942b3dc57bee19701b417a18689f57cb24f03bf38b9fcc064f3412ee175bef95 SHA512 2a930f98f49c3c94687fb403eb186ddc51fec67068c6b4b8dd6694cadb9fefb6802f878efe6e2caed62ddf68aeae36ec80fc9e56ca268021e32dee819f001fb5
DIST pdmenu_1.3.4.tar.gz 161002 BLAKE2B 51fb2d0384df4b545f908e081e87a1d7414b22a5c1d9e2dffb2ac5f7d4069c7e2e9de8a1bde459a1fed34c8159f37aff8ef20b69e4817e28f9730500b26e654d SHA512 2540b3040a799f4682de1014f8da750501000cef7080ea24b066a7e44971e33452a25e3885849bc47a156727641c4acb8d1268d3c16a2aab2cb37d510f50f3ad
4 changes: 4 additions & 0 deletions app-shells/pdmenu/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,8 @@
<maintainer type="person">
<email>[email protected]</email>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Ben Kohler</name>
</maintainer>
</pkgmetadata>
61 changes: 61 additions & 0 deletions app-shells/pdmenu/pdmenu-1.3.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="A simple console menu program"
HOMEPAGE="http://joeyh.name/code/pdmenu/"
SRC_URI="https://dev.gentoo.org/~bkohler/dist/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~x86"
IUSE="nls gpm examples"

DEPEND="
sys-libs/slang
gpm? ( sys-libs/gpm )
nls? ( sys-devel/gettext )"

RESTRICT="test"

PATCHES=(
"${FILESDIR}"/${PN}-impl-dec.patch
)

DOCS=( doc/ANNOUNCE doc/BUGS doc/TODO )

src_prepare() {
default
sed \
-e 's:\(-o pdmenu\):$(LDFLAGS) \1:g' \
-i Makefile || die
}

src_configure() {
CC=$(tc-getCC) econf \
$(use_with gpm) \
$(use_enable nls)
}

src_compile() {
emake CC=$(tc-getCC)
}

src_install() {
dobin "${PN}"
use examples && dodoc -r examples
mv "doc/${PN}.man" "doc/${PN}.1" || die
mv "doc/${PN}rc.man" "doc/${PN}rc.5" || die
doman "doc/${PN}.1" "doc/${PN}rc.5"
einstalldocs
}

pkg_postinst() {
ewarn "Note this part from man page: Security warning! Any exec command"
ewarn "that uses the 'edit' flag will be a security hole. The user need"
ewarn "only to enter text with a ';' in it, and they can run an"
ewarn "arbitrary command after the semicolon!"
}

0 comments on commit decdcc3

Please sign in to comment.