forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/gdbus-codegen: Version bump to 2.72.0
Signed-off-by: Matt Turner <[email protected]>
- Loading branch information
Showing
2 changed files
with
73 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST glib-2.70.4.tar.xz 4824296 BLAKE2B 10e472672bfa20cadad01a9c22d01f2363c3033a234f4abe939c30a86e22621ffe9f8bec8031f43b18cc8c07a1ddfa05631979641d8dab88ae7b42345b2a3cde SHA512 e0fa19ef7c2ee48d94fb15074e4e58ecd23b288cfa7bb92ca72d3e337dade80c675595f05b26c10d351a0167f6b273656aef3686d44708121a8861b16b7635c0 | ||
DIST glib-2.72.0.tar.xz 4879172 BLAKE2B 0bff92ac749ff2f39bffb0583e00f3556e04d5fcbcf9fa81fe91f6aa9771490c1732ac451bd685dca18e73bffa10c20ad418f1253ba0d0cc8b01c471cf429eee SHA512 351ff025d26348112584bed2c1052427150a8a2f8642c813dae1583fb105184528ad20e264cdf44bbca658a26c280e36acd0e642add112d29edc1b25dfc94fad |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
GNOME_ORG_MODULE="glib" | ||
PYTHON_COMPAT=( python3_{8..10} ) | ||
PYTHON_REQ_USE="xml" | ||
DISTUTILS_SINGLE_IMPL=1 | ||
DISTUTILS_USE_SETUPTOOLS=no | ||
|
||
inherit gnome.org distutils-r1 | ||
|
||
DESCRIPTION="GDBus code and documentation generator" | ||
HOMEPAGE="https://www.gtk.org/" | ||
|
||
LICENSE="LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos" | ||
|
||
RDEPEND="${PYTHON_DEPS}" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND=" | ||
dev-libs/libxslt | ||
app-text/docbook-xsl-stylesheets | ||
" | ||
|
||
S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen" | ||
|
||
python_prepare_all() { | ||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.56.1-sitedir.patch" | ||
) | ||
distutils-r1_python_prepare_all | ||
|
||
local MAJOR_VERSION=$(ver_cut 1) | ||
local MINOR_VERSION=$(ver_cut 2) | ||
sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die | ||
sed -e "s:@VERSION@:${PV}:" \ | ||
-e "s:@MAJOR_VERSION@:${MAJOR_VERSION}:" \ | ||
-e "s:@MINOR_VERSION@:${MINOR_VERSION}:" config.py.in > config.py || die | ||
cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed" | ||
sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed" | ||
} | ||
|
||
do_xsltproc_command() { | ||
# Taken from meson.build for manual manpage building - keep in sync (also copied to dev-util/glib-utils) | ||
xsltproc \ | ||
--nonet \ | ||
--stringparam man.output.quietly 1 \ | ||
--stringparam funcsynopsis.style ansi \ | ||
--stringparam man.th.extra1.suppress 1 \ | ||
--stringparam man.authors.section.enabled 0 \ | ||
--stringparam man.copyright.section.enabled 0 \ | ||
-o "${2}" \ | ||
http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl \ | ||
"${1}" || die "manpage generation failed" | ||
} | ||
|
||
src_compile() { | ||
distutils-r1_src_compile | ||
do_xsltproc_command "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.xml" "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1" | ||
} | ||
|
||
src_test() { | ||
einfo "Skipping tests. This package is tested by dev-libs/glib" | ||
einfo "when merged with FEATURES=test" | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all # no-op, but prevents QA warning | ||
doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1" | ||
} |