Skip to content

Commit

Permalink
sci-electronics/kicad: fix build error with libgit2-1.8.0
Browse files Browse the repository at this point in the history
  • Loading branch information
vowstar authored and dlan17 committed Mar 27, 2024
1 parent dade4c3 commit ded5389
Show file tree
Hide file tree
Showing 3 changed files with 44 additions and 0 deletions.
36 changes: 36 additions & 0 deletions sci-electronics/kicad/files/kicad-8.0.1-libgit2.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
From: Huang Rui <[email protected]>
Date: Fri, 22 Mar 2024 18:18:40 +0800
Subject: [PATCH] libgit2-1.8.0 compatibility: adjusted parent pointer type

- Adjusted parent pointer type in git_commit_create call for compatibility
with libgit2 1.8.0 and above.
- Included preprocessor checks to maintain support for versions older than
1.8.0.
- Ensures consistent function behavior across different libgit2 versions.

Fixes https://gitlab.com/kicad/code/kicad/-/issues/17536
Signed-off-by: Huang Rui <[email protected]>
---
kicad/project_tree_pane.cpp | 7 +++++++
1 file changed, 7 insertions(+)

--- a/kicad/project_tree_pane.cpp
+++ b/kicad/project_tree_pane.cpp
@@ -2233,7 +2233,14 @@ void PROJECT_TREE_PANE::onGitCommit( wxCommandEvent& aEvent )
}

git_oid oid;
+ // Check if the libgit2 library version is 1.8.0 or higher
+#if ( LIBGIT2_VER_MAJOR > 1 ) || ( LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR >= 8 )
+ // For libgit2 version 1.8.0 and above
+ git_commit* const parents[1] = { parent };
+#else
+ // For libgit2 versions older than 1.8.0
const git_commit* parents[1] = { parent };
+#endif

if( git_commit_create( &oid, repo, "HEAD", author, author, nullptr, commit_msg.mb_str(), tree,
1, parents ) != 0 )
--
2.44.0

4 changes: 4 additions & 0 deletions sci-electronics/kicad/kicad-8.0.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -81,6 +81,10 @@ fi

CHECKREQS_DISK_BUILD="1500M"

PATCHES=(
"${FILESDIR}"/${PN}-8.0.1-libgit2.patch
)

pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp

Expand Down
4 changes: 4 additions & 0 deletions sci-electronics/kicad/kicad-8.0.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -81,6 +81,10 @@ fi

CHECKREQS_DISK_BUILD="1500M"

PATCHES=(
"${FILESDIR}"/${PN}-8.0.1-libgit2.patch
)

pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp

Expand Down

0 comments on commit ded5389

Please sign in to comment.