Skip to content

Commit

Permalink
dev-python/pikepdf: Bump to 2.11.3
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 28, 2021
1 parent 73a59d2 commit defe1ab
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pikepdf/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST pikepdf-2.10.0.tar.gz 2376794 BLAKE2B c9f85ddec15a7eaef2ed3c43221196d957dc5
DIST pikepdf-2.11.0.tar.gz 2382340 BLAKE2B 60a09d1b7f463720af17be4b3ac70fd575f01f0e4f27b87723fddf18424d97fddc6f11de59bb1a061496f9d847babfcf3446d3bbd7445dea56106879a2ff31a3 SHA512 d55c10799667a142ed651ab36de01011abad0ae95c3dc267871147deb458e0930aba6fd5c3a20487641f2d8fa60d7b15f6ba40cbb2370bc13ef418ce3b300233
DIST pikepdf-2.11.1.tar.gz 2382829 BLAKE2B 97a3cd65c22de0e7e3ab3099a3f51993367ec7b7fe5353d0cad0f68e309df1a3c0aedf9e391cced16bd3c11e5353dfce464632c1ac890b2cd412b0e1f84e71b7 SHA512 26589155b4380cfd0a97a6eb3c130a1b71535f182f8cac0a19f0ea8b1ff749bb58dad4a5f881d27f404a6b20db9581d3915323ed9739704f8e52e51a1b5ecb16
DIST pikepdf-2.11.2.tar.gz 2297115 BLAKE2B c1ab1b99d13da7a52eda214d550597871f4d67553490f2c14096e6a620fa8bab6278a34b39e162de1bd0d71f781b79011468e5d045201dc936ec8eef07272657 SHA512 ff86e5c12e029978c0eb8e6bae7c5cd9a1b8e1f8eb07a6e623767ccb14ecc747493aa9eefc48be25464192e97eba5cd49c56983182f237532c4b4817b5732c28
DIST pikepdf-2.11.3.tar.gz 2298121 BLAKE2B 981c3607302ef5406bff886706b0d192943b367b753e4acbdbb36ea97a6921a24443f0204bc99b982b79260ba32b619e4a5f07b8a5b834be54feb0a6efdb950c SHA512 f9413ebf5bbb0a17c2ffeccc08262e59d47aaba60e68a7b1c2c43276c33fbe8b8363203394c850e21f1cc4883100047b966f7a8fbca6b3d5950bfda6f6918064
51 changes: 51 additions & 0 deletions dev-python/pikepdf/pikepdf-2.11.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1

MY_P=${P/_p/.post}
DESCRIPTION="Python library to work with pdf files based on qpdf"
HOMEPAGE="https://pypi.org/project/pikepdf/ https://github.com/pikepdf/pikepdf"
SRC_URI="
https://github.com/${PN}/${PN}/archive/v${PV/_p/.post}.tar.gz
-> ${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND="app-text/qpdf:0="
RDEPEND="${DEPEND}
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]"
BDEPEND="
>=dev-python/pybind11-2.6.0[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-4.1[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
test? (
>=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
>=dev-python/hypothesis-5[${PYTHON_USEDEP}]
>=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
>=dev-python/psutil-5[${PYTHON_USEDEP}]
>=dev-python/pytest-6[${PYTHON_USEDEP}]
>=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
>=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
)"

#distutils_enable_sphinx docs \
# dev-python/ipython \
# dev-python/matplotlib \
# dev-python/sphinx_rtd_theme
distutils_enable_tests pytest

src_prepare() {
sed -i -e '/wheel/d' setup.py || die
sed -i -e '/-n auto/d' setup.cfg || die
distutils-r1_src_prepare
}

0 comments on commit defe1ab

Please sign in to comment.