Skip to content

Commit

Permalink
app-emulation/fuse: bump to version 1.5.2
Browse files Browse the repository at this point in the history
Closes: gentoo#7770
  • Loading branch information
atomsymbol-notifications authored and a17r committed Apr 5, 2018
1 parent bf0386b commit df1dc8d
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/fuse/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST fuse-1.5.0.tar.gz 1619748 BLAKE2B 6ffbea1c7a6572f2cdd3d293a438f6e37da2eadf299396358bed2e65db3aa9720333b62b28b4f0064ec5434c99a6a0b790737230f8ec0c01f96e50f594305bd1 SHA512 c13fdef6b23377e7d2b53e7f5b2db01447d12eafc0b9114fd8b83cd5058964a655a720810ab7dc6a6e1a1d9a33ffc787b5e46bf54df1259f4ba0ff78c3189421
DIST fuse-1.5.1.tar.gz 1623081 BLAKE2B 4b6cf747d15bc2d33a0baba88254a08187e8a615564236835da19d32f9afb312d5a5c90ac07a88d904019626b153546ecd8cd09b88fa16731af94ea54cd0e346 SHA512 d5f5b8a0e61f298a955450de208b29f8ab4fc0133c5c58e596f36f3834c088c946e19d7437dd1a6e73a89d32dcaf6ca9ce0fed8ec310c37aa6a6568be482abe4
DIST fuse-1.5.2.tar.gz 1626746 BLAKE2B 38236b9457e975fe227e2a19ed0fb80cac022fbb0bd8fcb1e51666103c4abe8960b1bd166fc1d12ab4e0f32954f7c3f59625d57d456313f75ca023bf51477e0b SHA512 45507834eb70d1e74c8f58017f4ae0bb54e2560456eeadfa8b6888a1c79e9c9443cccb7ae9733b96a895f94040be820c57a7d698115c2f483e64ebc4fd734268
63 changes: 63 additions & 0 deletions app-emulation/fuse/fuse-1.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
HOMEPAGE="http://fuse-emulator.sourceforge.net"
SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"

# Only one UI back-end can be enabled at a time
REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"

RDEPEND=">=app-emulation/libspectrum-1.4.1
alsa? ( media-libs/alsa-lib )
ao? ( media-libs/libao )
backend-sdl? ( media-libs/libsdl )
backend-svga? ( media-libs/svgalib )
backend-X? ( x11-libs/libX11 x11-libs/libXext )
!backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
dev-libs/glib:2
gpm? ( sys-libs/gpm )
joystick? ( media-libs/libjsw )
png? ( media-libs/libpng:0= sys-libs/zlib )
xml? ( dev-libs/libxml2:2 )"
DEPEND="${RDEPEND}
backend-fbcon? ( virtual/linux-sources )
dev-lang/perl
virtual/pkgconfig"

DOCS=( AUTHORS ChangeLog README THANKS )

src_configure() {
local myconf=(
--without-win32
$(use_with alsa)
$(use_with ao libao)
$(use_with gpm)
$(use_with joystick)
$(use_enable joystick ui-joystick)
$(use_enable memlimit smallmem)
$(use_with png)
$(use_with xml libxml2)
)

if use backend-sdl; then
myconf+=("--with-sdl")
elif use backend-X; then
myconf+=("--without-gtk")
elif use backend-svga; then
myconf+=("--with-svgalib")
elif use backend-fbcon; then
myconf+=("--with-fb")
else
myconf+=("--with-gtk")
fi

econf "${myconf[@]}"
}

0 comments on commit df1dc8d

Please sign in to comment.