forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/wstool: initial import. ebuild by me.
Package-Manager: portage-2.2.20.1
- Loading branch information
Showing
5 changed files
with
152 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST wstool-0.1.10.tar.gz 73404 SHA256 2810f7f384b45bc653e006e0d473ed66a3ba88e237792a92955bc61fcef61b7c SHA512 8b5924844e8ff0ddcce3302b550493a9bbe525c7c7d7f5a23e49d4734649f50893ca0f2e5dbd05b20ee73d31666d61a4c3035e7d30e6053bfe8ff5c6aa9aafde WHIRLPOOL b9a6399e0dfb894685b7ed83210fe2920bdcfb2a426684829c65fec33b3963eb6cde3f7c35f9f16194306731bb366ba54ce48ba10805ff70c7eaf0a094d7f15c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
Index: wstool-0.1.10/setup.py | ||
=================================================================== | ||
--- wstool-0.1.10.orig/setup.py | ||
+++ wstool-0.1.10/setup.py | ||
@@ -23,15 +23,9 @@ def get_version(): | ||
def _resolve_prefix(prefix, type): | ||
osx_system_prefix = '/System/Library/Frameworks/Python.framework/Versions' | ||
if type == 'man': | ||
- if prefix == '/usr': | ||
- return '/usr/share' | ||
- if sys.prefix.startswith(osx_system_prefix): | ||
- return '/usr/share' | ||
+ return os.path.join(prefix, 'share') | ||
elif type == 'bash_comp': | ||
- if prefix == '/usr': | ||
- return '/' | ||
- if sys.prefix.startswith(osx_system_prefix): | ||
- return '/' | ||
+ return os.path.join(prefix, '../') | ||
elif type == 'zsh_comp': | ||
if sys.prefix.startswith(osx_system_prefix): | ||
return '/usr' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<herd>ros</herd> | ||
</pkgmetadata> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 1999-2014 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python{2_7,3_3,3_4} ) | ||
|
||
SCM="" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
SCM="git-r3" | ||
EGIT_REPO_URI="https://github.com/vcstools/wstool" | ||
fi | ||
|
||
inherit ${SCM} distutils-r1 | ||
|
||
DESCRIPTION="Commands to manage several local SCM repositories for ROS" | ||
HOMEPAGE="http://wiki.ros.org/wstool" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
SRC_URI="" | ||
KEYWORDS="" | ||
else | ||
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz | ||
http://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz | ||
" | ||
KEYWORDS="~amd64 ~arm" | ||
fi | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
dev-python/vcstools[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-python/sphinx | ||
test? ( | ||
dev-python/nose[${PYTHON_USEDEP}] | ||
dev-python/coverage[${PYTHON_USEDEP}] | ||
dev-vcs/git | ||
dev-vcs/bzr | ||
dev-vcs/mercurial | ||
dev-vcs/subversion | ||
) | ||
" | ||
|
||
PATCHES=( "${FILESDIR}/prefix.patch" ) | ||
DISTUTILS_IN_SOURCE_BUILD="yes" | ||
|
||
python_test() { | ||
# From travis.yml | ||
# Set git config to silence some stuff in the tests | ||
git config --global user.email "[email protected]" | ||
git config --global user.name "Foo Bar" | ||
# Set the hg user | ||
echo -e "[ui]\nusername = Your Name <[email protected]>" >> ~/.hgrc | ||
# Set the bzr user | ||
bzr whoami "Your Name <[email protected]>" | ||
# command to run tests | ||
nosetests --with-coverage --cover-package=wstool || die | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 1999-2014 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python{2_7,3_3,3_4} ) | ||
|
||
SCM="" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
SCM="git-r3" | ||
EGIT_REPO_URI="https://github.com/vcstools/wstool" | ||
fi | ||
|
||
inherit ${SCM} distutils-r1 | ||
|
||
DESCRIPTION="Commands to manage several local SCM repositories for ROS" | ||
HOMEPAGE="http://wiki.ros.org/wstool" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
SRC_URI="" | ||
KEYWORDS="" | ||
else | ||
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz | ||
http://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz | ||
" | ||
KEYWORDS="~amd64 ~arm" | ||
fi | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
dev-python/vcstools[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-python/sphinx | ||
test? ( | ||
dev-python/nose[${PYTHON_USEDEP}] | ||
dev-python/coverage[${PYTHON_USEDEP}] | ||
dev-vcs/git | ||
dev-vcs/bzr | ||
dev-vcs/mercurial | ||
dev-vcs/subversion | ||
) | ||
" | ||
|
||
PATCHES=( "${FILESDIR}/prefix.patch" ) | ||
DISTUTILS_IN_SOURCE_BUILD="yes" | ||
|
||
python_test() { | ||
# From travis.yml | ||
# Set git config to silence some stuff in the tests | ||
git config --global user.email "[email protected]" | ||
git config --global user.name "Foo Bar" | ||
# Set the hg user | ||
echo -e "[ui]\nusername = Your Name <[email protected]>" >> ~/.hgrc | ||
# Set the bzr user | ||
bzr whoami "Your Name <[email protected]>" | ||
# command to run tests | ||
nosetests --with-coverage --cover-package=wstool || die | ||
} |