forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
2 changed files
with
168 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST glance-11.0.0.tar.gz 1565001 SHA256 35abd3af08b97a56556fdd1a68c61fcfa99ead6354f746f8f7cdc4517e90084e SHA512 33ceab2c7f52f5ce92b2bb33732697a85e4bdf552ca9d08bb7b21430ef942b545614de9b834bdd455b0544474217675731b77cded7218c56ef44274c29a97f47 WHIRLPOOL a256b0525f8a42e588a1d7cce4a6add919b9bd31752560dc7664814178fb4b3c952bfd7ec5d0d40932dc39c380c866561f9cb5ed1383482d4320f5417179c028 | ||
DIST glance-2015.1.1.tar.gz 1102359 SHA256 5c5714264c4ad9c3d178b983899b54f69f138505ddd77e13141dc5f3d1598ebe SHA512 d9233b78174ec0f84b317abf7d26153a7e3ead25b4ebc31acbe5d0806b6877da5875de52ee0742dcbdd5fd3d23cb0240208f6fd57fa59cc403ad228ac85f2a0f WHIRLPOOL 69a4cd27b4ac57a47523ceb4b899bbbb3569e7af2bb8f3e64373d98b7c72450bd587c6da96d33903dcbf44e02f89ea563d116d9d2dc90d4a0f472eca89963a87 | ||
DIST glance-2015.1.2.tar.gz 1108933 SHA256 e46bc6648a74a643cef3825dcd44c7e275ed3385b96cab83ef50c4c514932541 SHA512 0f8b8dbc3c507a47ad0873f35ec2212903d7e419b61c0298f77661f89a9718e3604786d52976860c78841fe0a94ad8fc1fe99514183d2b29ed414efe448e590a WHIRLPOOL df8ba6586b2f71c5d7ecb252b80e6c6de6f08df1029576fc8b2fb2a68633f5ce76de1334949af955e85c39e9f1df25b2f8763837ef8efa228b29559dc34be863 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,167 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python2_7 python3_4 ) | ||
|
||
inherit distutils-r1 user | ||
|
||
DESCRIPTION="Provides services for discovering, registering, and retrieving | ||
virtual machine images" | ||
HOMEPAGE="https://launchpad.net/glance" | ||
SRC_URI="https://launchpad.net/${PN}/liberty/${PV}/+download/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc mysql postgres +sqlite +swift test" | ||
REQUIRED_USE="|| ( mysql postgres sqlite )" | ||
|
||
CDEPEND=">=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND} | ||
test? ( | ||
${RDEPEND} | ||
>=dev-python/Babel-1.3[${PYTHON_USEDEP}] | ||
>=dev-python/coverage-3.6[${PYTHON_USEDEP}] | ||
>=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}] | ||
>=dev-python/mox3-0.7.0[${PYTHON_USEDEP}] | ||
>=dev-python/mock-1.2[${PYTHON_USEDEP}] | ||
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] | ||
!~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}] | ||
<dev-python/sphinx-1.3[${PYTHON_USEDEP}] | ||
>=dev-python/requests-2.5.2[${PYTHON_USEDEP}] | ||
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}] | ||
>=dev-python/testresources-0.2.4[${PYTHON_USEDEP}] | ||
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}] | ||
>=dev-python/testtools-1.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/psutil-1.1.1[${PYTHON_USEDEP}] | ||
<dev-python/psutil-2.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/pymysql-0.6.2[${PYTHON_USEDEP}] | ||
>=dev-python/psycopg-2.5[${PYTHON_USEDEP}] | ||
>=dev-python/pysendfile-2.0.0[${PYTHON_USEDEP}] | ||
dev-python/qpid-python[$(python_gen_usedep 'python2_7')] | ||
>=dev-python/pyxattr-0.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}] | ||
)" | ||
|
||
#note to self, wsgiref is a python builtin, no need to package it | ||
#>=dev-python/wsgiref-0.1.2[${PYTHON_USEDEP}] | ||
|
||
RDEPEND=" | ||
${CDEPEND} | ||
sqlite? ( | ||
>=dev-python/sqlalchemy-0.9.9[sqlite,${PYTHON_USEDEP}] | ||
<dev-python/sqlalchemy-1.1.0[sqlite,${PYTHON_USEDEP}] | ||
) | ||
mysql? ( | ||
dev-python/mysql-python | ||
>=dev-python/sqlalchemy-0.9.9[${PYTHON_USEDEP}] | ||
<dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}] | ||
) | ||
postgres? ( | ||
dev-python/psycopg:2[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-0.9.9[${PYTHON_USEDEP}] | ||
<dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}] | ||
) | ||
>=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}] | ||
>=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}] | ||
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}] | ||
!~dev-python/routes-2.0[${PYTHON_USEDEP}] | ||
!~dev-python/routes-2.1[$(python_gen_usedep 'python2_7')] | ||
>=dev-python/webob-1.2.3[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-migrate-0.9.6[${PYTHON_USEDEP}] | ||
>=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}] | ||
>=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] | ||
>=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-context-0.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-service-0.7.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/futurist-0.1.2[${PYTHON_USEDEP}] | ||
>=dev-python/taskflow-1.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/keystonemiddleware-2.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/WSME-0.7[${PYTHON_USEDEP}] | ||
dev-python/paste[${PYTHON_USEDEP}] | ||
>=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}] | ||
<dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}] | ||
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-db-2.4.1[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-log-1.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-messaging-1.16.0[${PYTHON_USEDEP}] | ||
!~dev-python/oslo-messaging-1.17.0[${PYTHON_USEDEP}] | ||
!~dev-python/oslo-messaging-1.17.1[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-middleware-2.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-policy-0.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/retrying-1.2.3[${PYTHON_USEDEP}] | ||
!~dev-python/retrying-1.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/osprofiler-0.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/glance_store-0.7.1[${PYTHON_USEDEP}] | ||
!~dev-python/glance_store-0.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/semantic_version-2.3.1[${PYTHON_USEDEP}] | ||
>=dev-python/castellan-0.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/cryptography-1.0[${PYTHON_USEDEP}] | ||
" | ||
|
||
PATCHES=( | ||
) | ||
|
||
pkg_setup() { | ||
enewgroup glance | ||
enewuser glance -1 -1 /var/lib/glance glance | ||
} | ||
|
||
python_prepare_all() { | ||
sed -i '/xattr/d' test-requirements.txt || die | ||
sed -i '/pysendfile/d' test-requirements.txt || die | ||
sed -i '/^hacking/d' test-requirements.txt || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_compile_all() { | ||
use doc && "${PYTHON}" setup.py build_sphinx | ||
} | ||
|
||
python_test() { | ||
# https://bugs.launchpad.net/glance/+bug/1251105 | ||
# https://bugs.launchpad.net/glance/+bug/1242501 | ||
testr init | ||
testr run --parallel || die "failed testsuite under python2.7" | ||
} | ||
|
||
python_install() { | ||
distutils-r1_python_install | ||
|
||
for svc in api registry scrubber; do | ||
newinitd "${FILESDIR}/glance.initd" glance-${svc} | ||
done | ||
|
||
diropts -m 0750 -o glance -g glance | ||
dodir /var/log/glance /var/lib/glance/images /var/lib/glance/scrubber | ||
keepdir /etc/glance | ||
keepdir /var/log/glance | ||
keepdir /var/lib/glance/images | ||
keepdir /var/lib/glance/scrubber | ||
|
||
insinto /etc/glance | ||
insopts -m 0640 -o glance -g glance | ||
doins etc/*.ini | ||
doins etc/*.conf | ||
doins etc/*.sample | ||
} | ||
|
||
python_install_all() { | ||
use doc && local HTML_DOCS=( doc/build/html/. ) | ||
distutils-r1_python_install_all | ||
} |