forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-misc/dfshow: version bump to 0.8.2 beta
Closes: https://bugs.gentoo.org/696430 Signed-off-by: Angelos Kouratzinos <[email protected]> Package-Manager: Portage-2.3.76, Repoman-2.3.16 Closes: gentoo#13193 Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
1 parent
8c5cb28
commit df68f09
Showing
2 changed files
with
32 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST dfshow-0.8.0_beta.tar.gz 97301 BLAKE2B fa98ef37d23ef39e8512eed410d4a3a9e45aee87d9ee1c35230a9bea47af61c936091117c7232c195cd661ba61b09376ba1db4167bf8388323311f2a2fa7b6a6 SHA512 79cd82916521500d5f6f7ab00770af084f1a52069fe5625b7336f3081084ece6d2773be7f5480c444455ad3151e603d937b3feb279a18502c435c1a05d6d1446 | ||
DIST dfshow-0.8.2_beta.tar.gz 97733 BLAKE2B 99790b6901760a5e4adc7942fa84d11fb9d5e2f4e60a5d4abc2ce8fed0e86ab5f3def67c2f567b1ca54f1ecdbbe04522d4a75d69694b0ad213a69d86d49514e4 SHA512 1fca7f72c0200df13ac6e640314f9ad94ea3b88eb62a18a606f3a06a02252107f59747fbd404891fff5898b3796650023827ca59ceb690a0aa45e3c0a8bca749 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit autotools | ||
|
||
MY_PV="${PV//_beta/-beta}" | ||
|
||
DESCRIPTION="DF-SHOW is a Unix-like rewrite of some of the applications from DF-EDIT" | ||
HOMEPAGE="https://github.com/roberthawdon/dfshow" | ||
SRC_URI="https://github.com/roberthawdon/dfshow/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
S="${WORKDIR}/${PN}-${MY_PV}" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
DEPEND="dev-libs/libconfig | ||
sys-libs/ncurses:0= | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
sed -i 's/LDADD = -lncursesw -lm -lconfig/LDADD = -lncursesw -lm -lconfig -ltinfow/' Makefile.am || | ||
die "sed in Makefile.am failed" | ||
eautoreconf | ||
eautomake --add-missing | ||
} |