Skip to content

Commit

Permalink
dev-python/jenkins-webapi: version bump to 0.5.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
hydrapolic committed Dec 28, 2015
1 parent a63c7b7 commit df82b18
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/jenkins-webapi/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST jenkins-1.596.3.war 68396864 SHA256 85409f83b81ba90094ecc9e3ea6df0920ecfb3064b731a6a5c9b397eda18b47f SHA512 8652d4d18e3258208fe190c4a6aa5586faa66f690d7d7f7369c5490a587e3ec5e074dc22f2c8caedf5e5335f5b8f511717b2d6eb667a61e9948a703bf80310fe WHIRLPOOL ac6401ebe42a42495dc148d71a61daf49905292e6cbcbb5d8e41f520a01c8f1f783fd75baf908a3e99fbd9f25483366a3a5a005fa04b5843550c8e211f4d8e2d
DIST jenkins-webapi-0.3.2.tar.gz 14831 SHA256 8f67d86c1f95edb79928af9b3b7c60ef9a63bfbfd19b6fe0a892ef4039f25500 SHA512 2ac59c90bba48406cc9fe5595505d5836eab1147869fbc8c06577767891d37904bffa5516316af0cb25f7f9193ae5277c0219ecc9daf5e0efa093fd449d1f4f0 WHIRLPOOL e4562a1857d7c526aec8c5ecc35f6a0644c48bf69fad4bdfef20f0708fdc0dfb5595c428acdc03e1df02c3d21669d47c89e0f3a99c1ee09a9741f9e21ab83b48
DIST jenkins-webapi-0.4.0.tar.gz 16149 SHA256 7515b1e0503e07d50088e32205873146eda3b1132d8a6508e28f4e935c41e8b2 SHA512 ae40366e6fb6414391287ffa42ec92fba1971f070ac718d521c5b10f6e47d14ceea15a8c71f559380356530fdb2f826e08a6c611813b407dad73dab39fcddfeb WHIRLPOOL 30abf44c7d1ec6884baa3481c9d2f234f46f812d5ee6a8d9e49de8bc367ffef9c58f7653dcd30c24a308372cb8f6211e51f40e441e17f9ef15abd222de5d775b
DIST jenkins-webapi-0.5.0.tar.gz 78813 SHA256 d3a730761bd5164683e1bfff53332b0bf056393e0660769ba8e09df6d555304d SHA512 dde91231e6fe6713eb5953efa038d44a820b51968c2b0591e5dd064c7a35c7dab4d1780370dc97a0a671b3d3cb7d8a48e571c7c0af4f0d5f8a65430c8c074eb3 WHIRLPOOL 2110593ae171efd30f4f0fd407d8bc526e85ce53a3670b5f4c09c73aa8a880cdcc314091104e1684485899a65227a2da18fba7c358a7d11a80f0de5ac99a26c7
60 changes: 60 additions & 0 deletions dev-python/jenkins-webapi/jenkins-webapi-0.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )

inherit distutils-r1

JENKINS_VERSION="1.596.3"

DESCRIPTION="Module for interacting with the Jenkins CI server"
HOMEPAGE="https://github.com/gvalkov/jenkins-webapi"
SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? ( http://mirrors.jenkins-ci.org/war-stable/${JENKINS_VERSION}/jenkins.war -> jenkins-${JENKINS_VERSION}.war )"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

RDEPEND=">=dev-python/requests-2.7.0[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
net-analyzer/netcat
net-misc/curl
app-arch/unzip
>=virtual/jre-1.7.0
>=dev-python/pytest-2.6.3[${PYTHON_USEDEP}]
>=dev-python/termcolor-1.1.0[${PYTHON_USEDEP}]
>=dev-python/pytest-cov-1.8.0[${PYTHON_USEDEP}]
>=dev-python/httmock-1.2.2[${PYTHON_USEDEP}] )
doc? (
>=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
>=dev-python/alabaster-0.6.1[${PYTHON_USEDEP}] )"

src_unpack() {
unpack ${P}.tar.gz

if use test; then
# tests fail with jenkins 1.6x
# https://github.com/gvalkov/jenkins-webapi/issues/14
mkdir -p "${P}/tests/tmp/latest"
cp "${DISTDIR}/jenkins-${JENKINS_VERSION}.war" "${P}/tests/tmp/latest/jenkins.war"
fi
}

python_test() {
emake test
}

python_compile_all() {
use doc && emake -C docs html
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit df82b18

Please sign in to comment.