Skip to content

Commit

Permalink
dev-vcs/git-lfs: update 9999
Browse files Browse the repository at this point in the history
Signed-off-by: Jeffrey Lin <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Signed-off-by: Ettore Di Giacinto <[email protected]>
  • Loading branch information
anaveragehuman authored and mudler committed Sep 23, 2018
1 parent f9201cc commit df87299
Showing 1 changed file with 7 additions and 15 deletions.
22 changes: 7 additions & 15 deletions dev-vcs/git-lfs/git-lfs-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,16 +1,16 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGO_PN="github.com/git-lfs/${PN}"
EGO_PN="github.com/${PN}/${PN}"

if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
inherit golang-build golang-vcs
else
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
inherit golang-vcs-snapshot
inherit golang-build golang-vcs-snapshot
fi

DESCRIPTION="command line extension and specification for managing large files with Git"
Expand All @@ -20,28 +20,20 @@ LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
SLOT="0"
IUSE="+doc"

# since version 2.0.2 git-lfs uses time.Until that was introduced in golang >=1.8
# https://github.com/golang/go/commit/67ea710792eabdae1182e2bf4845f512136cccce
DEPEND=">=dev-lang/go-1.8.1:=
doc? ( app-text/ronn )"

DEPEND="doc? ( app-text/ronn )"
RDEPEND="dev-vcs/git"

S="${WORKDIR}/${P}/src/${EGO_PN}"

src_compile() {
# can't use golang-build_src_compile for go generate
# and others steps executed by build.go
GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
go run script/*.go -cmd build || die "build failed"
golang-build_src_compile

if use doc; then
ronn docs/man/*.ronn || die "man building failed"
fi
}

src_install() {
dobin bin/git-lfs

dobin git-lfs
use doc && doman docs/man/*.1
}

0 comments on commit df87299

Please sign in to comment.