Skip to content

Commit

Permalink
app-arch/dpkg: Version 1.19.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Jan 25, 2019
1 parent 0e3f503 commit df87d2f
Show file tree
Hide file tree
Showing 2 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/dpkg/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST dpkg_1.19.0.5.tar.xz 4557428 BLAKE2B 99c31705bfad1cfa024366c788264f4e747a7143f87c581730797975303c1054003e41fd65ecf80df1dc053ba87c0e8449ec574ddcb158228b41ae57a23db18f SHA512 60d7198ffe6ea759c30ad82143b3107d41ce59224b853cb5a7beb79af0de6ba6a69414c365e6b3555a0a9c60e3cf9b543a3a448d80a734be38ccecb77ae963a9
DIST dpkg_1.19.2.tar.xz 4607868 BLAKE2B 4c191fb3dbe64bb3a515dadbb5f81bb32a0ae3b7267603978f7aee34f6baa02bacb818600759fe4bac0c3470ce2d6409c778a408833af796fe65f27fe910713f SHA512 244a6ef6aad935aee649503d6ce3238e34f4fae3f57ca79e99c1890140d913c29255bc9d0e90b50e96d2cf44ab0e44d6c3675a7bed306213fe5fe31710324cf7
DIST dpkg_1.19.3.tar.xz 4644312 BLAKE2B 42a906c5603cc36e53591d0f33c54930fcb0f0848b53cd1908ff5c018f3a4ab823c71408982247f61e0810f223124853fc181994853f39786563ddbf6228ba54 SHA512 6a53b68bc51b9c700618ad379d4f314f0058479d068ae7bb842388e57b6393f87c4990c1d71ed085e76314d0e29295a5344a0ea78f62ef8657df2d53124bbe8f
DIST dpkg_1.19.4.tar.xz 4645784 BLAKE2B 2c8a76686ece182b7c87b1fcf3ed81a7bbc9616475e2003847fe9a35b574a814873b183ab5984bb66f725a8e92f3a000bf9250f3f9d1e6b338f6620b3011a067 SHA512 e07538bac0645bf7d49b30f4fb3b59602f304f346437faaea6b4bffbeb59f05471c5e834d6c7e98c869e5466a66c39a0d9e9c05da1cc52a10b5fc60875be218e
91 changes: 91 additions & 0 deletions app-arch/dpkg/dpkg-1.19.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils multilib autotools toolchain-funcs

DESCRIPTION="Package maintenance system for Debian"
HOMEPAGE="https://packages.qa.debian.org/dpkg"
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
IUSE="+bzip2 libmd +lzma nls selinux static-libs test unicode +update-alternatives +zlib"

RDEPEND="
>=dev-lang/perl-5.14.2:=
bzip2? ( app-arch/bzip2 )
libmd? ( app-crypt/libmd )
lzma? ( app-arch/xz-utils )
nls? ( virtual/libintl )
selinux? ( sys-libs/libselinux )
zlib? ( >=sys-libs/zlib-1.1.4 )
"
DEPEND="
${RDEPEND}
app-arch/xz-utils
sys-devel/flex
virtual/pkgconfig
nls? (
app-text/po4a
>=sys-devel/gettext-0.18.2
)
test? (
dev-perl/IO-String
dev-perl/Test-Pod
virtual/perl-Test-Harness
)
"
DOCS=(
ChangeLog
THANKS
TODO
)
PATCHES=(
"${FILESDIR}"/${PN}-1.18.12-dpkg_buildpackage-test.patch
"${FILESDIR}"/${PN}-1.18.12-flags.patch
"${FILESDIR}"/${PN}-1.18.12-rsyncable.patch
)

src_prepare() {
use nls && strip-linguas -i po

default

eautoreconf
}

src_configure() {
tc-export CC
econf \
$(use_enable nls) \
$(use_enable static-libs static) \
$(use_enable unicode) \
$(use_enable update-alternatives) \
$(use_with bzip2 libbz2) \
$(use_with libmd) \
$(use_with lzma liblzma) \
$(use_with selinux libselinux) \
$(use_with zlib libz) \
--disable-compiler-warnings \
--disable-dselect \
--disable-silent-rules \
--disable-start-stop-daemon \
--localstatedir="${EPREFIX}"/var
}

src_compile() {
emake AR=$(tc-getAR)
}

src_install() {
default

keepdir \
/usr/$(get_libdir)/db/methods/{mnt,floppy,disk} \
/var/lib/dpkg/{alternatives,info,parts,updates}
# /usr/$(get_libdir)/db/{alternatives,info,parts,updates} \

prune_libtool_files
}

0 comments on commit df87d2f

Please sign in to comment.