Skip to content

Commit

Permalink
dev-php/xdebug-client: bump to v2.9.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.7, Repoman-3.0.1
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Sep 17, 2020
1 parent 7bd54e5 commit df93d52
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/xdebug-client/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST xdebug-2.9.4.tar.gz 434622 BLAKE2B bd0d0c6a46867ffba88693f142346d11b5abfab3254c549b74ff9169536c42903b1fb1cb94c3344060590b63e287878ea05c6ef7ad8343234bada3857e0dbe75 SHA512 cf19fb9fd12c32e04c18f296694d0667dfe6e14617da932804d17526c88ab19dd2307ad43d036a8c0cb1f871a964523473879da8815f346faf83ec3b9e3952e3
DIST xdebug-2.9.5.tar.gz 434947 BLAKE2B 08fd7cc92880c9b00180d495341fc7e54998cf3c2294b824d94c3c4ed982ae5b087084b776bcc4f8f4e1aa420396c803d330bc76748cf972cccab4e3f1416d38 SHA512 2a937d08468d3a2963559a56bdf9c9aa6ede3f0ee63797aa14831bcab33a5ede65b87791171a0c794eefdfcffa65bb4d0c06b5377fe03ade65f4defa6e328c72
DIST xdebug-2.9.6.tar.gz 436208 BLAKE2B 00cfb42c41bfb44f285b97779d6ba625641fc34494465e9e791ab5458c6a608e432df0ad45c561df2f8c9aba04ab34b3a98bb5e6bfb92ace39a3ad4145f3514a SHA512 13ed07a1489ba7bc0b4e85bf56306c733e7894cea8cb442649635196606b12d92e5618ab2485e7cde4aaee2ac6752993aecd933c24fd64b5113ef619339403d2
DIST xdebug-2.9.7.tar.gz 437517 BLAKE2B 6d3cb615b6b75354e5dc993a2de9f90b5865ee1a98935c084a9d7a4e1d03cceb71278b06da1d5e47f2b4105937f6d24cb8d767c7179fa55798e61a599e173c13 SHA512 ec23f7b5b2e2b109a753e12f1cb01377db52716600fbb31ca5b9a749e9d98e0eb60942b272c25a42efcb56add016310c79eda2c7385a3e0fc18e563f2f486d1e
40 changes: 40 additions & 0 deletions dev-php/xdebug-client/xdebug-client-2.9.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"

MY_PN="xdebug"
MY_PV="${PV/_/}"
MY_PV="${MY_PV/rc/RC}"

inherit autotools

DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)"
HOMEPAGE="https://xdebug.org/"
# Using tarball from GitHub for tests
#SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
LICENSE="Xdebug"
SLOT="0"
IUSE="libedit"

S="${WORKDIR}/${MY_PN}-${MY_PV}/debugclient"

DEPEND="libedit? ( dev-libs/libedit ) net-libs/libnsl:0="
RDEPEND="${DEPEND}"

src_prepare() {
default

eautoreconf
}

src_configure() {
econf $(use_with libedit)
}

src_install() {
newbin debugclient xdebug
}

0 comments on commit df93d52

Please sign in to comment.