Skip to content

Commit

Permalink
dev-python/pytest-cov: bump to 2.10.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.10, Repoman-3.0.2
Signed-off-by: Andrey Grozin <[email protected]>
  • Loading branch information
Andrey Grozin committed Dec 1, 2020
1 parent b2e1d96 commit df94abc
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pytest-cov/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pytest-cov-2.10.1.tar.gz 56822 BLAKE2B 45eba205a2c6687882445d3554cedc04ad556854f5eac8eb0fab7fda84cdf2736b034dfdceb664293d1add153a5271403eb94585a863676ccfef9ab09727d165 SHA512 2dd575141754a417f34b414ba7e07291c273abdc63a6b7dc72d317c6ec10076b83c2ad78eeefdda7cee1fd6f56932d838602da4dd760a1c0d12095be94c22568
DIST pytest-cov-2.8.1.tar.gz 47661 BLAKE2B 590fd50b69d01a71b20982d8cdbed0698ebe24c290d791bb44c96aa1aaaf77cf1f379d565eb775864c6945facf6d271115236cb44b95e4a4c9bb7cc6fd591acf SHA512 769a17c2095dbe990df148a0105c9e3dc88ac2265ac77ac31448dab6abf6d8cc0d54f5c6ff01fd708bd38700bfea93f57d3bb702bd9bb0a708257d094b2376ec
51 changes: 51 additions & 0 deletions dev-python/pytest-cov/pytest-cov-2.10.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6..9} pypy3 )

inherit distutils-r1

DESCRIPTION="py.test plugin for coverage reporting"
HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-python/py-1.4.22[${PYTHON_USEDEP}]
>=dev-python/pytest-3.6[${PYTHON_USEDEP}]
>=dev-python/coverage-4.4[${PYTHON_USEDEP}]
"
DEPEND="
test? (
dev-python/virtualenv[${PYTHON_USEDEP}]
dev-python/fields[${PYTHON_USEDEP}]
>=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

#PATCHES=(
# # Bug 597708
# "${FILESDIR}/${PN}-2.8.1-disable-broken-tests.patch"
# "${FILESDIR}/${PN}-2.8.1-latest-setuptools.patch"
# # https://github.com/pytest-dev/pytest-cov/issues/365
# "${FILESDIR}/pytest-cov-2.8.1-python38.patch"
#)

distutils_enable_sphinx docs \
dev-python/sphinx-py3doc-enhanced-theme

python_test() {
distutils_install_for_testing
PYTHONPATH="${S}/tests:${BUILD_DIR}/lib:${PYTHONPATH}" \
PYTEST_PLUGINS=${PN/-/_} \
pytest -vv || die "Tests failed under ${EPYTHON}"
}

0 comments on commit df94abc

Please sign in to comment.