Skip to content

Commit

Permalink
sys-fs/squashfs-tools-ng: Version bump to 0.8
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Dec 31, 2019
1 parent a24d99d commit df9f196
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/squashfs-tools-ng/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST squashfs-tools-ng-0.7.tar.xz 372956 BLAKE2B 5fd0849c8cb0255ea56edc5b5cdc771363f5ca038f4306bb7d816ff26ce23cbd4f4652ef8ae497b8c9fe1ec09f9ebcfcf13aeb6b99b97db80a95018c25d4a3a6 SHA512 e53d7b64e68a40b49667b65d9fa8f12e977e8ca923c2fe9ce1e1def2745573f8607f7dee7ae6c06496489ef721c4c500ec40513ea5f6bd3ad4bb3a7796972b8e
DIST squashfs-tools-ng-0.8.tar.xz 1004616 BLAKE2B 5d347eef252886e7750da306f038494a15660350aca7b93aaf85a8411882489d8855c771e719a68b025f5c15fdc8b0d30727dde0884c5982460ff85d106fcd37 SHA512 7a533c7f9f21f717718a9ce5d775cf297c2e8edb6f121741b14692b52cbb6e3d7fe5cd59525222f7f9617440ea2adb2acec4dda3252abf3bebc689905b9fdc20
51 changes: 51 additions & 0 deletions sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="A new set of tools for working with SquashFS images"
HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi

LICENSE="LGPL-3+ tools? ( GPL-3+ )"
SLOT="0"
IUSE="lz4 lzo selinux +tools +xz zstd"

DEPEND="
sys-libs/zlib:=
lz4? ( app-arch/lz4:= )
lzo? ( dev-libs/lzo:= )
xz? ( app-arch/xz-utils:= )
selinux? ( sys-libs/libselinux:= )
zstd? ( app-arch/zstd:= )
"
RDEPEND="${DEPEND}"

src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf
}

src_configure() {
local myconf=(
--disable-static
$(use_with lz4)
$(use_with lzo)
$(use_with selinux)
$(use_with tools)
$(use_with xz)
$(use_with zstd)
)
econf "${myconf[@]}"
}

src_install() {
default
find "${D}" -name "*.la" -delete || die
}

0 comments on commit df9f196

Please sign in to comment.