Skip to content

Commit

Permalink
kde-apps/dolphin: Fix startup error message
Browse files Browse the repository at this point in the history
This is a downstream hack for now.

KDE-bug: https://bugs.kde.org/show_bug.cgi?id=435586
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed May 9, 2021
1 parent 9d37008 commit dfd9e0a
Show file tree
Hide file tree
Showing 3 changed files with 28 additions and 0 deletions.
2 changes: 2 additions & 0 deletions kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -64,6 +64,8 @@ RDEPEND="${DEPEND}

PATCHES=(
"${FILESDIR}/${P}-fix-session-restore-w-o-tabs.patch" # KDE-bug 434911
# TODO: Downstream hack, track upstream bug for better solution
"${FILESDIR}/${PN}-21.04.0-fix-no-semantic-desktop.patch" # KDE-bug 435586
)

src_configure() {
Expand Down
3 changes: 3 additions & 0 deletions kde-apps/dolphin/dolphin-21.04.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -62,6 +62,9 @@ RDEPEND="${DEPEND}
>=kde-apps/kio-extras-${PVCUT}:5
"

# TODO: Downstream hack, track upstream bug for better solution
PATCHES=( "${FILESDIR}/${P}-fix-no-semantic-desktop.patch" ) # KDE-bug 435586

src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
diff --git a/src/search/dolphinfacetswidget.cpp b/src/search/dolphinfacetswidget.cpp
index d52d146a8..9f0078631 100644
--- a/src/search/dolphinfacetswidget.cpp
+++ b/src/search/dolphinfacetswidget.cpp
@@ -7,6 +7,8 @@

#include "dolphinfacetswidget.h"

+#include <config-baloo.h>
+
#include <KLocalizedString>

#include <QComboBox>
@@ -257,7 +259,9 @@ void DolphinFacetsWidget::updateTagsSelector()
void DolphinFacetsWidget::updateTagsMenu()
{
updateTagsMenuItems({}, {});
+#ifdef HAVE_BALOO
m_tagsLister.openUrl(QUrl(QStringLiteral("tags:/")), KCoreDirLister::OpenUrlFlag::Reload);
+#endif
}

void DolphinFacetsWidget::updateTagsMenuItems(const QUrl&, const KFileItemList& items)

0 comments on commit dfd9e0a

Please sign in to comment.